Whiist Startup Error RRS feed

  • Question

  • I tried to upgrade to version 0.6 and am now getting an error when I start the WHS console.



    Code Snippet

    Could not load file or assembly 'Interop.WHSInfoIF, Version=,Culture=neutral, PublicKeyToken=null' or one of its dependencies.  The system cannot find the file specified.

    at Microsoft.HomeServer.HomeServerConsoleTab.WOLTab.HomeServerTabExtender.BuildComputerList()

    at Microsoft.HomeServer.HomeServerConsoleTab.WOLTab.HomeServerTabExtender..ctor(Int32 width, Int32 height, IConsoleServices consoleServices)


    I had Whiist 0.5.6 working perfectly on RC1.  I uninstalled 0.5.6, restarted the console and started getting this error.  I've tried reinstalling 0.5.6 and still get the error.  I tried installing 0.6 and I still get the error.  I do have the WOL (by Evangelos Hadjichristodoulou) addin, but have not had any problems until I uninstalled Whiist.


    To fix the problem I had to uninstalled WOL and then reinstall it. 


    This is not good.  I uninstall Whiist and it breaks WOL.


    Sunday, June 24, 2007 3:50 AM

All replies

  • This is a known issue when using the interop assemblies. Please see this thread for more background (and how it will be addressed in a future WHS release).

    Sunday, June 24, 2007 1:53 PM
  • mmarable,

    Update: I see EdH posted while I was typing this post.

    First, you really should have posted this error in the original thread: Whiist - Website Management Add-In

    Second, I thought Andrew fixed this error and conflict while running WOL with Whiist vs 0.6. (see the original threads).

    Please repost in the original forum and Andrew should get back to you shortly.

    Until then, I would would start from scratch. Remove WOL and Whiist>> reboot WHS>>Install Whiist>>then install WOL. Hope that helps.

    Sunday, June 24, 2007 1:57 PM
  • Hi mmarable,

    Unfortunately in earlier versions Whiist and some other Add-In's shared a common file, which after uninstalling Whiist would leave this file missing file. Uninstalling and then reinstalling WOL should fix the problem.

    Apologies for any inconvenience.

    Sunday, June 24, 2007 4:36 PM