locked
32-bit SDK for HPC Server 2008 fails --- "The procedure entry point GetProcessIdOfThread could not be located..." RRS feed

  • Question

  •   I'm wondering if anyone has run into the following with the RTM of the SDK for HPC Server 2008.  I have various 64-bit MPI apps that run fine with the 64-bit version of the new SDK.  But I wanted to do some demos under 32-bit Windows XP Pro, so I rebuilt the apps for 32-bit, installed the 32-bit SDK on the Windows XP machine, and then tried to run my apps via mpiexec:

      mpiexec -n 4 MyMPIApp.exe

    Immediately, a dialog pops up that says "The procedure entry point GetProcessIdOfThread could not be located in the dynamic link library KERNEL32.dll".  I close the dialog, and the console window then displays:

      ReadFile() failed, error 109
      Error: unable to start the local smpd manager

    I disabled the firewall, same result.  Rebooted, same result.  Installed MPI.NET and ran one of my MPI.NET apps, exactly the same error.  If I uninstall, and install the SDK for Compute Cluster Pack, the error goes away.  So something is up with the new SDK.

    Any ideas?  Thanks!
    Wednesday, October 8, 2008 7:18 PM

Answers