none
HPC Pack 2016 Installation error (in final step)

    Question

  • Failing the very last step of process "Microsoft HPC Pack 2016 Head node Application"

    Relevant info from log files (C:\windows\temp\HPCsetuplogs\HPCSetuplogs-<date>-<091226>) folder:

    chainer.txt:

    09:44:07.892 - 	The Fabric cluster is now ready for use
    09:44:13.251 - 	Execute PowerShell script: Get-Item '..\ServiceFabric\ServiceFabricSDK\ServiceFabricSDK.psm1' | Unblock-File; Import-Module '..\ServiceFabric\ServiceFabricSDK\ServiceFabricSDK.psm1'; try {Connect-ServiceFabricCluster; Publish-NewServiceFabricApplication -ApplicationPackagePath 'HpcApplicationType.sfpkg' -ApplicationParameterFilePath 'ApplicationParameters\Local.1Node.xml' -OverwriteBehavior Always} catch{$_ | Out-File 'C:\Windows\Temp\HPCSetupLogs\HPCSetupLogs-20170327-091226\ServiceFabricCluster.err' -Append; throw}
    09:47:27.583 - 	[BackgroundWorker_DoWork] Ending installation with return code 1
    09:47:27.583 - 	[InstallProgressPage] failed to do installation with error: System.InvalidOperationException: Component Microsoft HPC Pack 2016 Head Node Application cannot be installed with error code 1. Failed to create the application for HPC head node to the Service Fabric cluster.
       at Microsoft.Hpc.Setup.Chainer.InstallWizard.InstallProgressPage.BackgroundWorker_DoWork(Object sender, DoWorkEventArgs e)
       at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
       at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
    09:47:27.583 - 	[Error] Component Microsoft HPC Pack 2016 Head Node Application cannot be installed with error code 1. Failed to create the application for HPC head node to the Service Fabric cluster.
    

    servicefabriccluster.err:

    Test-ServiceFabricApplicationPackage : The BuildLayout of the application in 
    C:\Users\a-sriram\AppData\Local\Temp\TestApplicationPackage_7012726817206\uavzbdkl.vec\HpcApplicationType is invalid. 
    Config is missing for service DiagnosticsStatefulServicePkg.
    At D:\HPCPack2016\ServiceFabric\ServiceFabricSDK\Publish-NewServiceFabricApplication.ps1:117 char:38
    + ... tionSuccess = (Test-ServiceFabricApplicationPackage $AppPkgPathToUse)
    +                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Test-ServiceFabricApplicationPackage], FabricImageBuilderValidati 
       onException
        + FullyQualifiedErrorId : TestApplicationPackageErrorId,Microsoft.ServiceFabric.Powershell.TestApplicationPackage
     
    Test-ServiceFabricApplicationPackage : The BuildLayout of the application in 
    C:\Users\a-sriram\AppData\Local\Temp\TestApplicationPackage_7017058873233\s2hxr4kh.2m0\HpcApplicationType is invalid. Config is missing for service 
    ManagementStatefulServicePkg.
    At D:\HPCPack2016\ServiceFabric\ServiceFabricSDK\Publish-NewServiceFabricApplication.ps1:117 char:38
    + ... tionSuccess = (Test-ServiceFabricApplicationPackage $AppPkgPathToUse)
    +                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Test-ServiceFabricApplicationPackage], FabricImageBuilderValidationException
        + FullyQualifiedErrorId : TestApplicationPackageErrorId,Microsoft.ServiceFabric.Powershell.TestApplicationPackage
     
    

    and finally, the powershell script window that opens up has the following error:

    Monday, March 27, 2017 3:04 PM

Answers

  • Seem the script fails to unzip the HPC fabric application package, could make sure there is enough disk space in C: and retry? 

    The error message indicates the file is used by another process, maybe by an anti-virus software, could you disable the anti-virus software temporarily if exists.

    • Marked as answer by SRIRAM R Tuesday, March 28, 2017 4:20 PM
    Tuesday, March 28, 2017 6:52 AM

All replies

  • Seem the script fails to unzip the HPC fabric application package, could make sure there is enough disk space in C: and retry? 

    The error message indicates the file is used by another process, maybe by an anti-virus software, could you disable the anti-virus software temporarily if exists.

    • Marked as answer by SRIRAM R Tuesday, March 28, 2017 4:20 PM
    Tuesday, March 28, 2017 6:52 AM
  • Disabling anti virus (Mc Afee) did the trick in my case.


    Thanks!

    Tuesday, March 28, 2017 4:20 PM