locked
Promise SATA300 TX2plus SATA - Cannot Install WHS *Resolved* RRS feed

  • Question

  • I’m stuck at the “Load Additional Storage Drivers” message.  I’ve downloaded the most recent version (1.00.0.33), unzipped them and put them on a USB stick.  I select the INF file and it looks as if the drivers install but the WHS installer does not see the drives.

     

    The SATA300 TX2plus is listed on the WHCL for Server 2003 so I believe that it should work.  Here is my basic setup.

     

    Dell Precision 650, BIOS A05

    3GB RAM

    2, Seagate SATA 320GB HDs

    Promise Technology, Inc. SATA300 TX2plus Serial ATA Controller, BIOS 1.00.0.34

    IDE DVD drive

     

    I’ve looked at the BIOS settings on the Dell and the BIOS “sees’ the drives.

     

    Am I missing something?  All suggestions welcomed.  Thanks!

     

    Issue resolved:

     

    A little trial and error can go a long way…

     

    Steps -

    1. Use version 1.00.0.31 of the driver instead of the current version (1.00.0.33).
    2. Disconnect the data cable from second SATA drive (channel 1).
    3. Install WHS.
    4. Once the installation completes, shutdown WHS and reconnect the second SATA drive.
    5. Reboot.
    6. Check the PC BIOS to make sure that you are booting to the correct HD – continue with the reboot.
    7. Connect to the console and add the new drive in the WHS console.

    I'm up an running!

     

    -don

    Wednesday, May 2, 2007 6:04 PM

All replies

  • I simpler method is to completely install and setup WHS; and after thourghly doing that, install your RAID disks trough the WHS Console's Server Storage tab.  Keep your Windows 2003 drivers close, that's what works best with WHS.

    Christopher C. Kennedy

    Owner / Software Engineer

    Southside Solutions

    A Microsoft ISV Partner

    Phone: ***.238.3816

    Fax:     ***.365.6534

    E-mail: cck@southside-solutions.com

    Web:    www.southside-solutions.com

    Friday, June 8, 2007 8:50 AM
  • I have been stuck at this point for a long time.  I was going to try to load Server 2003 just to verify the SATA card works but I'll try your solution first.

     

    Poweredge 650, BIOS A05

    Promise SATA300TX Plus

    2 320GB SATA Hard drives

     

    I first had to scrounge an old IBM T21 DVD ROM drive for the server and have been stuck at the load additional drivers because WHS can't find the hard drives.

     

    Chuck
    Friday, June 8, 2007 5:12 PM
  • It worked perfectly.

     

    The Dell Poweredge 650 does not come with a DVD drive, only a CD ROM and does not support booting from USB.  Being an older server it also does not natively support large hard drives. So here is what I had to do.

     

    Install a old IBM T21 DVD ROM drive.  I had to trim the left side of the drawer just a little to make it fit.

    Next I installed the Promise SATA300TX Plus card in the PCI slot and attached 1 320GB SATA drive.  I had to use power adapters for the SATA drives.

    Installed WHS using the older Promise drivers like the original posted mentioned.

    After the install was done I hooked up the other 320GB SATA drive, closed it up and powered it on.

    Next install the connecter software on my PC, and tell WHS to add the drive to the storage pool.

     

    Everything is running perfectly now.

     

    The downsides.  The Poweredge 650 only has space for two hard drives and both PCI slots are taken.  One PCI had the ethernet card and the other has the Promise SATA card.  My next task will be to get the Rocket Raid 1742 card to see if it will work with WHS.  The 1742 card has two internal SATA connections and 2 eSATA external ports so I will be able to add two more hard drives at a later date.  At this point I'm waiting for RC1 to become available.

     

    Thanks for the help.

     

    Chuck

    Saturday, June 9, 2007 1:38 PM