locked
CRM Router keeps retrying email with large attachment RRS feed

  • Question

  • Hi everybody,

    curious if anyone can help me to resolve the following issue:

     

    1. Due to security issues one of our customers has installed email router on their premises, next to their email server.
    2. Email server used to have attachment limit 5MB and all was well but that apparently has changed.
    3. One of the monitored mailboxes (queue) has received an email with 30MB+ attachment
    4. Email router has duly tried to push this email to CRM and CRM rejected the attachment as too big. 
    5. Problem is that web server (which is what CRM effectively is) rejects uploaded file only after it's been uploaded. Or perhaps after the limit has been reached (5MB) - don't really know. In either case router pushes 5-30MB per "attempt"
    6. It would not have been a problem if router did not continuously retry the message. Which it kept doing hour after hour after hour. Which severely blown our monthly traffic.
    Question: how to stop router from pushing emails it failed to upload to CRM due to attachment size restriction?

    None of the existing settings on inbound profile seems to help. Except perhaps for Message Expiration which by default set to 24 hours - seems reasonable. But I could not find any "Retry" type of setting.

    Any help would be appreciated.
    --

     


    George Doubinski, MVP http://crm.georged.id.au
    Tuesday, January 11, 2011 12:27 AM
    Moderator

All replies

  • not sure whether this is supported or not, and id recommend to test this first before doing it on a live site, but you could try editing the "Microsoft.crm.tools.emailagent.xml" file found in your program files\ MS CRM Email\Service\

    Would be a good idea to stop the MS CRM Email router service before editing it though.

    Thursday, January 13, 2011 3:45 AM
  • I could try editing the configuration file but the question is, which setting do I change?
    George Doubinski, MVP http://crm.georged.id.au
    Thursday, January 13, 2011 4:23 AM
    Moderator
  • possibly try MaximumDeliveryAttempts?

    for more info in the config settings as there maybe other settings that could help you here, try this link below:

    http://blogs.msdn.com/b/crm/archive/2008/07/02/email-router-configuration-xml-file-explained.aspx

     

    Thursday, January 13, 2011 8:01 PM
  • Thanks for the suggestion. Unfortunately, MaximumDeliveryAttempts specifies

    "Maximum attempts the email router will try to send the email out"

    In other words, this setting is for outbound attempts while I'm having problem with router continuously trying to submit email with large attachment into CRM.

     


    George Doubinski, MVP http://crm.georged.id.au
    Thursday, January 13, 2011 9:12 PM
    Moderator