locked
HELP!!!! Server crash retrieving data. RRS feed

  • Question

  • I am desparate here. I came home Friday night and my power had went out or something. My WHS was on but the "i" light was flashing blue with nothing else. No light on the hard drive bay. Can't get it to do anything. I turned it off and removed the hard drive. Then I hooked up the drive to my desktop via external hard drive enclosure. I can see all the files and they look fine but I can't open them or copy them over to the desktop. (it says file is corrupted) I was hoping I could copy everything over so I could put the drive back in the server and do a reset without risking my data. I can't access my server at all. Either through my network or plugging straight into a pc. I was thinking if I could get in I might could just reboot it. This is an Acer Easystore WHS. I only have the one drive in the server that contains the OS and my data. This data is the actual files NOT the backups. I would like to get my data safe first then try to fix the server from there. I am wondering if the data can only be opened etc if it is on my server rather than my pc because of the way it is stored on the server or something. Please help.....I am running out of ideas.
    Sunday, August 15, 2010 3:18 PM

All replies

  • I am desparate here. I came home Friday night and my power had went out or something. My WHS was on but the "i" light was flashing blue with nothing else. No light on the hard drive bay. Can't get it to do anything. I turned it off and removed the hard drive. Then I hooked up the drive to my desktop via external hard drive enclosure. I can see all the files and they look fine but I can't open them or copy them over to the desktop. (it says file is corrupted) I was hoping I could copy everything over so I could put the drive back in the server and do a reset without risking my data. I can't access my server at all. Either through my network or plugging straight into a pc. I was thinking if I could get in I might could just reboot it. This is an Acer Easystore WHS. I only have the one drive in the server that contains the OS and my data. This data is the actual files NOT the backups. I would like to get my data safe first then try to fix the server from there. I am wondering if the data can only be opened etc if it is on my server rather than my pc because of the way it is stored on the server or something. Please help.....I am running out of ideas.

    Please see this FAQ post.

    Also, if your data is that important (which you are implying it is), you should add a second drive to your server and enable Folder Duplication for all shares.  Otherwise, a hard drive failure (which may or may not be what happened in your case) can wipe out some/all of your data.

    Sunday, August 15, 2010 3:34 PM
    Moderator
  • At the end of this post it says I can copy the data from the shares folder to another pc.....when I try to do this it won't do it. It says the file is corrupted. I am thinking (and praying) this is because of something the server does to the files and it is the same reason I can't open them from here. Does this have anything to do with "tombstones" being in a different place or something?

    Second, how can I do a server reinstall if I can't even get access to the server. There is a reset button on the back..... will it let me in if I am hooked directly to it from a pc (rahter than through the router) once I have pressed the reset button cause it won't as of right now? I have been assuming this might fix the problem but I have been trying to make sure my data was safe before I did that.

    Sunday, August 15, 2010 3:49 PM
  • At the end of this post it says I can copy the data from the shares folder to another pc.....when I try to do this it won't do it. It says the file is corrupted. I am thinking (and praying) this is because of something the server does to the files and it is the same reason I can't open them from here. Does this have anything to do with "tombstones" being in a different place or something?  
    Yes.  Make sure you follow the instructions in FAQ post.

    Second, how can I do a server reinstall if I can't even get access to the server. There is a reset button on the back..... will it let me in if I am hooked directly to it from a pc (rahter than through the router) once I have pressed the reset button cause it won't as of right now? I have been assuming this might fix the problem but I have been trying to make sure my data was safe before I did that.

    There is a reinstall method that comes with all pre-built servers (including the Acer models).  However, I don't know the exact steps for your model, so you'll need to refer to the instructions that came with your server.
    Sunday, August 15, 2010 4:03 PM
    Moderator
  • Thank you!!! One more time just to clarify.....You said "yes" above.....Meaning that the tombstones is the reason?

    I am thinking about going out and buying another hard drive to stick in the server. Can I stick that one in then try to do a "new install" on it...then put this old drive back in and get the data? Good idea or not? Trying to chart the safest course of action. Of course, if I do that I might cause more problems with the server not being able to open the file either.

    I wish I had just posted out here 2 days ago instead of fighting this fight alone.

    Sunday, August 15, 2010 4:08 PM
  • Thank you!!! One more time just to clarify.....You said "yes" above.....Meaning that the tombstones is the reason?  
    Most likely.  Did you follow the steps in the FAQ post to recover your data?  
    I am thinking about going out and buying another hard drive to stick in the server. Can I stick that one in then try to do a "new install" on it...then put this old drive back in and get the data? Good idea or not?

    Not a good idea.  Don't connect a drive that was a primary drive from a previous install of WHS to a current install of WHS.  If you want to install on a new hard drive, that's fine.  But then connect the old primary drive to a client (not the server) and copy the data to your server through the network. 

    Trying to chart the safest course of action. Of course, if I do that I might cause more problems with the server not being able to open the file either.

    I wish I had just posted out here 2 days ago instead of fighting this fight alone.

     

    Sunday, August 15, 2010 5:44 PM
    Moderator
  • I got it!!!! Thank you for your help! The files I was trying to copy were from a different "shares" folder. I unhide and found the DE folder and it worked like a charm. Now to reset the server and see if I can get that to work. All my data is safe!

    YOU ARE A LIFESAVER!

    Sunday, August 15, 2010 7:24 PM