locked
Server Reinstall now getting BSOD devolume.sys whentrying to read old drive pool RRS feed

  • Question

  • Hey guys,

    Any help would be more than appreciated on my problem.

    Situation:  Vail Server 1x 1.5TB Boot Drive 6x 2TB Drives all on H55 Mitx Mobo core i3

    Main 1.5TB Drive failed. Replaced this.  Tried to do a server reinstall keeping data.. Failed

    New reinstall with just the boot drive connected. All updates. Re attached the other 6 2TB Drives from the old Server build.

    Shows drives as locked. OK. Tried to unlock drives but then BSOD with devolume.sys

    Tried to just attach 1 drive to get data off.. same.. BSOD.

    Argghh.. lots of data on here that I am looking at as lost.  Is there anyway to get to read these drives again either as a drive pool or even

    individually so that I can copy the data to the new Server ???

    Thanks in advance,

     

     

    Saturday, October 2, 2010 12:54 AM

All replies

  • First, have you submitted a bug report on Connect?

    If your drives are from a different version of Vail than you are running now (i.e. they are from the original preview release from the end of April and you're now running the preview refresh), I'm sorry but they're unreadable. To get at the data that's on them, you would have to reinstall the matching version of Vail, since Microsoft intentionally broke compatibility with the refresh.

    If they're from a Vail server running the same version, you should be able to connect them, then (without trying to mount them as default server storage, which seems to be somewhat broken at the moment) simply access the "non default server storage" through the mount point for that purpose on the C: drive of your server.


    I'm not on the WHS team, I just post a lot. :)
    Saturday, October 2, 2010 2:28 AM
    Moderator
  • Hello Ken,

    Its the same version. I basically did a complete new reinstall when the refresh came out and then copied my data to it.

    Its strange, I have reinstaled a new refresh Vail server. When I connect either the other 6 drives or just 1 of them they show as locked. I thought , well that's no problem, in the worse case I will just attach the drives seperately and then copy the data off them back to a new Vail build, the same as I have done in the Past with V1 when it died on me.

    But the minute after I unlock any of the old data drives, it shows as initialising and then within 30 seconds it BSOD's with the Devolume.sys error. Very frustrating. Its not in a VM or anything but on hardware.

    I thought that by attaching them to a new but the same, build they would show up as non default storage, and then I could copy from them. The frustrating thing is that I have tested this when the refresh first came out to make sure that I could get to the data in a disaster and it worked perfectly.

    I am just re installeg again to try once more before giving up. How do I go through the mount point on C: to se if I can access from there ?

    D'oh...  I will submit a bug report with connect.

    Thanks

    Brgds

    Nick

     

     

     

    Saturday, October 2, 2010 8:18 AM
  • Nick

    Just wondering if you have managed to solve the problem. 

    I have exactly the same issue.  I have reinstalled the Vail refresh, but every attempt to unlock the storage pool of 7 drives results in the same BSOD.

    Any help would be great.

    Brgds

    John

     

    Tuesday, October 12, 2010 12:50 PM
  • John, if you were previously running the public preview released at the end of April, and you've now upgraded to the refresh released in August, you will not be able to mount your old server storage and read it. This is by design; Microsoft intentionally broke compatibility because of issues corrected in the preview refresh.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, October 12, 2010 1:00 PM
    Moderator
  • Ken

    Thanks for your reply.  Like Nick, I had setup a new server installation using the Vail Refresh (replacing the previous Vail release)  and put the data on the 7 drives in a storage pool.  I had kept a back up of the data on 3 separate hard drives as the Vail is only in Beta release.

    Unbelievably, the main server drive failed at the weekend as did one of the three backups.  Just to compound my luck the only files that I cannot recover are my wife's document file. 

    I have reinstalled a new refresh Vail server (i.e. the same version). When I connect the 7 drives or just 1 of them they show as locked.

    After I unlock any of the old data drives, it shows as initialising and then within 30 seconds it BSOD's with the Devolume.sys error.

    You had mentioned going through the mount point on c: in response to Nick's email.  I am just looking into how to do this, but would be very grateful if you are able to briefly explain how to do this.

    I only need to access one of the shared folders stored across the 7 external drives.

    Thanks in advance for any guidance

    Brgds

    John

    Tuesday, October 12, 2010 1:34 PM
  • My first guidance is going to have to be to point you to the top of the forum, where an announcement warns against using Vail in a production environment. You agreed to a similar warning when you installed Vail; it's part of the EULA for the software. Vail is beta; nobody should be trusting it to keep their data safe. So it's quite possible that you have lost whatever data you don't have backed up elsewhere.

    Now, as for accessing the data: When you connect one or more drives from a foreign server storage pool to your Vail server, you should see something like "Non default server storage" show up in the appropriate section of the dashboard. In addition, in the root of your server's C: drive, there should be a similarly named folder. That folder is a "mount" or "junction" point, an NTFS construct which allows you to access a drive as a folder without giving it a separate drive letter.

    Failing that, if you've been using server backup, you can probably access a recent backup to recover most data. You may need to use the tools built into Windows Server 2008 R2 to do so, rather than going through the dashboard. (Vail uses these tools behind the scenes, so Vail backups are Windows Server 2008 server backups.) You can learn more about server backup on Technet.

    To repeat my initial warning: If you have only enough hardware for one server, please drop back to V1. Vail is not production quality today; if you don't have the hardware to keep multiple servers and backups (I think I have 12 TB of storage right now, to protect less than 2 TB of data) you should be using a released product rather than a beta.


    I'm not on the WHS team, I just post a lot. :)
    Tuesday, October 12, 2010 2:24 PM
    Moderator
  • Thanks again for your prompt response. 

    I thought I had a full backup and in truth was only using the Vail Server to learn and help the beta test.  I have now realised the need for more than a secondary redundancy to be built in. 

    The good news is that I have learnt much more about servers than I ever expected I would a few weeks ago.

    I will give your recommendations a try this evening.

    Thanks again

    Tuesday, October 12, 2010 4:07 PM