none
PC Restore - "An unknown network error has occured during PC Restore" RRS feed

  • Question

  • Hi, I have read all the other links about this but I have not been able to restore my client PC's

     

    I have a Dell PowerEdge Server running a legal and full copy of Windows Home Server / Service Pack 2 with every update avaliable. It has been tracking and backing up 5 different laptops for about 1 year now. I lost a hard drive on one PC and didn't like the update I did on another. I decided to restore both laptops using the client restore CD.

     

    I download the update avaliable from Microsoft "restorecd.msi" which unpacks into "RestoreCD_dual.iso" I burned this to a CD Rom and booted one of my Laptops. It found the network card and I could find the server. I typed in the password and I recieved the error "An unknown network error has occured during PC Restore" while it was trying to login(?). I did what was suggested in this forum by unplugging the internet from my home router but this did not help. I plugged the server and PC into a spare router but this did not help either. My server is static not DHCP but I tried it both ways with no better results.

     

    My second PC is a netbook. I made a bootable USB stick and copied the ISO image on to it (expanded). It boots and is able to run. At first it could not find my ASUS network card but I copied the drivers from the netbook into a folder on the USB stick and I have it scan for drivers while booting. It now finds the network card. The same error occurs when it tries to connect to the server. Since the USB stick is more flexable I was able to add a line in the "hosts" file '192.168.1.99 server99' so that it could resolve my server by name. This also did not help.

     

    I decided to try to run the software from the server itself. The software should be able to run, login but not restore to itself. I found in "C:\Program Files\Windows Home Server" a copy of the same software that is used on th erecovery CD "ClientRestoreWizard.exe" I ran it and found that after typing in the password I get the same error as if I was remote trying to connect from an external PC. At this point I think th eerror is at the server level not the Restore PC level.

     

    I cleared the event logs and ran the "ClientRestoreWizard.exe" software and found only one error (Type = Warning  Source = ASP.NET 2.0.50727.0)

    Event code: 3007

    Event message: A compilation error has occurred.

    Event time: 12/24/2010 8:12:13 AM

    Event time (UTC): 12/24/2010 1:12:13 PM

    Event ID: 06fcb524114b47c0bf81b5a6ba375132

    Event sequence: 8

    Event occurrence: 1

    Event detail code: 0

     

    Application information:

    Application domain: /LM/W3SVC/2/Root/EnrollId-1-129376699090781250

    Trust level: Full

    Application Virtual Path: /EnrollId

    Application Path: C:\inetpub\EnrollId\

    Machine name: SERVER99

     

    Process information:

    Process ID: 2564

    Process name: w3wp.exe

    Account name: NT AUTHORITY\NETWORK SERVICE

     

    Exception information:

    Exception type: HttpCompileException

    Exception message: (0): error CS0016: Could not write to output file 'c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\enrollid\d5ae5ceb\c800d3da\App_Web_id.aspx.cdcab7d2.tlfy84ve.dll' -- 'The directory name is invalid. '

     

    Request information:

    Request URL: http://SERVER99:55000/EnrollId/Id.aspx?q=1293196303

    Request path: /EnrollId/Id.aspx

    User host address: 192.168.1.99

    User:

    Is authenticated: False

    Authentication Type:

    Thread account name: NT AUTHORITY\NETWORK SERVICE

     

    Thread information:

    Thread ID: 1

    Thread account name: NT AUTHORITY\NETWORK SERVICE

    Is impersonating: True

    Stack trace: at System.Web.Compilation.AssemblyBuilder.Compile()

    at System.Web.Compilation.BuildProvidersCompiler.PerformBuild()

    at System.Web.Compilation.BuildManager.CompileWebFile(VirtualPath virtualPath)

    at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)

    at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)

    at System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean noAssert)

    at System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp, Boolean noAssert)

    at System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath)

    at System.Web.UI.PageHandlerFactory.System.Web.IHttpHandlerFactory2.GetHandler(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath)

    at System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig)

    at System.Web.HttpApplication.MapHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

    at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

     

     

    This error Occures every time I try to restore a PC. I have yet to figure out what this means but I can only hope that getting this fixed may allow me to recover my laptops properly.

     

     Anyone? I'll take any help anyone can provide. Thank You for reading.

    Friday, December 24, 2010 1:18 PM

All replies

  • OK - I tried removing all my .net software and reinstalling but found I could not fix the error. I then found that my connector software would no longer connect to the server from any of my home PC's. I ended up reloading the server from scratch. I used the newest "Windows Home Server with Power Pack 3" DVD from Microsoft. After installing and running all the avaliable updates the .net errors are no longer an issue. The under lying issue of I could not install nor use the home connector software to the server nor could I connect via the recovery software still existed. Here is what I found, I hope this helps others. Disconnecting the internet from the router did not help. I did find however you must shut off the DDNS option if you are using it in your router. This was a must for me for both the home connector software to connect to the server after you enter the password. You can turn back on afterward. The newest "ClientCD.iso" avalable by Microsoft is broken. Maybe some of you get it to work but when I unpack it, it only has two files. If you run from a CD or client PC folder it tries to download software from the server. It always comes back with an error! I reverted back to the software that came with my first version of WHS. It has the following list of files. DOTNETFX20 (FOLDER) WindowsInstaller31 (FOLDER) Setup.exe (6.0.2423.0) WHS_CONNECTORHELP.CHM WHSConnector.msi WHSConnector_x64.msi WHSVersionUpgrade.dll WHSVersionUpgrade_x64.dll Using this version of software I was able to install the WHS Connector software on all PC's in the house with error. I am still working on testing the "File Recovery Software"
    Monday, January 3, 2011 10:22 AM