none
Linkage between WHS Admin Console/Settings/Add-ins & Server Shared Folders/Software/add-ins not functioning. RRS feed

  • Question

  • Hi

    Can anyone advise what specifically links the Server Shared folders to WHS Admin console settings/add-ins? Is this a program within WHS and if so which program or is the linkage defined by the p/c operating system W7/Vista/XP? Does Microsoft security &/or anti-virus/firewall (McAfee) play any part in authorising/blocking the connection. Is this a hyperlink connection or something different? 

    My problem as described in previous posts is that MSI files are in the correct software/add-ins folder on the server however the admin console function cannot see these files. By some chance is there a WHS add-ins.exe program which needs to be installed which for some reason was not done at the factory settings level? I can access the WHS SYS partitioned drive using an external hard drive enclosure to check if the correct files are in place - the problem is I have no idea which files I need to be checking for.

    Thanks
    Thursday, February 18, 2010 9:52 PM

All replies

  • The MSI has an attribute assigned to it that marks it as an Add-in for Windows Home Server (WHSLogo).  If on a healthly Windows Home Server you don't see the Add-In then it's not for Windows Home Server.
    --
    Friday, February 19, 2010 11:11 AM
  • I have two MSI files in shared folders/software/add-ins folder: The Toolkit I downloaded directly from Microsoft and an MSI File from McAfee for Homeserver specifically on a provided link from McAfee. The Toolkit I managed to install manually only by using Remote Desktop and I have posted a bug report to Microsoft Connect. I have 2 servers and the same problem exists on both server add-ins. That indicates to me that the Factory supplied software is not functioning correctly and I will be returning to Acer for reformatting and re-installation of their latest version of the WHS operating system. One server has already beeen returned to Acer for checking and returned with a clean bill of health.  

    Friday, February 19, 2010 12:01 PM
  • You are meant to run the toolkit on a client machine.  Then from program files select Publish toolkit and then you can install the add in from the Windows Home Server Console.

    I am still confident in the fact that either the version of McAfee you are trying to install is not meant for Windows Home Server or there is a current verison of mcafee still installed.
    --
    Friday, February 19, 2010 12:11 PM
  • You can download a checking utility I wrote from here:
    http://uploading.com/files/5a5ef24c/CheckWHSAddIn.zip/

    Extract the files to the same directory where the add-in is or copy them to a new directory and then copy the add-in to that directory.  Then from the command prompt change to the directory and run:
    CheckWHSAddIn.exe NAMEOFADDIN.msi

    It will report either:
       WHSLogo = 1 was not set -  THIS IS NOT A WHS Add-In
    or
       WHSLogo = 1 was set -  THIS IS A WHS Add-In

    You don't have to run this on your server so long as the file are together it should run on any XP, Vista, W7 machine  - if you don't pass the name of an MSI, say an exe or jpeg then the app will probably crash but it won't be fatal.

    By the way you should never trust a program someone gives you over the internet.  I have presented the code below in case someone wants to verify it:

    using System;
    using System.Collections.Generic;
    using System.Text;
    using System.IO;
    
    namespace MakeWHSMSI
    {
        class Program
        {
            static void Main(string[] args)
            {
                if (args.Length > 0)
                    if (!string.IsNullOrEmpty(args[0]))
                    {
                        FileInfo fileInfo = new FileInfo(args[0]);
                        Console.WriteLine("MakeWHSmsi: Parameter Passed : {0}", args[0]);
                        SetupWHSLogo(fileInfo);
                        return;
                    }
                Console.WriteLine("MakeWHSmsi: No Parameter Passed");
            }
    
    
            static void SetupWHSLogo(FileInfo f)
            {
                // Find the installer
                if (!f.Exists)
                {
                    Console.WriteLine("Installer Not Found. Current = " + f.DirectoryName);
                    return;
                }
                Console.WriteLine("Installer at: " + f.FullName);
    
                // Open the MSI installer
                Type type = Type.GetTypeFromProgID("WindowsInstaller.Installer");
                WindowsInstaller.Installer installer = (WindowsInstaller.Installer)Activator.CreateInstance(type);
                WindowsInstaller.Database db = installer.OpenDatabase(f.FullName, WindowsInstaller.MsiOpenDatabaseMode.msiOpenDatabaseModeTransact);
    
                // Search for the WHSLogo property
                bool whslogofound = false;
                WindowsInstaller.View v2 = db.OpenView("SELECT * FROM Property");
                v2.Execute(null);
                WindowsInstaller.Record record = v2.Fetch();
                while (record != null)
                {
                    string str1 = record.get_StringData(1);
                    string str2 = record.get_StringData(2);
                    if (str1 == "WHSLogo") whslogofound = true;
                    record = v2.Fetch();
                }
    
                // If we can't find it, add it.
                if (whslogofound == false)
                {/*
                    WindowsInstaller.View v = db.OpenView("INSERT INTO Property (Property.Property, Property.Value) VALUES ('WHSLogo', '1')");
                    v.Execute(null);
                    db.Commit();
                    Console.WriteLine("Added: WHSLogo = 1");
                  */
                    Console.WriteLine("WHSLogo = 1 was not set -  THIS IS NOT A WHS Add-In");
                }
                else
                    Console.WriteLine("WHSLogo = 1 was already set -  THIS IS A WHS Add-In");
            }
        }
    }
    

    --
    Friday, February 19, 2010 12:41 PM
  • Hi

    I downloaded and placed the ZIP file in the server/software/add-ins folder. Unzipped to same folder to obtain - CheckWHSAddin - Application - 6KB and Interop.WindowsInsdtaller.dll - Application extension - 36Kb. I then used the run command: CheckWHSAddIn.exe NAMEOFADDIN.msi from my p/c and received the message:

    CheckWHSAddin.exe : Windows cannot find 'CheckWHSAddin.exe.'

    I then decided to attempt to install the WHSTookit Windows Installer package - 3,161KB from the same server add-ins folder: I receved the standard pop-up:

    Do you want to run this file?

    Name:   \\(Servername)\\Software\Add-Ins\WHSToolkit.msi
    Publisher:  Microsoft Corporation
    Type: Windows Installer Package
    From:   \\(Servername)\\Software\Add-Ins\WHSToolkit.msi

    I selected RUN and received a Windows Installer Warning "Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel. I selected OK and the installation stops. In the W7 Programs and Features / UNinstall or change a program I can locate: Windows Home Server Toolkit 1.1 12/24/2009 3.98MB 6.0.1800.0.

    IF, again IF I understand the foregoing, Tookit was previously installed and if so should have been identified by you check program. Also from speaking previously with Acer Tech Support two days ago they wanted the toolkit installed thru remote desktop which I had not used previously but managed yesterday to manually install Toolkit on the server. If incorrect how do I unstall from the server as again I cannot locate any specific window which allows uninstallation from within the WHS admin console.
    McAfee advise the specifically downloaded file I have from them is the correct file and is a valid msi file. Nothing in the server\software\add-ins can be seen when using the server admin console which still has  blank pages against add-ins Installed + Available in the Settings section. Last night I ran the toolkit from the server and received 1 error which was that Upnp was not working and possibly my router has this disabled however when I checked the router this iss definitely enabled (ticked check box). The toolkit message also said that this Upnp is most unlikely on its own to be the cause but what else it can be is clearly unknown to me and as yet unidentified. 


    If I have done anything incorrectly let me know and I will attempt again.

    Thanks 








    Friday, February 19, 2010 2:01 PM
  • p.s. I was more likely the windows network connector troubleshooter I ran last night which advised regarding the Upnp error. 
    Friday, February 19, 2010 2:09 PM
  • Hi,

    You have to open a command prompt aka DOS Prompt, Command Window and CHANGE DIRECTORY to where you put the files.  Then you can run the command - you replace NAMEOFADDIN with the actual filename of the add-in.

    My check program will just say if an MSI is a Windows Home Server Add-In.  I want to prove one way or another that the Mcafee Add-in you have is suitable for WHS or not.

    For the toolkit do you have a Program group "Windows Home Server ToolKit" within that should be "publish toolkit".  Then from the Windows Home Server Console you can install the add-in.

    Cheers,
    Al
    --
    Friday, February 19, 2010 2:19 PM
  • Hi

    Please clarify how to confirm which directory the server file software/add-ins actually resides on. What is the specific DOS command to change to the server directory from my pc? Does it require a drive letter (how to locate?) or by server name? The server shows up in "My Computer" under Network heading under its name only.

    I still don't understand how the Microsoft Tookit MSI already installed is not identified by the same program. IF I remember correctly when I installed the toolkit manually on the server yesterday It installed correctly and I the sent a CAB report to Microsoft Connect. If it did not install correctly then the CAB report would not have been produced.  

    Regarding McAfee I have attempted running this replacement file before and I receive a warning that a previous version of McAfee needs to be uninstalled and if so this would indicate that both the McAfee Trial Version which was factory installed and the new dowloaded version are both valid MSI Files. Also I have just right-clicked properties for the McAfee topwhsaddIn4.9ACER file and W7 displays the following:  Type of File (Windows Installer Package (.msi) Opens with Windows installer. Unless there is some very unusual about this file then both Windows and McAfee correctly identify as an MSI file. This is the second time I have downloaded from McAfee with a different link and the file name/size/file extension is exactly the same. 

    Regarding the Tookit Program group. I cannot see these files on the server /softwareadd-ins folder. If I need to use remote desktop where should I be looking as there is nothing obvious. Also on my pc I have accessed C/program files/windows home server/ tookit and can see Toolkit as a windows installer package. Do you want me to attempt to run from this location? If yes I am guessing that it will advise that a different version is already installed (via remote desktop yesterday) and if so can this be manually uninstalled (How and which files) and the version on my pc installed?

    Thanks

    Thanks
    Friday, February 19, 2010 2:51 PM
  • Now you've confused me if the toolkit was installed and working okay why are you asking to install it?  The MSI you download from microsoft has to be installed on a client PC it then contains another MSI that is uploaded to the correct path on the Home Server and then is installed through the Windows Home Server Console - this is all detailed in the readme that can be found in the program group "Windows Home Server Toolkit" or at
    C:\Program Files\Windows Home Server\Toolkit\readme.htm

    I think I have said in every post so far a Windows Home Server MSI is special you windows 7 machine cannot tell the difference between a WHS MSI and any other - that is what the app is I have written and you have downloaded - it is not like a normal MSI, it has an extra tag in it to signify it's for the console and all the files contained with it are specially design to work with the Windows Home Server Console and will not work on any other system.

    Basically you've got to get the suspect mcafee MSI, my EXE and it's DLL all in the same directory on another PC you choose and then get to a command prompt.

    For example on your client PC (not the server) create a new folder and copy all those files to it. Then open a command prompt and change directory to it i.e:

    Open drive C.  Right click mouse, select New, select folder.  Type testmsi press <return>  go find those files and copy them to the folder you created.  Go to start, go to run, type CMD and press <return>.  In command windows type cd c:\testmsi  type dir  find the line that ends in MSI  then type CheckWHSAddIn.exe <THE NAME OF THE MSI>

    Where I have typed <THE NAME OF THE MSI> replace it with the name of the msi that you saw.  I.e. if you saw  tpsinstall.msi then you would type that.

    From the Windows Home Server Console - under Settings, Add-Ins what do you have currently listed?


    --
    Friday, February 19, 2010 3:07 PM
  • Hi

    I copied over the contents of the server add-ins folder to my pc and placed in docs/server/addins and then ran your dos command:

    CheckWHSAddIn.exe NAMEOFADDIN.msi 

    Again I receive the same message  'CheckWHSAddin.exe : Windows cannot find 'CheckWHSAddin.exe.' therefore if correct the check program can't identify valid MSI files either on my pc or the server shared folders which seems to indicate that the WHS admin console is having the same problem identifying these files in the server shared folders.
    Friday, February 19, 2010 3:10 PM
  • By some chance could there be a hidden block/safery feature build into W7 to protect users from incorrectly attempting to install WHS programs using file extension .msi into their pc by mistake and possibly corrupt the operating system? Just guessing/grasping at straws but thought I should post - just in case....
    Friday, February 19, 2010 3:14 PM
  • Are you opening a Command Prompt window first?  If you follow the instructions I give you will have an eaiser time of it.


    http://www.c3scripts.com/tutorials/msdos/open-window.html


    --
    Friday, February 19, 2010 3:18 PM
  • By some chance could there be a hidden block/safery feature build into W7 to protect users from incorrectly attempting to install WHS programs using file extension .msi into their pc by mistake and possibly corrupt the operating system? Just guessing/grasping at straws but thought I should post - just in case....

    Even if you did it would not harm your windows 7 installation. 
    --
    Friday, February 19, 2010 3:19 PM
  • CheckWHSAddIn.exe NAMEOFADDIN.msi 


    Once you get past the first error of CheckWHSAddIn.exe cannot be found you must replace NAMEOFADDIN.msi with the name of the add-in.  You keep on typing NAMEOFADDIN.msi as if you don't understand NAMEOFADDIN represents the name of the file and isn't actually the file. 

    For example if I was to say Hello MYNAME  -  I would write Hello Al  you would write Hello antfortas  - I only say this because at no time have you written topwhsadd.msi or something to that effect - this is why I say you must look at the screen when doing 'dir' in the command window to see what the full name of the msi is.
    --
    Friday, February 19, 2010 3:24 PM
  • Hi

    I copied over the contents of the server add-ins folder to my pc and placed in docs/server/addins and then ran your dos command:

    CheckWHSAddIn.exe NAMEOFADDIN.msi 

    Again I receive the same message  'CheckWHSAddin.exe : Windows cannot find 'CheckWHSAddin.exe.' therefore if correct the check program can't identify valid MSI files either on my pc or the server shared folders which seems to indicate that the WHS admin console is having the same problem identifying these files in the server shared folders.

    No that error means the file CheckWHSAddIn.exe is not found - because you are not opening a command window and changing the current directory to the location of the file.
    --
    Friday, February 19, 2010 3:37 PM

  • OK I think I understand (no experience with DOS)

    As advised above I copied over the contents of the server add-ins folder to my pc and placed in docs/server/addins and then ran the dos command:

    CheckWHSAddIn.exe Toolkit.msi

    Result:

    MakeWHSmsi: Parameter Passed : topwhsaddIn4.9ACER.msi
    Installer at : C:\Users\Owner\Documents\Server\addins\topwhsaddIn4.9ACER.msi

    WHSLogo = 1 was already set - THIS IS A WHS Add-In

    However when I did the same for the WHSTookit.msi in the same location it advised

    WHSLogo = 1 was not set - THIS IS NOT A WHS Add-in - even though I was able to obtain a CAB report submitted to Microsoft connect??

    I then copied over the existing Tookit.MSI file from my local disk/program files/Windows Home server/Toolkit and placed in same docs folder and ran again. This time the result was:

    WHSLogo = 1 was already set - THIS IS A WHS Add-in

    It's surprising to me regarding the Microsoft WHSToolkit.msi I downloaded and installed yesterday - why does this show up as NOT A WHS Add-in as I downloaded from the microsoft site and more importantly how to uninstall manually from the server. I think our posts overlapped above and in answer to your question as to why Toolkit was downloaded and installed using Remote Desktop was because that is what ACER Tech Support wanted me to do in remote desktop. Perhaps they also don't know their own pre-installed software set-up? 

    I suspect that there is a wide gulf between users who purchase what is described as a Home Server which is basically viewed like a plug and play standard versus knowing the ins and outs of the programs and experience with DOS. Also this problem has been ongoing since purchase both with my previous XP /Vista setup and now an all W7 set-up so if the Tookit was already installed correctly it could not be seen by the admin console and the same with the McAfee Replacement msi file which appears to be valid. I have 2 servers both with the same problem between add-ins shared folders and the WHS admin console therefore it is a consistent and replicatable (?) problem hence my impression is that there is an underlying problem with the factory flashed SYS software - unless you can identify a linkage related problem within WHS which blocks this connection beween the folders and the admin console.

    Thanks 
    Friday, February 19, 2010 4:14 PM
  • Okay we got there in the end. 

    Back to the WHSToolkit - the file you download from Microsoft is design to be installed on any machine that is connected to your windows home server.  Within that MSI is *another* MSI which is then copied to your windows home server - that part of the operation is handled by the ConnectorTroubleshooter which was installed previously.

    Acer shouldn't be advising you to open a remote dekstop session and I shouldn't be advising you to open dos command prompts but then it's a way to get the job done that suits the person supporting you.

    I am wondering if perhaps running two identical servers on the same network is not such a good idea.  I think the design of Windows Home Server only ever thought one home server would be on the same network. 

    Now to the installation of mcafee.  As we've proven it's tagged correctly as a WHS Add-In if it won't show on the available tabs and it doesn't show on the installed tabs you have it partially installed and you only have one option here which is to do a server recovery.  Because this is an add-in that installs more than a class library for the Windows Home Server Console I do not recommend using any Add-In cleanup utility or manually removing the files.


    --
    Friday, February 19, 2010 4:32 PM

  • I appreciate both ACER and yourself attempting non standard methods to get the problem solved. Currently I am not running 2 servers on the same network because WHS and homeserver.com is unable to handle correctly and creates security certificate warnings. There is also only one port available to connect to homeserver.com so 2 servers cannot connect at the same time and the router cannot be set up for port forwarding for 2 servers on the same network. 

    I have done 3 server recoveries back to the factory preset level and currently the server I am posting regarding was recovered to the factory preset level and the only updates have been automatic from WHS to SP2 level. Unless I can access the admin console uninstall function I cannot properly uninstall McAfee trial software which needs to happen in order to install the current msi file. Its appears to be a closed loop. McAfee advise to contact Acer and Acer advise to contact Microsoft/WHS as this is viewed by both as a WHS software bug/issue that they have no control over.

    My only choice now appears to be to return the 2 server HDD to Acer for reformatting/clean re-install unless you can suggest something else to attempt. If I get both HDD's back from Acer and find the same issue then it surely raises the question as to whether Acer are installing the correct files or that there are missing/corrupt files within the factory master disk? If so it seems amazing to me that I appear to be the only person posting with this specific problem.

       

     
    Friday, February 19, 2010 4:53 PM
  • From what I hear most people seem to uninstall McAfee anyway.  I can't really suggest much else.

    If removing McAfee from Add Remove Programs doesn't work and installing the add-in doesn't work when no add-in is there I don't know what else to suggest. 
    Perhaps it's worth searching the forums or some other Windows Home Server sites or posting a more descriptive first post as "How to remove mcafee from Acer 340R".  For example:
    http://social.microsoft.com/Forums/en-US/whssoftware/thread/3842ba90-7b9d-4865-a891-1e937ae237ea

    http://www.google.co.uk/search?hl=en&q=%22Windows+home+server%22+mcafee+uninstall+Acer&meta=&rlz=1I7GGLD_en


    --
    Friday, February 19, 2010 5:09 PM
  • Hi
    Thought that I should advise that I have just shipped off both servers and HDD's back to Acer asking for a full check of the hardware/drivers and complete reformat and clean install of WHS onto the discs. I have also asked that McAfee Trial is not included however if not poossible then at least I have 2 identical discs with the latest Acer version. Once I have the servers back I will power up one server and before doing anything else I will test the add-ins functionality / connectivity to the admin console. I hope it works without a hitch but correspondingly will leave the cause of my current problems a mystery - however if it still doesn't work straight out of the box then there clearly is a problem that Acer and Microsoft will need to address.  Thanks to Al West and Ken Warren for assistance to date. I will post the re-start results when available  
    Friday, February 19, 2010 7:12 PM