none
1,1 TB of bad sectors on drive in WHS. No Bad sectors of same disk in non WHS system. RRS feed

  • Question

  • After a "chkdsk d: -x -r" of my whs with 6 1,5 TB disks the chkdsk marked 600 MB sectors as bad?! I shut down the WHS and took each Drive individaully to my main win 7 system. It turns out that the D: partition of my system drive has all the 600 MB bad sectors. Running a  "chkdsk <driveletter> -x -r -b" (-b reevaluates the bad sectors) on the this datapartition of the systemdisk in my main system resulted in no bad sectors. After putting back the system drive and starting the WHS i did once again a "chkdsk d: -x -r" Result: 1,1 TB  marked as bad sectors. For now I don't believe this is a hardware failure. so anyone any ideas of what's going on?

     

    Monday, May 10, 2010 9:25 AM

Answers

  • It looks to be a driver issue. Eventually I swapped out the Mobo (with win server 2003 support) for a new one, reinstalled WHS with AHCI support (F6-method) and after some minor problems my WHS is running smoothly again.
    • Marked as answer by BartS. _ Thursday, June 24, 2010 9:01 AM
    Thursday, June 24, 2010 9:01 AM

All replies

  • No clue, never heard of such an issue before. Possibly a driver or controller issue or disk running too hot in your server?

    I guess you run (scheduled) chkdsk on the system drive at boot time? If not please try (after resetting bad blocks in Vista or Win7 using chkdsk /b (no need to use /r if you use /b)

    Please try installing SMART monitoring tool (Hard Disk Sentinel, CrystalDiskInfo, SmartMonTools) on the homeserver to check out what's goin on. If there's also CRC errors during real life operation WHS will degrade performance to PIO mode when it experiences too many of these errors. Also if you really have that many bad blocks new ones can no longer be remapped at some point in time, so you will likely run into all kinds of issues sooner or later.

    Another thing you can do is full format (not quick format) of the disk, then check again. Since this would mean reinstalling the server I guess that's not really something you want to try with 6 1.5 TB disks, probably loaded with data.

    Has the disk only been used in WHS or was it repurposed?

    Monday, May 10, 2010 12:10 PM
    Moderator
  • I've been experiencing performance issues for some time now with my WHS. Everything seems to point to hardware failure but I cannot find any proof if and which part is failing. In the event viewer there were messages of "/device/ide/ideport3 did not respond in time" errors (how DO i find out which disk that is?) and there was a disk in PIO mode, solved that problem with help of this forum and then checked my drives one by one in the WHS and in my main system. They all got a clean bill of health. To be sure I swapped cables and put these disks on different sata ports. That's when I noticed the bad sectors....

    The disk in question has only been in use in my WHS and this particular one is the drive with my system partition on it. There have been no CRC errors and the SMART monitor add-in reports the disk is healthy.Will take out the drive again and use the chkdsk -b option again.

    Hence my question in another topic, can I make an image (with acronis 2010 for instance) of the entire drive, restore the image to another drive of same brand,model and size.

     

    Monday, May 10, 2010 2:46 PM
  • If it's only one disk which is causing you problems I would suspect there is some issue with the disk itself, however it's not possible to rule out a a driver or controller issue.

    "/device/ide/ideport3 did not respond in time" errors often indicates failing hardware or driver issues and may also result in controller running in PIO mode. These erros are sometimes resolved by chkdsk /r. Failing hardware can be anything from the hard disk, motherboard, controller and even a dodgy power supply. This type of error can be very nast and difficult to fix. I've seen examples with similar errors in high end servers which in the end (after replacing a number of components and  reinstall) were fixed by getting all new hardware

    If you want to keep the disk you can try an do a full format on the disk, then do a server reinstall. Please note you may loose data if you have files or client backups stored on the D partition of the system drive. Alternatively you can get a new disk and do server reinstall. In both cases server reinstall will probably take a (very) long time, especially if you have a large amount of data stored on your server.

    If you have a lot of data trying image method Ken pointed to in the other thread could be worthwile.  

     

     

    Monday, May 10, 2010 7:12 PM
    Moderator
  • I have seen such reports before, and usually they were tied to certain high storage capacity disks used on an older hardware platform (incompatible controller) or with drivers, which did not support the size (or this specific disk model).

    Best greetings from Germany
    Olaf

    Monday, May 10, 2010 7:15 PM
    Moderator
  • Actually, If anything my hardware is maye a bit too new.  I've got:

    Intel Pentium G9650 processor, Intel DH55TC Motherboard, 2GB Kingston Valueram DDR3 1333,Be Quiet LP 300W, 2 Samsung 1,5TB,4 Seagate Barracuda's LP 1,5 TB

    So it looks a, Server Reinstall is the way too go. definately don't like that. Well I think I'll try to take an image first,format the drive and put the image back on the same disk. Theoretically that should work. If that doesnt help I'll try to move my data off the server. The most important data is already backupped to an external drive. I can remove duplication for the rest, remove two drives from the WHS and start a new installation from those two disks so I can add the other disks 1 by 1 and move data from them to the new servers.

    Tuesday, May 11, 2010 4:38 AM
  • Found the time to work on my WHS. Pulled the disk with the systempartition on it and performed a "chkdsk /b"a the D-partition. After putting the disk back in the WHS I booted and performed a simple chkdsk which reported errors. After this I did a chkdsk /f on c an d partition and chkdsk reported he corrected some errors in the "uppercase table"  whatever that may be. Now i the WHS console in the storage report WHS says it has 500 GB reserved as "system space" Any ideas why it does that?
    Wednesday, May 12, 2010 2:40 PM
  • System space includes all parts of storage space, which are not part of folders, which are managed by Windows Home Server on the DATA volumes. This can be anything from shadow copies to data, which you put to a subfolder of D:\, which does not exist by default - or after running chkdsk it may also be content in the Lost and Found folder.

    Best greetings from Germany
    Olaf

    Wednesday, May 12, 2010 6:04 PM
    Moderator
  • checked some folders. I do not see any strange or temporary folders.
    Wednesday, May 12, 2010 7:42 PM
  • Checked the event logs today:

     

    the system failed to flush data to the transaction log. corruption may occur. (ftdisk)

    and

    "the entry d:/users/shates/xxx in the hash map cannot be updated. cause: a device stopped functioning" (windows search)

     

    Well ... and that's it. How do I troubleshoot this? There's no other error or warning in the event logs?

    and corruption MAY occur???  I really starting to dislike WHS.....

     

    Thursday, May 13, 2010 4:23 PM
  • This is almost certainly a hardware issue, and if it isn't it's almost certainly a driver issue. If it were a Windows Home Server issue, you would see many more reports in these and other forums.

    HBA and cabling are the most likely sources of the problem, but memory is possible, as is a power supply issue.


    I'm not on the WHS team, I just post a lot. :)
    Thursday, May 13, 2010 5:23 PM
    Moderator
  • I agree  SOMEthing is failing. I just cannot proof which part. anyway, Use HDtune in the WHS system to check out the drive with 1,1TB of bad sectors . No errors detected. Yet chkdsk marks 1 TB as bad. How is this possbile?
    Friday, May 14, 2010 8:28 AM
  • ...
    How is this possbile?
    Incompatibility between your BIOS and the drive you're using is the most likely cause. Have you done all your testing and problem resolution on the same hardware, or are you testing disks in another computer?

    I'm not on the WHS team, I just post a lot. :)
    Friday, May 14, 2010 1:42 PM
    Moderator
  • Can you run Memtest86 to check your memory?  I had some Kingston memory that didn't agree with the MB.  Timings were set correctly.  After a few seconds of running Memtest I was getting lots of errors.  Slowed the memory timings down a bit and it worked fine after that.
    Friday, May 14, 2010 2:05 PM
  • will test the memory. My last disk tests were all in the original server.
    Friday, May 14, 2010 3:42 PM
  • This system ran 2 months and had no problems whatsoever so I don't believe in an incompatibility problem with the BIOS.
    Saturday, May 15, 2010 8:26 AM
  • It looks to be a driver issue. Eventually I swapped out the Mobo (with win server 2003 support) for a new one, reinstalled WHS with AHCI support (F6-method) and after some minor problems my WHS is running smoothly again.
    • Marked as answer by BartS. _ Thursday, June 24, 2010 9:01 AM
    Thursday, June 24, 2010 9:01 AM