none
SyncToy 2.1 trying to create folders where they already exist from a previous Echo RRS feed

  • Question

  • Wonder if anyone can assist. I've been trying SyncToy 2.1 to automate my backups.

    I've successfully run "Contribute" to an external USB drive. It seems to behave as expected, but when I try to "Echo" the same folder structure, e.g. "My Docs" to a Samba Network drive, I run into problems.

    New files and folders copy over left to right as expected, but SyncToy then tries to copy every folder that already exists from a previous "Echo", left to right.

    It fails.  "Cannot write to the destination file. Cannot create a file when that file already exists. (exception from HRESULT: 0x8000700B7) creating folder X:\bills backups\My Docs.............................etc."

    I can live with that, but it also fails to copy files which have been modified for the same reason. eg. My .pst backup file for instance won't copy over, leaving me only with the original first backup on the destination network backup drive.

    It should, I understand overwrite the old file if it's been modified "New and updated files are copied left to right. Renames and deletes on the left are repeated on the right. " Save overwritten files in the recycle bin" is checked, but the recycle bin remains empty as the previous backup is not overwritten.

    I've tried deleting the folder pair and re-creating; Also deleting the actual folder structure from the destination drive and starting again (including the log file from the source folder prior to re-trying the Echo.)

    Echo options are all left at default

    Help!

    Thanks Bill

    Tuesday, February 22, 2011 6:34 PM