locked
OCS setup error 0x80004005 on OCS2k7R2 RRS feed

  • Question

  • Hello, 
    i want  install OCS 2007 R2  on Windows 2008 SRV EE + MS SQL 2008 EE (x64),


    When i  want  run " Configure Pool" in Environment Preparation , and i choice existing pool in my  OS, after click on "next" button i have error messagebox  with  error code 0x80004005 .

    I reinstall IIS and .NET3.5, but error still exist.

    If You can help  me, i  will be  galde You.


    Thx  in advance

    this solution didn't  resolve my  problem:

    http://social.microsoft.com/Forums/en-US/communicationsserversetup/thread/663fe179-e59b-47b4-b69b-80857b1af7ae/
    • Edited by msdn_2009 Thursday, February 19, 2009 10:36 AM OCS, 0x80004005, OCS2007 R2
    Thursday, February 19, 2009 10:31 AM

Answers

  • I create wrong certificate form CA, and this was  a problem.  

    now,  im reinstall AD and forest, and CA, and this  resolve my problem

    • Marked as answer by msdn_2009 Friday, February 27, 2009 12:37 PM
    Friday, February 27, 2009 12:37 PM
  • when im install OCS, i had next error,   below im put   code name of this error and  quick resolv ( from Microsoft support) 

     1. error 0xC3FC200D

     AID:

     

    Error message when you use the Conferencing Validation Wizard to troubleshoot conversation issues in Communicator 2007: "Failure [0xC3FC200D] One or more errors were detected"
    http://support.microsoft.com/kb/937296/en-us

    2. Newsgroup

    Knows why the error 0xC3FC200D is being shown when tries to validate OCS and provide a solution to server.

    A:
    ===============
    - Checked that there is no internal CA.
    - Checked the certificate properties. It was ok.
    - Edit the SIP IP address to all, port 5060 and transport as TCP.
    - Stopped the services and started again.
    - Checked the Eventvwr and there is no error.
    - Now the OCS was validated fine.
    - Customer is not using Enterprise Voice.
    - Created a new user account and we entered the Communication tab information.
    - Installed the Communicator on the server.
    - He was able to log in Communicator, but with Synchronizing error message on the
    systray
    - Opened the IIS manager and set the existing certificate to Default Web Site.
    - Re-started the Communicator and now its working fine.


    3. Newsgroup

    -> Getting error when checking validation of web server component. Error 0xc3fc200d

    -> The Certificate Authority was installed on the same machine as OCS 2007. This is known to cause issues and lead to the kind of failures we saw during validation.
    See the following article for information on issues associated with having a CA on the same machine as OCS 2007.
    938296 Error message when you run the validation wizard in Communications Server 2007: "ConnectFailure when the server is trying to connect to the different MCU Factory"
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;938296
    We requested a new certificate from Corpdt5154.rhf.org. We then removed certificate services from corpdv01.
    We plugged in the certificate to OCS and IIS.After getting these two set up properly, and importing the Corpdt5154 CA
    Certificate to the Trusted Root Certification Authorities on the client machine, we could manually configure a client and connect to OCS.
    We added the _sipinternaltls._tcp.rhf.org record pointing to corpdv01.rhf.org on port 5061
    After doing this, we can successfully connect to OCS using automatic configuration.
    I sent you some instructions on installing the CA certificate on additional clients.
    To add a trusted root certification authority to a Group Policy object
    http://www.microsoft.com/windows/windows2000/en/advanced/help/sag_PKPprocsAddDomRoot.htm
    We installed CWA, activated, and created the website. We can successfully access CWA.

     

     

    1. Notatka KB
    > Error message when you click the "Join the Meeting" link in the e-mail message that you receive from the Web Conference session presenter in Communications Server 2007: "An error occurred verifying the server's certificate"
    > http://support.microsoft.com/kb/939802/en-us
    >
    > 2. Info z newsgroup
    >
    > Changed the Certsrv, Certenroll and Certcontroll and removed
    > Integrated and added Basic
    >
    > - Checked the entry CAType at registry and confirmed that the value is
    > 0
    >
    > - Confirmed if certdat.inc is correct
    >
    > - The CA virtual directories at IIS was using DefaultAppPool. Checked
    > the DefaultAppPoool and it was using the IIS Anonymous Account at the
    > Identity tab
    >
    > - Created a new Applications Pool called Certsrv and changed the application at the Virtual Directory Certsrv, certEnroll and CertControll to use the new one we just created.
    >
    > - The New Application Pool was configured to use Network Services.
    >
    > - Tested and was able to request a certificate without any problem.
    >
    Securing OCS with ISA Server
    > http://technet.microsoft.com/en-us/magazine/dd440949.aspx

     

     

    Im think, this info can resolve some problems with OCS installation for other user's

     

     

    Thanks for all reply.


     

     

     

    • Marked as answer by msdn_2009 Friday, February 27, 2009 12:55 PM
    Friday, February 27, 2009 12:51 PM

All replies

  • The code means Access Denied
    Are you sure you have sufficient permissions to configure the pool? Logged into the domain?


    - Belgian Exchange Community : http://www.pro-exchange.be -
    Thursday, February 19, 2009 1:00 PM
  • Yes, I'm.

    Im Loged to domain,   and im loged as Administrator,  
    first step "Environment Preparation" is  signed green "v"
    but  2nd step, in log  is sifgned "success" but  i dont have green "v"
    and in 3rd step  i  see this error :/

    Can i  send You  my install log ? maybe this say  you more then my post.


    Monday, February 23, 2009 8:15 AM
  •  

    Hello,

    In one of the case, i face this problem because i am not able to contact root domain controllers by NetBIOS names. While database creation for the pool, it requires root domain controllers are required to response by NetBIOS name (not fqdn).

    Please check and confirm.


    HCL OCS Team
    Monday, February 23, 2009 7:02 PM
  • I create wrong certificate form CA, and this was  a problem.  

    now,  im reinstall AD and forest, and CA, and this  resolve my problem

    • Marked as answer by msdn_2009 Friday, February 27, 2009 12:37 PM
    Friday, February 27, 2009 12:37 PM
  • when im install OCS, i had next error,   below im put   code name of this error and  quick resolv ( from Microsoft support) 

     1. error 0xC3FC200D

     AID:

     

    Error message when you use the Conferencing Validation Wizard to troubleshoot conversation issues in Communicator 2007: "Failure [0xC3FC200D] One or more errors were detected"
    http://support.microsoft.com/kb/937296/en-us

    2. Newsgroup

    Knows why the error 0xC3FC200D is being shown when tries to validate OCS and provide a solution to server.

    A:
    ===============
    - Checked that there is no internal CA.
    - Checked the certificate properties. It was ok.
    - Edit the SIP IP address to all, port 5060 and transport as TCP.
    - Stopped the services and started again.
    - Checked the Eventvwr and there is no error.
    - Now the OCS was validated fine.
    - Customer is not using Enterprise Voice.
    - Created a new user account and we entered the Communication tab information.
    - Installed the Communicator on the server.
    - He was able to log in Communicator, but with Synchronizing error message on the
    systray
    - Opened the IIS manager and set the existing certificate to Default Web Site.
    - Re-started the Communicator and now its working fine.


    3. Newsgroup

    -> Getting error when checking validation of web server component. Error 0xc3fc200d

    -> The Certificate Authority was installed on the same machine as OCS 2007. This is known to cause issues and lead to the kind of failures we saw during validation.
    See the following article for information on issues associated with having a CA on the same machine as OCS 2007.
    938296 Error message when you run the validation wizard in Communications Server 2007: "ConnectFailure when the server is trying to connect to the different MCU Factory"
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;938296
    We requested a new certificate from Corpdt5154.rhf.org. We then removed certificate services from corpdv01.
    We plugged in the certificate to OCS and IIS.After getting these two set up properly, and importing the Corpdt5154 CA
    Certificate to the Trusted Root Certification Authorities on the client machine, we could manually configure a client and connect to OCS.
    We added the _sipinternaltls._tcp.rhf.org record pointing to corpdv01.rhf.org on port 5061
    After doing this, we can successfully connect to OCS using automatic configuration.
    I sent you some instructions on installing the CA certificate on additional clients.
    To add a trusted root certification authority to a Group Policy object
    http://www.microsoft.com/windows/windows2000/en/advanced/help/sag_PKPprocsAddDomRoot.htm
    We installed CWA, activated, and created the website. We can successfully access CWA.

     

     

    1. Notatka KB
    > Error message when you click the "Join the Meeting" link in the e-mail message that you receive from the Web Conference session presenter in Communications Server 2007: "An error occurred verifying the server's certificate"
    > http://support.microsoft.com/kb/939802/en-us
    >
    > 2. Info z newsgroup
    >
    > Changed the Certsrv, Certenroll and Certcontroll and removed
    > Integrated and added Basic
    >
    > - Checked the entry CAType at registry and confirmed that the value is
    > 0
    >
    > - Confirmed if certdat.inc is correct
    >
    > - The CA virtual directories at IIS was using DefaultAppPool. Checked
    > the DefaultAppPoool and it was using the IIS Anonymous Account at the
    > Identity tab
    >
    > - Created a new Applications Pool called Certsrv and changed the application at the Virtual Directory Certsrv, certEnroll and CertControll to use the new one we just created.
    >
    > - The New Application Pool was configured to use Network Services.
    >
    > - Tested and was able to request a certificate without any problem.
    >
    Securing OCS with ISA Server
    > http://technet.microsoft.com/en-us/magazine/dd440949.aspx

     

     

    Im think, this info can resolve some problems with OCS installation for other user's

     

     

    Thanks for all reply.


     

     

     

    • Marked as answer by msdn_2009 Friday, February 27, 2009 12:55 PM
    Friday, February 27, 2009 12:51 PM