locked
Dynamics CRM 2011 SSRS Reporting Error (rsProcessingAborted) 0x8004832C RRS feed

  • Question

  • I have Microsoft Dynamics 2011 with a distributed installation. 
    **One server for SQL server and Reporting
    **Another one for CRM Server 

    I have installed SSRS Reporting extensions, and Standard reports work fine.

    But, When I run a created report wich was created from report's wizard, CRM throws an error.
    ReportServerException: Error to process the report. (rsProcessingAborted)

    I got trace data from CrmDiagTool, I paste this data:

    MSCRM Error Report:
    --------------------------------------------------------------------------------------------------------
    Error: Exception of type 'System.Web.HttpUnhandledException' was thrown.

    Error Number: 0x8004832C
    Error Message: An error occurred during report rendering.
    Error Details: An error occurred during report rendering
    Source File: Not available
    Line Number: Not available
    Request URL: https://vass.crm5.vass.es:444/CRMReports/rsviewer/reportviewer.aspx
    Stack Trace Info: [ReportServerException: The target principal name is incorrect]
    [ReportServerException: A call to SSPI failed, see inner exception.]
    [ReportServerException: A call to SSPI failed, see inner exception.]
    [ReportServerException: An unexpected error occurred.]

    [ReportServerException: 
    Microsoft.Crm.CrmException: An unexpected error occurred.
    System.ServiceModel.Security.SecurityNegotiationException: A call to SSPI failed, see inner exception.
    System.Security.Authentication.AuthenticationException: A call to SSPI failed, see inner exception.
    System.ComponentModel.Win32Exception: The target principal name is incorrect]

    [ReportServerException: Error de ejecución de consulta para el conjunto de datos 'DSMain'. (rsErrorExecutingCommand)]

    [ReportServerException: Error al procesar el informe. (rsProcessingAborted)]
       at Microsoft.Reporting.WebForms.ServerReport.ServerUrlRequest(Boolean isAbortable, String url, Stream outputStream, String& mimeType, String& fileNameExtension)

    Thank you in advance for your help.

    Friday, March 9, 2012 1:50 PM

All replies

  • This looks like a kerberos issue. The message "The target principal name is incorrect" would indicate that a SPN is defined but is different from the expected value.

    I would recommend checking what SPN's are registered on the CRM and Reporting Services service accounts. And checking what registrations exist for vass.crm5.vass.es. Checking SPNs can be done using the setspn command utility using "setspn -L <accountname>" to check for registered SPNs by account and "setspn -Q <spn>" to check if this is registered. What SPNs need to be configured are listed in the CRM installation & deployment guide. Based on your URL I asume you have configured ADFS, there is an additional spn to configure this is in the claims configuration guide. Both these documents are available here: Microsoft Dynamics CRM 2011 Implementation Guide

    Basicaly SPNs must be unique within the domain (registered to one account only) and must match the dns name used to connect to the server.


    Patrick Verbeeten
    www.patrickverbeeten.com
    www.wavextend.com

    • Proposed as answer by nrodriEditor Tuesday, March 13, 2012 8:32 PM
    Friday, March 9, 2012 3:34 PM
  • Hi Patrick,

    I'd done that I you indicate me, but still custom reports don't work.

    I've got the updated SPNs and checked SPN's by account and servername, and all it's completed.

    In the event Viewer of windows server, I can see an error of kerberos and NTLM, and this must be the problem, as you tell me.

    But, I don't understand why only wrongs with custom reports and works fine with standard report

    the Kerberos error is following:

    -------------------------------------------------------------

    An account is failed:

    Subject ID: NULL ID

    Account Name : -

    Domain Name: -

    Failure Reason: An Error occurred during Logon

    Status: 0xc000006d

    Sub Status: 0x8009030e

    Thank you very much for your help, Patrick.

    Monday, March 12, 2012 5:00 PM
  • 1) Browse the reports manager URL i.e . http://<servername>/reports and open org_mscrm folder -> custom reports folder -> mscrm_FetchdDatasource

    2) Check in Connect Using if we have selected "Credentials supplied by user"

    3) In the security tab on the left hand side we have following roles :-

    ReportingGroup has the Browser for Microsoft CRM role.

    SQLAccessGroup has the Publisher for Microsoft CRM role.
    4) check the same setting for org_mscrm folder -> custom reports -> mscrm_DataSource

    5) Restart the reporting services and try again.

    6) Also, if this does not resolve the issue try run report directly from SSRS using SystemUserID and OrganizationId as LogIn name and Password respectively from systemuserbase table in org_mscrm database.



    Arpita

    Tuesday, March 13, 2012 1:47 AM
  • Hi David,

    I agree with Patrick above post, this is definitely something to do with authentication and kerberos. Built-in reports run with an integrated authentication data source while any new reports you create using the CRM wizard will be configured to use a fetchXML datasource which needs SPNs configured for authentication.

    Can you check which SPN's are associated with the account and paste the info here please.

    > setspn -L service.account


    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com



    Tuesday, March 13, 2012 8:33 PM
    Answerer
  • We faced the similar issue after we upgraded CRM to rollup upgrade 12. Out of the box reports worked just fine but any custom reports created through the report wizard failed to execute. Here is the solution that resolved the issue:

    1) In IIS set the useAppPoolCredentials value to True  in windows authentication for the CRM Website.

    . Open IIS Manager. 
    . Expand the server and then select Sites. Then select the Microsoft CRM website. 
    . Under Management, select Configuration Editor. 
    . In the From: section above the properties select "ApplicationHost.config <location path=…"
    . For the "Section:" location, select system. Webserver > security > authentication > windows Authentication. 
    . In the properties page, set useAppPoolCredentials to True, then select Apply.

    2) Set the Service Principal Names (SPN) value for the service account running the CRM Application Pool – crm_app_svc

    . Added following SPN for all servers where CRM is deployed (In case of multiple server deployments for load balancing)– 
       HTTP/<servername>, HTTP/<servername>.<FQDN>

    Monday, March 4, 2013 2:09 PM
  • Hi Patrick,

    REPORTS CANNOT BE DISPLAYED Issue : Can you help me on the below its happening only for Custom reports after I installed the UR 17 in crm 2011 applications. After I restart the service its working fine but after sometime again the same issue happening

    Eventviewer Log : "Web service request GetDataSources to Report Server http://localhost/reportserver failed. Error: The request failed with HTTP status 503: Service Unavailable."

    Trace Log :

    Error: Exception of type 'System.Web.HttpUnhandledException' was thrown.
    Error Number: 0x8004832C
    Error Message: An error occurred during report rendering.
    Error Details: An error occurred during report rendering.
    Source File: Not available
    Line Number: Not available
    Request URL: (Removed for Security reasons)
    Stack Trace Info: [WebException: The request failed with HTTP status 503: Service Unavailable.]
    at Microsoft.Reporting.WebForms.Internal.Soap.ReportingServices2005.Execution.RSExecutionConnection.GetSecureMethods()
    at Microsoft.Reporting.WebForms.Internal.Soap.ReportingServices2005.Execution.RSExecutionConnection.IsSecureMethod(String methodname)
    at Microsoft.Reporting.WebForms.Internal.Soap.ReportingServices2005.Execution.RSExecutionConnection.SetConnectionSSLForMethod(String methodname)
    at Microsoft.Reporting.WebForms.Internal.Soap.ReportingServices2005.Execution.RSExecutionConnection.ProxyMethodInvocation.Execute[TReturn](RSExecutionConnection connection, ProxyMethod`1 initialMethod, ProxyMethod`1 retryMethod)
    at Microsoft.Reporting.WebForms.SoapReportExecutionService.LoadReport(String report, String historyId)
    at Microsoft.Reporting.WebForms.ServerReport.EnsureExecutionSession()
    at Microsoft.Reporting.WebForms.ServerReport.GetDataSources(Boolean& allCredentialsSet)
    at Microsoft.Crm.Web.Reporting.SrsReportViewer.SetExecutionCredentials(ServerReport reportObj)
    [CrmReportingException: An error occurred during report rendering.]
    at Microsoft.Crm.Web.Reporting.SrsReportViewer.SetExecutionCredentials(ServerReport reportObj)
    at Microsoft.Crm.Web.Reporting.RemoteSrsReportViewer.LoadReportAndSetParameters()
    at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
    at System.Web.UI.Control.PreRenderRecursiveInternal()
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    [HttpUnhandledException: Exception of type 'System.Web.HttpUnhandledException' was thrown.]
    at System.Web.UI.Page.HandleError(Exception e)
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    at System.Web.UI.Page.ProcessRequest()
    at System.Web.UI.Page.ProcessRequest(HttpContext context)
    at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
    at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    Monday, August 18, 2014 6:18 PM
  • Hi,

    Please anyone help on the above issue. Its urgent.

    Tuesday, August 19, 2014 8:07 AM
  • I faced the sam eissue and the PFE team helped resolve the issue.

    Below are the steps I followed to resolve the issue.Hope it helps!

    ------------------------------------------------------------------------------------------------------

    Refer the article : (http://support.microsoft.com/kb/2590774) .

    I used the bottom workaround portion. I saw that the SPN you added was for the wrong account.

    We also need to create the registry key that was referenced in the article to make this work.

    Next Steps :

    On the SRS server I went to the following location in the registry HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM and created a string value with the name SandboxClientSpn.tmc-crm then I right clicked on it and gave it a value of FetchXML SPN: HTTP/CRMfetch(tmc-crm)

    Once the key was in place I went to the command line and ran the following command to add the needed SPN Setspn –A HTTP/CRMFetch(tmc-crm) snoco\crmapppool

    After the SPN is added I ran the following command: klist purge(in the command prompt). This cleared the Kerberos tickets to ensure the SPN was going to be grabbed at the next authentication.

    Finally we performed an IISRESET on the CRM server and tested. The reports now work.

     

    Friday, August 29, 2014 4:43 PM
  • Hi Hina,

    Thanks for your reply .

    But problem here is for me is. The reports are running but some point of time its stops working and throwing the above error after we restart the reporting service again its starts working. I don't know what causes this to happen.

    Please help me in this cause.

    Thanks and regards,

    Sudhan XT

    Saturday, August 30, 2014 11:43 AM