locked
Error msg with Microsoft ICE 2.0 - Preview is unavailable (Could not create Direct3D 11 device.) RRS feed

  • Question

  • Hello Microsoft ICE Suport Team,
    I am running a MS ICE on a MacBook Air 13" running OSX. I have an original copy of Windows 7 Professional installed which I am using with the help of Parallels Desktop 10 for Mac.
    Yesterday afternoon I downloaded the latest version of MS ICE-2.0.3-for-64-bit-Windows (x64) (ICE-2.0.3-for-64-bit-Windows.msi), and was required to first download and install Visual C++ 2013 Runtime Libraries on my machine. I installed vcredist_x64.exe and was soon able to make a few panoramas last night. Then after making a couple of panoramans ICE suddenly stopped functioning and gave me the following error message:
    "Preview is unavailable (Could not create Direct3D 11 device.)
    Can you please suggest what night be going wrong? It was working perfectly and for it to suddenly malfunction suggest some bug or missing component.
    Do I need to install anything or reinstall vcredist_x64.exe?
    I was reading in the ICE forum that some people needed to install the free full featured version if Visual Studio Community 2013 (http://www.visualstudio.com/products/visual-studio-community-vs).
    I prefer not to install unnecessary software but if it is needed I will do it. Or would another single feature software that is required would suffice.
    I would greatly appreciate any help you may offer.
    Thanks in advance.
    Monday, March 2, 2015 10:06 PM

All replies

  • hello,

    Same problem on PC with windows vista : "Preview is unavailable (Could not create Direct3D 11 device.). Is it possible to re-install old version of ICE ?


    Thursday, March 12, 2015 3:59 PM
  • Quite similas message while trying to install: previews unavailable (could not initialize direct 3D)
    Woul appreciate any help
    Wednesday, April 1, 2015 6:10 PM
  • hello, Same problem on Lenovo 510G with windows 7

    Please excuse the google.translate to translate from Romanian to English :))

    Hello,

        
    I used ICE-1.4.4-for-64-bit Windows for over a year, is very satisfied with the operation and processing speed,
        
    learning the new features of the new version of ICE from here: http://research.microsoft.com/en-us/um/redmond/projects/ice/ here: http://grail.cs.washington.edu/projects / photomontage / - I decided the time to pass quickly to new version
        
    I had to install many programs working version, to install ICE-2.0.3-for-64-bit Windows
        
    Yesterday I installed the latest version of ICE I-2.0.3-for-Windows-64-bit on a 64 bit Lenovo 510G, two to three times, failing to make it functional no - ICE up in the running when to display the final image appears an error message - Could not initialize Direct3D 43 code
        
    I tried to fix this error, seeking to download Direct3D for installation but failed
        
    I dropped back to the old version for now, until I find better support or a tutorial with proper installation and solve problems that may occur in operation
        
    if you have a positive experience with the latest version please share it, may be useful to many of us.
        
    you tried a simple 3-5 panorama images - a work simpler in order to confirm the correct software?

    Look curiosity your results.

    My experience with ICE can see here:

    https://photosynth.net/view.aspx?cid=6550cc8a-eff3-452b-b929-a01d100290bb

     
    Good luck ... "pan"!


    Saturday, May 2, 2015 6:13 PM
  • It is possible, see also my post above.

    Good luck ... "pan"!

    Saturday, May 2, 2015 6:19 PM
  • I am having the same problem on Vista

    would be nice to have a solution by now

    Sunday, February 7, 2016 8:30 PM
  • Same problem here (Windows 7 on Mac Pro -- no joke, I am using Windows mainly for ICE!)

    Preview is unavailable (Could not create Direct3d 9 device.)

    This happens when I create more than three panoramas in the same session. A workaround is to restart ICE.


    • Edited by derandi4 Tuesday, July 26, 2016 6:10 PM
    • Proposed as answer by VauVe Sunday, August 21, 2016 5:24 PM
    Tuesday, July 26, 2016 6:10 PM
  • Hello, Win7 64 bit: version new does not show the image after stitching? Can be saved and see on file. Version 1.4.4 works but this new 2.0.3 (?) does not. It worked for some months but STOPPED to work when trying today. What o do, thanks.
    Sunday, August 21, 2016 5:27 PM