locked
Sata Addin Card issue RRS feed

  • Question

  • Hi,

    My PSU in my WHS blew the other day, everything was ok, except i was getting errors on the SATA PCI card I had, so after testing the hard drive that was plugged into is and finding that it was fine, i ordered a new Sata Card off Ebay, this time i went for a PCI-E one as I already have a gigabit NIC in one PCI port i figured for performance it would be best, the only thing is the issue still exisit even  though this card is a SIS based and last one was VIA, I have swithed the hard drives arround (my 500 samsung was in the card now its a 750 seagate as the samsung is faster) I Have even reinstalled WHS yet after the server trys to wite data to that disk in  the event log i get a couple of errors:


    The driver detected a controller error on \Device\Harddisk2.

    and

    The device, \Device\Scsi\SI31321, did not respond within the timeout period. (before this one said VIARAID instead of SI31321)

    I have updated the driver and sata card bios and the issue seemed to be resolved but after trying to copy some data accross the WHS with sync back it failed.

    any ideas?

    TIA

    Sunday, September 14, 2008 11:36 PM

Answers

  • Most likely this a hardware problem, probably one or more of the disks. If you're lucky it's just a few bad blocks. To fix please run chkdsk /f /r on all partitions.

    If this doesn't fix it check SMART parameters for each disk using a utility like Speedfan.  

    If this is also OK some (any) other hardware part could be the culprit
    Monday, September 15, 2008 12:10 AM
    Moderator