locked
More issues with ExchUCUtil RRS feed

  • Question

  • I've been working through issues with ExchUCUtil using information in other posts, but now I've come across an issue and can't seem to find a remedy.  The script appears to fail when it calls "get-organizationconfig".  As you can see from the Directory list below there is no command/script called get-organizationconfig.

     

     

    Mode                LastWriteTime     Length Name
    ----                -------------     ------ ----
    -a---         3/23/2007  12:21 AM      12188 AddReplicaToPFRecursive.ps1
    -a---         3/23/2007  12:21 AM      12605 AddUsersToPFRecursive.ps1
    -a---         3/23/2007  12:21 AM       8957 AntispamCommon.ps1
    -a---         3/23/2007  12:21 AM      21809 CheckInvalidRecipients.ps1
    -a---         3/23/2007  12:21 AM      35285 configure-SMBIPsec.ps1
    -a---         3/23/2007  12:21 AM       7738 Configure-UMMrasGruu.ps1
    -a---         3/23/2007  12:21 AM      19332 ConfigureAdam.ps1
    -a---         3/23/2007  12:21 AM      14558 enable-CrossForestConnector.ps1
    -a---         3/23/2007  12:21 AM      46190 Exchange2007.xml
    -a---         3/23/2007  12:21 AM      13948 Exchange2007Edge.xml
    -a---         3/23/2007  12:21 AM      11294 ExchUCUtil.ps1
    -a---         3/23/2007  12:21 AM      10061 Export-OutlookClassification.ps1
    -a---         3/23/2007  12:21 AM      12749 get-AntispamFilteringReport.ps1
    -a---         3/23/2007  12:21 AM      10101 get-AntispamSCLHistogram.ps1
    -a---         3/23/2007  12:21 AM      11179 get-AntispamTopBlockedSenderDomains.ps1
    -a---         3/23/2007  12:21 AM      10221 get-AntispamTopBlockedSenderIPs.ps1
    -a---         3/23/2007  12:21 AM      10946 get-AntispamTopBlockedSenders.ps1
    -a---         3/23/2007  12:21 AM      10153 get-AntispamTopRBLProviders.ps1
    -a---         3/23/2007  12:21 AM      10258 get-AntispamTopRecipients.ps1
    -a---         3/23/2007  12:21 AM      15485 get-setuplog.ps1
    -a---         3/23/2007  12:21 AM       8139 Get-UCPool.ps1
    -a---         3/23/2007  12:21 AM      11632 GetDatabaseForSearchIndex.ps1
    -a---         3/23/2007  12:21 AM      11527 GetSearchIndexForDatabase.ps1
    -a---         3/23/2007  12:21 AM      12344 install-AntispamAgents.ps1
    -a---         3/23/2007  12:21 AM       3717 MoveAllReplicas.ps1
    -a---         3/23/2007  12:21 AM      16937 new-TestCasConnectivityUser.ps1
    -a---         3/23/2007  12:21 AM      15100 ReinstallDefaultTransportAgents.ps1
    -a---         3/23/2007  12:21 AM      12485 RemoveReplicaFromPFRecursive.ps1
    -a---         3/23/2007  12:21 AM       3532 RemoveUserFromPFRecursive.ps1
    -a---         3/23/2007  12:21 AM      13089 ReplaceReplicaOnPFRecursive.ps1
    -a---         3/23/2007  12:21 AM      12606 ReplaceUserPermissionOnPFRecursive.ps1
    -a---         3/23/2007  12:21 AM       4290 ReplaceUserWithUserOnPFRecursive.ps1
    -a---         3/23/2007  12:21 AM       9550 Reset-AntispamUpdates.ps1
    -a---         3/23/2007  12:21 AM      10932 ResetAttachmentFilterEntry.ps1
    -a---         3/23/2007  12:21 AM      12407 ResetSearchIndex.ps1
    -a---         3/23/2007  12:21 AM      10177 uninstall-AntispamAgents.ps1


    PS C:\Program Files\Microsoft\Exchange Server\Scripts> exchucutil

    Failed to read permissions on the Exchange Organization and UM DialPlan Containers. Please verify you are a member of the Exchange Organization Administrators group or have sufficient privilege to read from this Active Directory object. Additional information follows: The term 'get-organizationconfig' is not recognized as a cmdlet, function, operable program, or script file. Verify the term and try again.

    Tuesday, July 3, 2007 10:04 PM

Answers

  • I figured it out.

     

    If anyone else experiences this issues:

    I was using Windows Powershell and not Exchange Management Shell.

    Thursday, July 5, 2007 8:08 PM