locked
MS CRM 3.0 The Request failed with HTTP status 401 : Unathorized. RRS feed

  • Question

  • Hi guys,

    Yes, sounds easy but..

    i have a mscrm server where sql 2005 sp2 and ms crm is installed on. when i log in to crm i use http://localhost and everything is working fine.
    but when i click on reports i get : The Request failed with HTTP status 401 : Unathorized.
    same happens when i go to : Settings ->Organization Settings -> System Settings. as far i have checked everything else is working.

    so far i have done following things:

    restart the server
    iisreset
    checked reports and reportserver
    rollup4 is on
    i can add new users


    and i use admin with all roles assigned. same error happens for the users to.
    Tuesday, January 12, 2010 12:09 PM

Answers

  • it might be that the user being used has not been succesfully added to the active directory OU groups where you installed crm.
    check your authetenciation methods also install fiddler and see what requests are being sent to the rm server and report server
    Tiaan van Niekerk http://crmdelacreme.blogspot.com Skype:tiaan.van.niekerk1
    • Marked as answer by Jim Glass Jr Wednesday, January 13, 2010 6:03 PM
    Tuesday, January 12, 2010 3:11 PM
  • Have a look at this post and see if you find anything that helps.  If you find nothing on the page, then I would open a ticket with Microsoft support because I think solving this will require someone to look at your environment.
    Best Regards, Donna
    • Proposed as answer by Donna EdwardsMVP Thursday, January 14, 2010 3:43 PM
    • Marked as answer by iCRM Monday, January 18, 2010 12:41 PM
    Thursday, January 14, 2010 3:43 PM

All replies

  • it might be that the user being used has not been succesfully added to the active directory OU groups where you installed crm.
    check your authetenciation methods also install fiddler and see what requests are being sent to the rm server and report server
    Tiaan van Niekerk http://crmdelacreme.blogspot.com Skype:tiaan.van.niekerk1
    • Marked as answer by Jim Glass Jr Wednesday, January 13, 2010 6:03 PM
    Tuesday, January 12, 2010 3:11 PM
  • You can install the SRSS Data Connector and see if that helps.   Even when CRM and SQL are on the same server it helps in some situations.
    Best Regards, Donna
    Tuesday, January 12, 2010 10:36 PM
  • its MSCRM 3.0 i dont beleve there is a SRSS Data Connector for 3.0?

    and i dont beleve its related to only reports because when i go to  Settings ->Organization Settings -> System Settings i get the same error.

    Wednesday, January 13, 2010 11:49 AM
  • Ok, have you tried Tiian's advice?
    Best Regards, Donna
    Wednesday, January 13, 2010 3:44 PM
  • tryied with fiddler but mscrm is running with https 443 and fiddler shows nothing. everthing is fine under AD / OU.

    Thursday, January 14, 2010 1:56 PM
  • Have a look at this post and see if you find anything that helps.  If you find nothing on the page, then I would open a ticket with Microsoft support because I think solving this will require someone to look at your environment.
    Best Regards, Donna
    • Proposed as answer by Donna EdwardsMVP Thursday, January 14, 2010 3:43 PM
    • Marked as answer by iCRM Monday, January 18, 2010 12:41 PM
    Thursday, January 14, 2010 3:43 PM
  • A.

    This error occurs if Microsoft Dynamics CRM and Reporting Services are installed on the same server, the server is running Windows Server 2003 or is a Microsoft Windows Small Business Server 2003, and Domain user was specified on the Specify Security Account page when Microsoft Dynamics CRM was installed.

    To add the necessary permissions, make the following change in Reporting Services Report Manager.

    1.

    On the server running Microsoft Dynamics CRM, use Microsoft Internet Explorer to open Reporting Services Report Manager. By default, Report Manager is located at http://localhost/Reports. If you renamed the virtual directory for Report Manager when you installed Reporting Services, use the virtual directory name you used rather than Reports.

    2.

    Click Show Details.

    3.

    Click the icon in the Edit column next to the folder for your organization.

    4.

    Click Security.

    5.

    Click New Role Assignment.

    6.

    On the New Role Assignment page, in the Group or user name box, enter the value of the service account name for ASP.NET:

    For English locales, enter NT Authority\.

    For other locales, open the setup log file with Notepad. By default, this file is located at <systemdrive>:\Documents and Settings\User\Application Data\Microsoft\MSCRM\Logs\crm30svrsetup.log

    1.

    Search for ServerInstallInfo.AspNetServiceAccountName.

    2.

    Look at the value in this line, and enter this value in the box.

    7.

    Select the check box next to Publisher for Microsoft CRM.

    8.

    Click OK.


    this did it.  thx Donna
    Monday, January 18, 2010 12:41 PM