locked
Email Router Keeps Dying RRS feed

  • Question

  • The Microsoft Email Router service keeps on dying. Has anybody experienced this as well? What could the reason be and how do I fix it?
    Friday, December 27, 2013 6:33 PM

All replies

  • It will all depend on the reason for the problems. It's possible that the settings for the router have just been lost and need to be restored. Try going on to the server that holds the email router, navigate to the folder in Program Files -> Microsoft CRM Email -> Service and you'll see an XML file in there called Microsoft.Crm.Tools.EmailAgent.SystemState - there should also be one in there called this is a recent copy of that file, just remove the original file (but make sure it's recoverable just in case) and remove the .bak extension from the backup and see if that fixes the problem. Beyond this, it's probably going to be a reinstall of the software which is what I usually end up doing.

    My usual problem is that the Microsoft CRM Email Router service stops and cannot be restarted. I tried restoring this file without any luck. To fix issues such as this, I performed a reinstall (actually uninstalled first and then reinstalled) but took screenshots of everything in the router's set up so that I could get it back. Once I'd done this, it worked again. It sounds a pain but if you're getting persistent problems, it does seem to solve them and only takes about 15 minutes (depending on how many environments you need to set up).

    Thursday, January 2, 2014 2:24 PM
  • There should be some relevant events in the Application Event log for the Email Router. Are there any ?

    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Friday, January 3, 2014 12:19 PM
    Moderator
  • what version and what update rollup are you on?

    make sure you have the latest UR installed.

    Saturday, January 4, 2014 3:32 PM