locked
Can't access other computers on wireless network RRS feed

  • Question

  • OneCare Circle seems to work, but I can't print, nor can I bring up Network places.  If I turn off the firewall on just one of the computers, everything works.  However, the settings are identical on both computers, and both are running XP (one is professional, one home).

    Saturday, July 26, 2008 2:33 PM

Answers

  • You don't want the "file and printer sharing for subnet and internet". It looks like you have configured the firewall correctly so I have no suggestions to offer other than to contact support. How to reach support - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    Sunday, July 27, 2008 4:55 AM
    Moderator
  • I some cases, setting the second option for subnet and Internet is just fine and resolves the problem. Where this might be an issue is if you are connected to a public network and have this enabled. It does not open up sharing to the Internet when you are behind a router that is under your control.

    Open OneCare on each of the computers.

    Click Change Settings

    On the firewall tab, click configure firewall

    If the network is shown as Public, click Change Location to change it to "Home or Work."

    Click the Advanced Settings button

    Click Network connections tab.

    If there are multiple active connections shown, you may need to disable the extras in your Windows network connections settings. (Network and Sharing Center, manage connections, in Vista; Right click My Network Places and select Properties on the Start menu in XP)

    On the Ports and Protocols tab, add a check mark next to File and Printer Sharing - for subnet and Internet if the first setting alone (after all of the above are verified) does not allow Sharing to work.

    If all of the above fail, please contact support.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

     

    Monday, July 28, 2008 3:42 PM
    Moderator

All replies

  • Do you have file and printer sharing enabled in the firewall settings of both computers?

     

    Saturday, July 26, 2008 2:49 PM
    Moderator
  • I have "file printing and sharing-for local network (subnet)" enabled, but not the second option which reads "file and printer sharing-for subnet and internet."

     

    If I understand the settings correctly, enabling the second one would mean sharing files to anyone on the internet, right?

     

     

    I should add a clarification also:  The computers in question are a laptop (XP Pro), and a desktop (XP Home).  Turning off the firewall on the laptop doesn't make any difference, but turning off the firewall on the desktop lets everything work.  This leads me to think that I have something wrong on the desktop, but I have looked at all the settings, and they are all the same on both computers.

    Saturday, July 26, 2008 4:05 PM
  • You don't want the "file and printer sharing for subnet and internet". It looks like you have configured the firewall correctly so I have no suggestions to offer other than to contact support. How to reach support - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    Sunday, July 27, 2008 4:55 AM
    Moderator
  •  JimR1 wrote:
    Do you have file and printer sharing enabled in the firewall settings of both computers? YES

     

    Sunday, July 27, 2008 5:46 AM
  • I some cases, setting the second option for subnet and Internet is just fine and resolves the problem. Where this might be an issue is if you are connected to a public network and have this enabled. It does not open up sharing to the Internet when you are behind a router that is under your control.

    Open OneCare on each of the computers.

    Click Change Settings

    On the firewall tab, click configure firewall

    If the network is shown as Public, click Change Location to change it to "Home or Work."

    Click the Advanced Settings button

    Click Network connections tab.

    If there are multiple active connections shown, you may need to disable the extras in your Windows network connections settings. (Network and Sharing Center, manage connections, in Vista; Right click My Network Places and select Properties on the Start menu in XP)

    On the Ports and Protocols tab, add a check mark next to File and Printer Sharing - for subnet and Internet if the first setting alone (after all of the above are verified) does not allow Sharing to work.

    If all of the above fail, please contact support.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

     

    Monday, July 28, 2008 3:42 PM
    Moderator
  • Thanks.  That was it.  I enabled subnet and internet on the desktop, but left it disabled on the laptop, and everything works fine, in both directions.  I'm behind a router on a security enabled wireless network.

     

    Monday, July 28, 2008 4:03 PM
  • Glad that it helped. :-)

    In a mixed wired/wireless network you'll often see this problem. It's one of the mysteries of the OneCare firewall and Windows networking. <g>

    -steve

     

    Monday, July 28, 2008 5:43 PM
    Moderator