none
A way to stop Windows from triyng to connect to mapped drives on user logon RRS feed

  • Question

  • Hello folks,

    we are deploying a multifactor authentication (MFA) product in our environment. Some of our users do have WebDAV mapped drives against a Sharepoint Server 2019 OnPremise.

    When uers logon to their profiles Windows actually tires to connect to those WebDAV mapped dirves. At this point user has still not been granted acces as access is granted once MFA is completed and this must be done accessing Sharepoint through a web browser.

    This fact generates lots of unsuccesfull access attempts in the MFA. Is there a way to stop Windows from triyng to connect (to send credentials) to mapped drives on user logon?

    Kindly appreciate your help,

    Best regards.

    Tuesday, August 23, 2022 10:03 AM

All replies

  • The simplest solution is changing how you map your drives away from a GPO configuration to a powershell script that has a triggered delay.
    Wednesday, August 24, 2022 5:12 PM
  • This is a good option, thanks for pointing it out.

    But this would mean assuming there is no such flag to instruct Windows to avoid it's default behaviour.

    Wednesday, August 24, 2022 7:47 PM
  • It will probably finish booting to the desktop, it will just take a while, as you are waiting for each mapped drive's time-out period to lapse before Explorer will finish loading. 
    Wednesday, September 7, 2022 4:56 PM
  • There is no long wait for explorer to open. User does not feel the issue.

    Friday, September 9, 2022 9:39 AM
  • The reason you can use this command is because the script works in a way that it will only run when a user logs on (so it won't run when you reboot your machine). This means that if you have mapped drives that are not necessarily used every time you log on, then once your computer starts up again, Windows will try to reconnect to those mapped drives.
    Monday, September 26, 2022 11:59 AM