locked
SATA controller reinstall after WHS install RRS feed

  • Question

  • After loading the SATA controller driver during the initial installation process, WHS did not accept/recognize the SATA controller.  I had to re-install the driver after the installation finished.  Following the second SATA controller install, the system recognized the controller and the attached SATA drive, and added the drive without incident.

    Hardware:  Compaq Evo D310; P4 2Ghz; 300 GB PATA, 160 GB PATA, 500 GB SATA on Maxtor SATA-150 controller card; 512 MB ram.
    Friday, April 20, 2007 11:44 PM

Answers

  • I suspect you only installed the SATA controller driver at one point in the WHS setup? There are two points where you will need to do that. The first is during the WinPE setup, very near the beginning. That's the one you probably got. The second is the "Press F6" prompt during text mode setup.
    Saturday, April 21, 2007 3:39 AM
    Moderator

All replies

  • I suspect you only installed the SATA controller driver at one point in the WHS setup? There are two points where you will need to do that. The first is during the WinPE setup, very near the beginning. That's the one you probably got. The second is the "Press F6" prompt during text mode setup.
    Saturday, April 21, 2007 3:39 AM
    Moderator
  • I never saw the text mode in the setup - maybe I was in the bathroom? In the install sequence, after initial "load add'l drivers" screen, there were no opportunities to install drivers again after the "Ready to install - no add'l user input req'd until setup complete" screen.  Does the "press F6" screen timeout and then reboot?  If so, that's a bad call - it should wait for input before proceeding.  Otherwise, things happen (like what happened to me).  Not a big deal, obviously, since I'm up and running OK now, but if it had happened during the "re-install/upgrade" option, I would have (did) lost (lose) the backups on that drive when I would have (did) add/ed that drive back to the system (sorry for the tense changes, but I'm talking hypothetical and real in the same sentence).  Anyway, thanks for your insight.  I think I'll add this to the suggestion list - ditch the second driver install and migrate the drivers from the pre-install load screen.
    Saturday, April 21, 2007 12:41 PM
  • I had a similar issue - added the drivers at the first graphical stage, then at the blue screen stage , F6 wouldn't work to allow me to add the drivers again at the second stage.  In fact, F6 wasn't registered at all - on the third reboot, I tried F2 and that worked, but F6 never allowed me to do anything (or even showed that it had been pressed).

     

    Saturday, April 21, 2007 6:41 PM
  • You have a very short window for the "Press F6" prompt to do any good. I think around 5 seconds, but it could be a little longer or shorter.

    There are really three stages to WHS setup. The first and third stages wrap around the second stage, which is the Windows Server 2003 setup (including text mode). I don't disagree that the installation could be smoother, but remember that the primary distribution channel is likely to be preinstalled on OEM hardware like the HP MediaSmart Server. They'll do the install once, right up to the OOBE stage, then clone the drive for all shipping units. Not a problem.
    Saturday, April 21, 2007 7:04 PM
    Moderator
  • I realise the 'press F6' window is short, but I tried several times, pressing F6 once, pressing it several times in a row, holding it down... nothing I tried would register the fact that I'd pressed F6. Probably more annoying is that once I'd done a fresh install, the SATA controller was recognised automatically without me having to do anything, so the driver was actually built into WHS in the first place, just wasn't recognised during the install...
    Saturday, April 21, 2007 9:03 PM
  • I have the same problem with pressing F6 does nothing. After that, it should press F2 to go in to Recovery Mode, I tried that, and it works, so it's not the keyboard or anything.
    Wednesday, April 25, 2007 11:28 PM
  • I had a simular problem too, but it was with the ethernet driver, not the SATA drivers which, luckily for me was provided during installation by SBS 2003. I too did not receive any prompt to press a key to add the driver, as I was given in beta 2. My problem however was quickly rectified after installation by manually adding it then. It is not as key as the SATA drivers as it doesn't stop the installation process, only means I don't have a Internet connection right off. I wonder why this is happening to some?

     

    It is true what Ken says, about most purchasing pre-installed units. But there are those few of us with less experiance, but who still wish to build our own and learn while we are doing it. This increases our knowlege base and it is just plain fun! A bit frustrating at times, but lots of fun over all.

     

    I leave odds that this issue will be ironed out by RTM. At least I sure hope so! lol

     

    Seree

    Wednesday, April 25, 2007 11:58 PM
  • It did actually show the prompt for pressing F6 to install RAID and SCSI drivers, but pressing F6 multiple times did nothing. After about 4-5 seconds, it prompts to press F2 to go into Recovery Mode. Pressing F2 then works, so it's not the keyboard.
    Thursday, April 26, 2007 2:50 PM
  • I am about to do the reinstall from Beta2 to CTP.

    On the WHS I have a primary drive on the mainboard controller that will be automatically recognized by WHS install. My second and third drive are on a Promise S150 TX2 (non RAID) controller. These are SATA drives my mainboard natively does not support. Beta2 did not automatically install this controller, so I expect CTP not to also.

     

    Reading the instructions I fear that CTP will install on the primary disk, ignoring the disks on my additional controller and leaving me no option to install it. There is no need show any errors because it has a working disk to install to. If this happens I will lose my data.

     

    Reading the above comments I get the impression that the F6 function does not work, but Ken did not confirm this.

     

    Will I get the option to install the additional driver (two times as Ken describes)?

    Does the F6 function in text mode work?

    Monday, April 30, 2007 10:37 AM
  • The F6 prompt does work, however I've never found it 100% reliable. Probably one time in 4 or 5 I see it fail to detect the F6 keystroke, even on a PC that has previously worked fine. If it doesn't work the first time, I usually just shut down, restart, and try again.
    Monday, April 30, 2007 11:39 AM
    Moderator
  • F6 prompt worked, everything installed correctly and as described.

     

    Make sure (like Ken mentioned) that you see every available controller/drive in the different steps in installation (WINPE and text mode).

     

    I still have an other problem though, I hoped CTP would have resolved. I will put that in a new thread.

    Tuesday, May 1, 2007 2:53 PM
  • Hi Guys,

     

    I have slightly different problem:

    My SATALink card installed just fine durning the setup stage and it's been working fine since...

    until the last automatic windows update! Now WHS can't recognize it and can't install it manually with the correct drivers.

    It looks to me as another reinstall unless someone found a way?

     

    Bart

    Wednesday, May 23, 2007 3:56 PM
  • Bart, this sounds like a completely new issue and I think it important for it to have a thread of it's own. Would you please open a new topic and make sure the subject line makes it clear automatic updates lost your disks? Thanks Bart,

     

    Seree

    Wednesday, May 23, 2007 7:21 PM
  • I didn't find a lot of information on the forums about how to get Windows Home Server to work with RAID, although I understand it is an "unsupported" configuration.  There are a lot of good things about RAID (I'm using RAID 5), mostly in the performance area, that are not completely addressed in the Windows Home Server world of "shadowed" folders.  But my intention is not to start an argument about whether or not to use RAID (there is plenty of that already on the forums), but rather how I got it working using RAID.

     

    First attempt (failure):

    1. Loaded RAID drivers from CD supplied with my RAID card (Promise TX4310) during the first part of install.

    2. During second part of install (when it reboots and tries to read the HD with the blue text screen) it could not find the RAID driver (was looking for it amongst the installation files that it copied to the HD).  Kept getting an error 14.  Typing the F6 key did not seem to work at all (maybe because it wants to load the driver before the part where it prompts you for additional drivers?).

    3. I did the install about 3 times; tried for "magic timing" of hitting the F6 key.  Nothing worked.

     

    Second attempt (success):

    1. Created a floppy disk (I hate them!) with the RAID drivers on it, with the txtsetup.oem file in the root.  Made sure that the correct driver was pointed to in the [default] section of this file.

    2. Inserted the floppy and the install DVD, made sure that the computer BIOS was set to boot from DVD drive first and started up the computer.

    3. When it prompted me for the driver associated with a HD volume (my RAID drives are the only fixed storage in the system), I pointed it at the floppy.

    4. At some point it rebooted for the second part of the install (I was away from the computer at the time) and it magically and automatically found the driver on the floppy without any input on my part and the install continued beautifully!

     

    So the key to a successful RAID install is to place the RAID driver on a floppy with the root directory of the floppy containing the txtsetup.oem file (and the [default] section in this file being set correctly).

     

    Here is my rant section:

    During the second reboot, the 2003 server install is capable of reading some portion of the HD in order to start the install itself (verified this by noticing that the HD lights were flickering).  Why can't the install copy the *bleeping* driver to that part of the HD and automatically read it?  Hmmm.....

     

    Monday, April 7, 2008 6:22 PM
  • ChrisWHS,  Thanks a lot. This is exactly what my system was doing.

    I had one variation that was critical...

    I was trying to load the ICH9R drivers and F6 was not doing anything, I followed your advise and put the drivers on the root folder of a floppy and set the [Default] driver. on next boot everything went great, it saw the drivers on the floppy and started loading, but then I got an error loading /$OEM$/iaStor.sys  Error code 18.  Took me a few minutes to realize I needed to move the driver files to a /$OEM$/ folder on the floppy. rather than try and figure out what needed to move/dependancies etc. I just copied the iaStor.inf, iaStor.cat, and iaStor.sys to the folder, rebooted and it work perfectly.

     

    Thanks

    Thursday, June 24, 2010 4:04 PM