locked
EXE works but IDE does not RRS feed

  • Question

  • I am developing a system to communicate (Ethernet) with an RFID tag reader.  My application uses 3 DLLs from the reader's manufacturer.  When I write a very simply progam to connect to the reader, it times out on the connection when running under the IDE (either Debug or Release).  When I build an executable (either Debug or Release) the executable runs every time.

    One other strange thing is that every once in a while the program connects when using the IDE but only very infrequently.  It always connects when I run the executable.  I'm running VS2008, .NET3.5 SP1

    Any ideas?

    • Moved by Amanda Zhu Thursday, August 14, 2014 9:44 AM not VS general issue
    Wednesday, August 13, 2014 3:26 PM

Answers

  • Hi Dave,

    Thank you for your post. But your issue is out of support range of VS General Question forum which mainly discusses the usage issue of Visual Studio IDE such as WPF & SL designer, Visual Studio Guidance Automation Toolkit, Developer Documentation and Help System and Visual Studio Editor.

    I am moving your question to the moderator forum ("Where is the forum for..?"). The owner of the forum will direct you to a right forum.

    You can consult your issue on some development forum based on the type of your program. Visual Studio Language Forums may help you: http://social.msdn.microsoft.com/Forums/vstudio/en-US/home?category=vslanguages

    In addition, if you are working with Windows Forms app. please consult on Windows Forms Forum:http://social.msdn.microsoft.com/Forums/windows/en-US/home?category=windowsforms

    If you are working with WPF app, please consult on WPF forum: http://social.msdn.microsoft.com/Forums/vstudio/en-US/home?forum=wpf

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Just Karl Wednesday, August 20, 2014 9:01 PM
    • Marked as answer by Just Karl Thursday, August 28, 2014 3:27 PM
    Thursday, August 14, 2014 9:44 AM
  • Might also try them over here.

    Windows Hardware Dev forums on MSDN

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    • Proposed as answer by Just Karl Wednesday, August 20, 2014 9:01 PM
    • Marked as answer by Just Karl Thursday, August 28, 2014 3:27 PM
    Thursday, August 14, 2014 1:09 PM

All replies

  • Hi Dave,

    Thank you for your post. But your issue is out of support range of VS General Question forum which mainly discusses the usage issue of Visual Studio IDE such as WPF & SL designer, Visual Studio Guidance Automation Toolkit, Developer Documentation and Help System and Visual Studio Editor.

    I am moving your question to the moderator forum ("Where is the forum for..?"). The owner of the forum will direct you to a right forum.

    You can consult your issue on some development forum based on the type of your program. Visual Studio Language Forums may help you: http://social.msdn.microsoft.com/Forums/vstudio/en-US/home?category=vslanguages

    In addition, if you are working with Windows Forms app. please consult on Windows Forms Forum:http://social.msdn.microsoft.com/Forums/windows/en-US/home?category=windowsforms

    If you are working with WPF app, please consult on WPF forum: http://social.msdn.microsoft.com/Forums/vstudio/en-US/home?forum=wpf

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Just Karl Wednesday, August 20, 2014 9:01 PM
    • Marked as answer by Just Karl Thursday, August 28, 2014 3:27 PM
    Thursday, August 14, 2014 9:44 AM
  • Might also try them over here.

    Windows Hardware Dev forums on MSDN

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    • Proposed as answer by Just Karl Wednesday, August 20, 2014 9:01 PM
    • Marked as answer by Just Karl Thursday, August 28, 2014 3:27 PM
    Thursday, August 14, 2014 1:09 PM
  • Hello,

    If all else fails, ask the reader's manufacturer.

    Karl


    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer.
    My Blog: Unlock PowerShell
    My Book: Windows PowerShell 2.0 Bible
    My E-mail: -join ('6F6C646B61726C406F75746C6F6F6B2E636F6D'-split'(?<=\G.{2})'|%{if($_){[char][int]"0x$_"}})

    Wednesday, August 20, 2014 9:02 PM