locked
SMB and NFS networking problems RRS feed

  • Question

  • I had previously used WHS V1 to stream my media (Bluray and DVD .iso files) via my GB network without any problems.  I recently shared my videos folder both via smb and NFS in order to connect my Dune media streamer.  I can succesfully connect to the SMB share although there is alot of stuttering which I assume is poor speed performance.  I then tried to setup an NFS share which I succesfully did on the Vail server but then the dune connects, the videos folder is empty.  Is there any settings I can fiddl with in order to try and improve my streaming speeds via smb?  Also when I make a shre to everyone (no username and password needed) the device connects but the folder is empty.
    Tuesday, March 22, 2011 3:25 PM

All replies

  • When NFS behaves like that it's usually a permissions problem, the login doesn't have any access to the files/directories in the NFS share, so you'll have to grant access to the NFS login user.

     As for the performance problem, can't help there without knowing more about your hardware.  You're not running Vail in a virtual machine, are you?

     


    Bob Comer - Microsoft MVP Virtual Machine
    Tuesday, March 22, 2011 8:05 PM
  • I have a Dell PowerEdge 2900 with 4GB ram and a Broadcom NetXtreme II dual port GB NIC all connected to a dell power connect 48 port GB switch.  For the NFS share I have allowed anonymous users which I thought should give anyone read access on the LAN.  Although giving everyone read access on SMB gives me a blank folder when accessing it via my Dune media player as well. This is not using a virtual machine.

     

    Thanks 

    Tuesday, March 22, 2011 8:19 PM
  • Are there settings from within the NIC that I should look into?
    Tuesday, March 22, 2011 8:20 PM
  • That should definitely be enough hardware to handle the speed.  You might try turing off all TCP/UDP offloading in the NIC's hardware properties, it might be getting in the way and I've seen some problems with broadcom adapters from that.  Otherwsise how are the 2 NIC ports set up?  (DHCP, fixed IP address, same subnet/gateway, teamed, ... ?)

    It sounds kind of like Dune Media player may require more than just read access, but I don't have any experience with that.  You can try granting read/write to the NFS share just to see if it makes any difference.

     

     


    Bob Comer - Microsoft MVP Virtual Machine
    Tuesday, March 22, 2011 8:43 PM
  • Well turning off TCP offloading in the NIC fixed the streaming hiccups.  THANK YOU!  Now any ideas why sharing folders without requiring username and pw via smb shows an empty folder?
    Tuesday, March 22, 2011 10:21 PM
  • >Well turning off TCP offloading in the NIC fixed the streaming hiccups. THANK YOU!

    Cool!  That TCP offloading seems to get in the way more than it ever helps, I don't know why they keep pushing it.

    I really don't know on the folder thing, but I'll try and figure it out.  It'll probably take me a bit, I've already taken down my Vail test machine.  Give me a day or two and I'll be able to test again (or someone else might chime in with the answer.)

     


    Bob Comer - Microsoft MVP Virtual Machine
    Wednesday, March 23, 2011 1:13 PM
  • I couldn't recreate the problem, so I don't know what's happening.  It could be something to do with your Dune device.  Maybe asking them what the problem might be could get you an answer.

    That aside, I just used the normal Vail guest account for my testing, did you do it another way?

     


    Bob Comer - Microsoft MVP Virtual Machine
    Thursday, March 24, 2011 1:00 PM
  • The guest account I believe still requires the username "guest".  I use the sharing console under server manager to share a specified folders without authentication using smb.
    Thursday, March 24, 2011 5:47 PM
  • Interesting, I never tried that.  Guest is kind of a catchall and shouldn't need to be entered, any incoming connections should default to it if the user name doesn't match an existing user. (At least that's how I thought it would work, but I never really did much work with it.)

    I'll see if I can do what you did and if it makes any difference on my machines.

     

     


    Bob Comer - Microsoft MVP Virtual Machine
    Thursday, March 24, 2011 6:22 PM
  • I haven't been able to figure out exactly what you did, do you have a
    link or can you describe it a bit?  Maybe then I can figure out what's
    going wrong.
     
    I did verify that guest does not need to be entered to map a drive to
    a share, it is the catchall as I described.  Maybe you can try that?
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Saturday, March 26, 2011 3:03 PM