none
Upgrading Solution from Visual Studio 2013 to Visual Studio 2017 RRS feed

  • Question

  • I am trying out Visual Studio 2017 in a solution I had created in Visual Studio 2012 and migrated to Visual Studio 2013. The solution is composed of four projects, two of which are ASP.NET MVC while the others are Class Libraries. One of the MVC web applications, which uses ASPNET Membership Provider (Internet Accounts) is giving me the error as shown in the screenshot. The other MVC application which uses AD Accounts does not trigger any errors and runs fine.

    Anyone encountered the same issue? Cannot find much to go on.


    Tuesday, July 4, 2017 2:27 PM

All replies

  • Hi tech-dev_mt,

    Welcome to the MSDN forum.

    Refer to your description, your issue is about the ASP.NET MVC development. Since our forum is to discuss the Visual Studio WPF/SL Designer, Visual Studio Guidance Automation Toolkit, Developer Documentation and Help System, and Visual Studio Editor, please redirect to this appropriate forum: https://forums.asp.net/1146.aspx/1?MVC and start a new thread to seek for a more professional support, thank you for your understanding.

    If you have any other issue about VS IDE in the future, please feel free to let me know, have a nice day.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, July 5, 2017 2:30 AM
  • This is not an ASP.NET MVC issue. It is a Visual Studio issue.
    Wednesday, July 5, 2017 7:20 AM
  • Hi tech-dev_mt,

    Thank you for your update and sorry for my any misunderstanding.

    The 500 error is a general message and you need to see the detail error information, you can go to Event Viewer and check if there recorded any error or waring about this issue or not, please check this similar issue: Deploying website: 500 - Internal server error, some other community members shared the troubleshot methods to analysis this error 500 and you can have a look at it.

    >> One of the MVC web applications, which uses ASPNET Membership Provider (Internet Accounts) is giving me the error as shown in the screenshot.

    Please try to create a new ASP.NET MVC application and use the ASP.NET Membership Provider (Internet Accounts), then test this issue will occur or not? It can help us this issue is caused by the Membership Provider (Internet Accounts), VS 2017 or your application.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, July 6, 2017 2:35 AM