none
More on using Unix dhcpd to manage a Windows 2008 HPC Cluster

    Question

  • We've decided to replace the Microsoft DHCP server, and just dhcpd to manage both the Windows and Linux sides of our cluster.  We've managed to get the Windows nodes to boot by assigning the following configuration to the windows nodes:
      host abe0680 {
         hardware ethernet 00:15:C5:FD:2C:C6;
         fixed-address 10.1.66.172;
         option domain-name-servers 10.1.69.56;
         filename "Boot\x64\WdsNbp.com";
         option vendor-class-identifier "PXEClient";
         next-server 10.1.69.56;
      }

    When we want the node to boot into Linux, we apply different (Linux-specific) netboot configuration.  This way, we can change the number of nodes that are in Linux or Windows based on our expected workload, with a script and a reboot.  This works pretty well.

    However, WDS can't image/provision a new node.  Does anyone know what the DHCP configuration should look like when we're trying to boot WinPE for provisioning?

    Thanks,
    -Luke
    Monday, October 12, 2009 8:12 PM

Answers

  • if the node is part of the cluster, the reason it is not being re-imaged, might be as simple as
    a) you added the node to your cluster as a pre-configured node or the node template assigned to the node has no items in it.
    b) the node needs to be re-booted to pxe -- and somehow the OS command to the re-boot is not workgin because o something.
    c) the node is powered off...

    we should be able to re-image a node that is part of the cluster.
    if you can post  the items in the 'priovisioning log' it might help figure out what is going on.
    thanks
    -parmita
    pm
    Monday, November 2, 2009 11:56 PM
    Moderator

All replies

  • Hi Luke,

    maybe this is due to the "Respond only to PXE requests only from existing CNs" checkbox in the cluster management console. Are new nodes recognized if you set this to "Respond to all PXE requests" ?

    -Michael
    Thursday, October 15, 2009 11:58 AM
  • No luck with setting it to "Respond to all PXE requests".

    I'm just trying to re-image an existing node as my first test, not add a new ones -- at least for now.

    EDIT: It's worth mentioning that the nodes boot into the version of Windows installed on the local drive with the above configuration, and won't boot into anything if it's absent.  But how to get them to boot into WINPE when they need to be provisioned?
    Thursday, October 15, 2009 7:12 PM
  • hm. are you sure that the wdsnbp.com file is being downloaded ? You can see this either on the local node's output during Boot or on the headnode in the Application log. Look for events with source "deployment-services-diagnostics". At our site the linux dhcpd wasn't able to handle the "\" in the path correctly and returned a wrong path to the client.

    -Michael

    Friday, October 16, 2009 6:47 AM
  • Hi  Luke,

    I take you are currently applying a node template to the node you want to reimage?

    Next thing, please check what boot filename is assigned from the WDS Server. Unfortunately wdsutil does not work on my Win2008 HPC Headnode but i have another just win2008 + WDS machine for that.
    You can check with wdsutil /get-device /device:<AD-Computer-Name>.
    Otherwise try the eventlog again to see what bootfiles are passed to the node.
    In my opinion Boot\x64\WdsNbp.com redirects you to abortpxe.com and boots the next device.

    You can also try to set it to the pure PXE boot file named pxeboot.n12 which will directly boot the boot.wim and install if the unattended settings are set up correctly. However this will now happen everytime the node boots, so would have to set your dhcp config back manually to Boot\x64\WdsNbp.com.

    At least this would give a direction were the problem is.

    Edit:// Just got this from my old documentation. At that time we ran the cluster dual boot as well. We used the following flags in addtition to yours:
    Option 60 - Client Identifier set to "PXEClient" 
    Option 66 - Boot Server Host Name set to server name i.e. ccswoody (ccswoody is the headnode)
    Option 67 - Boot File Name set to the boot file name,for WDS this would be Boot\x64\pxeboot.com (probably win2003 so yours should be correct)
    (use / rather than \ )

    I'm not sure which of these Options overlap with your settings.

    Johannes
    JH
    • Edited by Johannes_de Friday, October 16, 2009 9:38 AM Added information
    Friday, October 16, 2009 9:31 AM
  • HI,

     Look at : http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=463f9b67-cf0e-4318-b346-1c2f6dc57abb

     About your issue, are you trying just to re-image a existing node ?
     By default, if the server is already into the cluster, the head node will not redeploy it !

     So if you want to redeploy it, you have two solution :
               remove the node from the cluster (put it of line then delete it), reboot it and replay the installation
               into the cluster MMC there is an option "re-image" (http://technet.microsoft.com/en-us/library/cc947640(WS.10).aspx)

    Best regards, Tom
    Tuesday, October 20, 2009 2:11 PM
  • if the node is part of the cluster, the reason it is not being re-imaged, might be as simple as
    a) you added the node to your cluster as a pre-configured node or the node template assigned to the node has no items in it.
    b) the node needs to be re-booted to pxe -- and somehow the OS command to the re-boot is not workgin because o something.
    c) the node is powered off...

    we should be able to re-image a node that is part of the cluster.
    if you can post  the items in the 'priovisioning log' it might help figure out what is going on.
    thanks
    -parmita
    pm
    Monday, November 2, 2009 11:56 PM
    Moderator