locked
Can I install everything on Windows 7 RRS feed

  • Question

  • Hi there,

    I'm trying to install the Zentity 2.0 server on Windows 7 but just as it's completing it throws an error saying it failed to add users to the Zentity Group and then it pretty much rollsback.

    Is it OK to install on Windows 7 or would I be better blowing away the machine and installing Windows Server 2008 R2.

    Cheers,

    Aidan.

    Wednesday, July 13, 2011 9:29 PM

All replies

  • Hi there,

    To answer my own question:

    I only had the Windows SDK tooling from Visual Studio 2010.

    The server install ran fine once I got the full Windows SDK for Winodws 7 and .NET 4.

    Note: there's a gotcha with the full Windows SDK and Visual Studio 2010 SP1 - basically the SDK has an older version of the VC++ 2010 redistrib. - see here:  http://msdn.microsoft.com/en-us/visualc/gg697159

    Cheers,

    Aidan.

     

    Thursday, July 14, 2011 11:00 AM
  • Hi there,

    Actually my suspicions were correct - it wasn't because of the Windows SDK.

    I carried out the whole uninstall/install of Visual Studio and the Windows SDK as outlined in the link above and I unintalled the Zentity Client and Server as well.

    When I tried installing the Zentity Server again I ended up with the same message relating to adding users to the Zentity Group.

    Again I was working from home and so I decided to fire up my VPN connection to the work domain.

    Once I was connected to the domain it looks like the install needed the NTLM authentication and guess what it installed fine again.

    So I reckon that if the admin account that you choose is a domain account you're going to need the domain authentication to complete the install.

    Cheers,

    Aidan.

    Friday, July 15, 2011 7:43 PM
  • Hi there,

    I guess I should really be following my own advice.  When I tried the President Data Import samples I got the following error:

     

    Create-ZentityDataModelFromXmlFiles : Exception calling "CreateDataModel" with "3" argument(s): "SOAP security negotiat
    ion with 'http://localhost:9090/Services/DataModelingService' for target 'http://localhost:9090/Services/DataModelingSe
    rvice' failed. See inner exception for more details."
    At C:\Program Files (x86)\Zentity\PowerShell scripts\Zentity-ConfigureDataModel.ps1:44 char:44
    +     if((Create-ZentityDataModelFromXmlFiles <<<<  $rdfsXmlFileLocation $schemaXmlFileLocation $modelNamespace) -eq $t
    rue)
        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Create-ZentityDataModelFromXmlFiles

     

    So once again I connected to my work domain via VPN and then guess what it finally gave me the message:

     

    "A new Data Model has been added and an update is required to reflect the changes. Press any key to continue"

     

    And then it advised me all was well with the following output:

     

    Update is in Progress
    Generation of Assemblies done.
    Stopping the Publishing Service. Please wait
    Copying of Assemblies Done.
    Configuration files Update Complete.
    Starting the Publishing Service. Please wait
    Zentity Clients are ready to be used by the new Assemblies
    Data Model Generation Done.

     

    Cheers,

    Aidan.

     

     

    Sunday, July 17, 2011 3:54 PM