none
Disable "Mark as Answer" button on initial click

    Question

  • It'd be nice if the "Mark as answer" button would be disabled on the first click.  I use Windows Live on my computer and I subscribe to the alerts, so occasionally (usually a few times a day) I'll get something like 5-10 alerts popping up in rapid sequence that cover the entire left 8th of my screen telling me that an answer has been marked in a post I'm subscribed to.  When I finally go to the page to view it, it appears the user has marked my post as an answer about 5 times.  My only guess is that this happens because the post doesn't immediately appear to be marked the instant the user clicks "Mark as answer". 

    This same functionality is used with the "Submit" button to prevent double-posts, and it would sure reduce the "annoyingness" of the Windows Live alerts if the user can't hit the button 5 times in 5 seconds, thus creating a slew of little blue boxes for those of us using alerts.
    David Morton - http://blog.davemorton.net/
    Thursday, August 14, 2008 3:12 PM

All replies

  • Although, I don't subscribe to any posts - particularly for reasons like this - I see this a lot. That is, here is no feedback that you have 'submitted' a post or marked a post. Personally, I find myself spamming buttons because they just don't seem to work. Inevitably, this causes problems and unnecessary traffic (possibly? I don't know).

    Stephen J Whiteley
    Wednesday, August 20, 2008 1:25 PM
  • This is something that I'm going to try to improve in our Oct. release. It's definitely on our list of thisngs to do though.

    Thanks
    Matt Fraser, STO Forums Software Developer
    Wednesday, August 20, 2008 4:23 PM