locked
Cryptographic errors with WGA???? RRS feed

  • Question

  • Hi there,

     

    Hoping someone can help me resolve this issue with WGA. I came back from vacation and my Computer is telling me that my version of windows is not genuine. I have an E Machine H3065. This is what the MGADT is telling me.

     

    Diagnostic Report (1.5.0545.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Cryptographic Errors Detected
    Windows Product Key: *****-*****-J8BM6-MXPH6-3R2BW
    Windows Product Key Hash: YMRVitCEjlJfwDQfjDvm97FbWA4=
    Windows Product ID: 55277-OEM-2111907-00103
    Windows Product ID Type: 2
    Windows License Type: OEM SLP
    Windows OS version: 5.1.2600.2.00010300.2.0.hom
    ID: dd97f4c7-4c11-4263-88e9-049e11c5b0a6
    Is Admin: Yes
    AutoDial: No
    Registry: 0x0
    WGA Version: Failed to retrieve file version. - 0x0
    Signed By: N/A, hr = 0x800b0100
    Validation Diagnostic:
    Resolution Status: Cryptographic Errors Detected

    System Scan Data-->
    Scan: Complete
    Cryptography: Complete

    Notifications Data-->
    Cached Result: 5
    File Exists: Yes
    Version: 1.5.540.0
    WgaTray.exe Signed By: Microsoft
    WgaLogon.dll Signed By: Microsoft

    OGA Data-->
    Office Status: 109
    Office Diagnostics: 77F760FE-275-80070002_7E90FEE8-171-80070002

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 6.0; Win32)
    Default Browser: C:\Program Files\Internet Explorer\iexplore.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Allowed
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>dd97f4c7-4c11-4263-88e9-049e11c5b0a6</UGUID><Version>1.5.0545.0</Version><OS>5.1.2600.2.00010300.2.0.hom</OS><PKey>*****-*****-*****-*****-3R2BW</PKey><PID>55277-OEM-2111907-00103</PID><PIDType>2</PIDType><SID>S-1-5-21-3580701330-605206068-3325160670</SID><SYSTEM><Manufacturer>System Manufacturer</Manufacturer><Model>Product Name</Model></SYSTEM><BIOS><Manufacturer>Phoenix Technologies, LTD</Manufacturer><Version>TCB425G</Version><SMBIOSVersion major="2" minor="3"/><Date>20040318000000.000000+000</Date><SLPBIOS>EMACHINES</SLPBIOS></BIOS><HWID>00EB3E570184A05F</HWID><UserLCID>1009</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Mountain Standard Time(GMT-07:00)</TimeZone></MachineData>   <Software><Office><Result>109</Result><Products/></Office></Software></GenuineResults> 

     

    Hope you can help. Thanks

    Mneenee

     

    Monday, September 18, 2006 3:31 PM

Answers

  • Please reinstall the correct WGA Notifications version.

     

    http://go.microsoft.com/fwlink/?linkid=69498

     

    It seems you have tried to move it without correct instructions.

     

    -phil

    Monday, September 18, 2006 5:16 PM
  • Well I tried that and it worked at first but after installing updates and rebooting it came back????  The star is not on my sys tray any more only on start up screen, but still can't update. Not sure what to do now? Please advise.

     

    Thanks much

     

    Mneenee

    Monday, September 18, 2006 6:01 PM
  • mneenee,

    Go to www.microsoft.com/genuine and click validate. that should clear up all your issues. If not, Please run the diagnostics tool again and repost here.

    Thanks,

    Monday, September 18, 2006 6:04 PM

All replies

  • Mneenee,

    Rerun the mgadiag utility and click the "Resolve" button on the Windows tab.  It has the ability to correct some cryptographic errors.

    Let us know how you do.

    Monday, September 18, 2006 3:39 PM
  • I did that it didnt work.

    Diagnostic Report (1.5.0545.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Cryptographic Errors Detected
    Windows Product Key: *****-*****-J8BM6-MXPH6-3R2BW
    Windows Product Key Hash: YMRVitCEjlJfwDQfjDvm97FbWA4=
    Windows Product ID: 55277-OEM-2111907-00103
    Windows Product ID Type: 2
    Windows License Type: OEM SLP
    Windows OS version: 5.1.2600.2.00010300.2.0.hom
    ID: dd97f4c7-4c11-4263-88e9-049e11c5b0a6
    Is Admin: Yes
    AutoDial: No
    Registry: 0x0
    WGA Version: Failed to retrieve file version. - 0x0
    Signed By: N/A, hr = 0x800b0100
    Validation Diagnostic:
    Resolution Status: Cryptographic Errors Detected

    System Scan Data-->
    Scan: Complete
    Cryptography: Complete

    Notifications Data-->
    Cached Result: 5
    File Exists: Yes
    Version: 1.5.540.0
    WgaTray.exe Signed By: Microsoft
    WgaLogon.dll Signed By: Microsoft

    OGA Data-->
    Office Status: 109
    Office Diagnostics: 77F760FE-275-80070002_7E90FEE8-171-80070002

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 6.0; Win32)
    Default Browser: C:\Program Files\Internet Explorer\iexplore.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Allowed
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>dd97f4c7-4c11-4263-88e9-049e11c5b0a6</UGUID><Version>1.5.0545.0</Version><OS>5.1.2600.2.00010300.2.0.hom</OS><PKey>*****-*****-*****-*****-3R2BW</PKey><PID>55277-OEM-2111907-00103</PID><PIDType>2</PIDType><SID>S-1-5-21-3580701330-605206068-3325160670</SID><SYSTEM><Manufacturer>System Manufacturer</Manufacturer><Model>Product Name</Model></SYSTEM><BIOS><Manufacturer>Phoenix Technologies, LTD</Manufacturer><Version>TCB425G</Version><SMBIOSVersion major="2" minor="3"/><Date>20040318000000.000000+000</Date><SLPBIOS>EMACHINES</SLPBIOS></BIOS><HWID>00EB3E570184A05F</HWID><UserLCID>1009</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Mountain Standard Time(GMT-07:00)</TimeZone></MachineData>   <Software><Office><Result>109</Result><Products/></Office></Software></GenuineResults> 

    Just says to contct Microsoft. Also I found a post (below) with a similar problem and tried these steps as well. This also hasnt solved the problem?

    The issue seems to lie with the "unknown" signature that is coming up more commonly now. The "unknown" signature denotes a problem with detecting digital signatures.

    Can you try these steps? You can also refer to this article for further information: http://support.microsoft.com/Default.aspx?kbid=813442

    1.

    Click Start, and then click Run.

    2.

    In the Open box, type cmd, and then click OK.

    3.

    At the command prompt, type "regsvr32 softpub.dll", and then press ENTER.

    4.

    Click OK when you receive the message that DllRegisterServer in Softpub.dll succeeded.

    5.

    Repeat steps 1 through 4 for the following files: Wintrust.dll, Initpki.dll, Dssenh.dll, Rsaenh.dll, Gpkcsp.dll, Sccbase.dll, Slbcsp.dll, Mssip32.dll, and Cryptdlg.dll. Remember to put regsvr32 in front of al the dll's in mention. ("regsvr32 wintrust.dll")

    "regsvr32 wintrust.dll"

    "regsvr32 Initpki.dll"

    "regsvr32 Dssenh.dll"

    "regsvr32 Rsaenh.dll"

    "regsvr32 Gpkcsp.dll"

    "regsvr32 Sccbase.dll"

    "regsvr32 Slbcsp.dll"

    "regsvr32 Mssip32.dll"

    "regsvr32 Cryptdlg.dll"

    6.

    Type exit, and then press ENTER to quit Command Prompt.

    After you re-register all of the DLL's, restart and, you should be good to go.

     

    Thanks for your help

    Mneenee

    Monday, September 18, 2006 4:01 PM
  • Please reinstall the correct WGA Notifications version.

     

    http://go.microsoft.com/fwlink/?linkid=69498

     

    It seems you have tried to move it without correct instructions.

     

    -phil

    Monday, September 18, 2006 5:16 PM
  • Well I tried that and it worked at first but after installing updates and rebooting it came back????  The star is not on my sys tray any more only on start up screen, but still can't update. Not sure what to do now? Please advise.

     

    Thanks much

     

    Mneenee

    Monday, September 18, 2006 6:01 PM
  • mneenee,

    Go to www.microsoft.com/genuine and click validate. that should clear up all your issues. If not, Please run the diagnostics tool again and repost here.

    Thanks,

    Monday, September 18, 2006 6:04 PM
  • That fixed it thank you sooooo much.

     

    Mneenee

    Monday, September 18, 2006 10:40 PM