none
.AWO folders after backup is restored RRS feed

  • Question

  • Because of various problems I had been having a few weeks ago I did a reinstall of my WHS.  After the reinstall I restored my folders and files from the built in WHS backup/restore feature and now in each of my folders I am left with an empty .AWO folder.  Because there are dozens if not hundreds of these folders I would like to know of a command I can run to remove each of these emply folders.  I have manually deleted some but I guess there is a simpler way.  I have not been a command prompt person since the DOS days and I cannot find what I need via Google.  I am also curious what the purpose is of these folders and I cannot find any info on that either.

    Thursday, September 16, 2010 1:27 PM

All replies

  • I don't know where the .awo folders came from, but I would use PowerShell and a command along these lines to remove those folders:

    get-childitem . -filter .AWO -force -recurse | remove-item -recurse -force
    I think that's even right... :)
    I'm not on the WHS team, I just post a lot. :)
    Thursday, September 16, 2010 2:21 PM
    Moderator
  • I think the ASUS Web Storage add-in creates

    those folders.

     

    /Per

    Friday, September 17, 2010 6:21 AM
  • I did use the Asus web storage briefly out of curiosity.  I have heard of PowerShell but never used it.  Would I simply enter the command at a prompt and from what Drive would I need to be .  Would I simply enter the command from the C:\ prompt like below and that should remove each of the .AWO folders from my shared and duplicated drives.  I wondered if WHS would accept the same command as say Win 2003 because of the tombstones.

     

    get-childitem . -filter .AWO -force -recurse | remove-item -recurse -force

    Friday, September 17, 2010 2:26 PM
  • You would run that at a PowerShell prompt.
    I'm not on the WHS team, I just post a lot. :)
    Friday, September 17, 2010 4:36 PM
    Moderator
  • I don't seem to have that program installed and was just following directions on how to obtain this from windows udpate but all I get when I try to manually do windows update is a screen saying that I have to enter the windows update to my IE trusted sites which I apparently did this before but I still cannot access the window update manually.  I am running WHS with PP3.  Below are the instructions I was trying to follow.

     

    http://www.home-server-addins.com/archives/311

     

    Friday, September 17, 2010 5:58 PM
  • For problems with the installation and use of third party add-ins, the creator of the add-in you're having difficulty with is going to be your best resource. I don't use Advance Admin Console, or really any add-ins, on my production server...
    I'm not on the WHS team, I just post a lot. :)
    Friday, September 17, 2010 6:34 PM
    Moderator
  • I was able to find the find the powershell program and get in installed now when I try to execute the command you mention I get an error.  I guess it relates to me now knowing or being able to tell from what you typed exactly where spaces exist in the command.  I am doing this connected to my server from offsite through the web.  I have tried a few different ways and get the same error.

     

    "the term getchilditem is not recognized as a cmdlet, function, operating program or script file.  Verify the term and try again"

    Friday, September 17, 2010 7:24 PM
  • Every character is important. You copy, you paste, you run. What's the problem?
    I'm not on the WHS team, I just post a lot. :)
    Friday, September 17, 2010 11:47 PM
    Moderator