locked
Email Router and Exchange 2007 RRS feed

  • Question

  • OK, goign nuts here in between searching for a solution and solving my dilemma...

    Set-up CRM4 with the email router with forwarding mailbox (update Rollup 3), an exchange 2003 and a 2007, a CAS server.

    I am in a migration from exchange2003 to 2007, so I moved the mailbox of the forwarding mailbox of CRM4 and since then, I want to rip my hair off.

    I was able to get the set-up to send email correctly from CRM (needed to add the "send-as" permission fo it to work), but I cannot figure out how to get the emailrouter to go get the emails in the box!!!
    I either get timeout errors, or the "404: not found" depending on my configurations tests.
    When running the test of the configuration manager, it goes on and on until timing out.

    Should I have the CAS role on the exchange server?
    Should I point for the incoming setting of the email router to the https of the Exchange 2007 itself or the CAS server?
    I ahve tried running the email router service as "local service", a domain admin account and the crm mailbox account: Which shold it be???

    I have een searching this group and the net for some "plain simple configuration when using exchange2007" on how to set things up, but for some reason, I can't find the solution anywhere (and this seems like a very general and often occuring problem).

    Configuration Profiles tab (Incoming profile) (Advanced tab has default settings)
    E-mail server Type: Exchange
    Authentication Type: Windows Authentication
    Location Server : http://{what should go here?? The xchg2007 or the Cas}
    Access Credentials: Other specified Specified
    Access credential: crm forwarding mailbox account with it's password

    Thank you all in advance for your input and insight, and my apologies for the frustrated tone of this email

    Serge Ayotte


    Friday, April 24, 2009 6:21 PM

Answers

  • Serge,

    You just need to install the certificate from the server.  Meaning, if you go to OWA on the server with the email router on it, if you do not have the certificate installed you will be told that the page isn't trusted, are you sure you want to continue on to the page.  You say yes, and then install the certificate.  Just like you would for any other client machine.  If you can get to OWA without the certificate warning/challenge, then you should be all set.

    Fronk
    http://dmcrm.blogspot.com
    • Marked as answer by Jim Glass Jr Friday, April 24, 2009 7:32 PM
    Friday, April 24, 2009 7:16 PM

All replies

  • Serge,

    Here's how your Incoming profile should be set up:

    Profile Name: Incoming (Whatever you want to name it, it doesn't matter)
    Direction: Incoming
    Email Server Type: Exchange
    Authentication Type: Windows Authentication
    Location Server: https://mail.domain.com (Whatever your certificate is set up for, and/or basically your OWA address without the /OWA).
        One note on the URL for the Location Server, make sure that the server you are configuring the email router on has your Exchange certificate installed on it.  If you don't, that will keep the email router from working every time.
    Access Crednetials: crm forwarding mailbox account with it's password.

    Also, I've put up a post about this, with links to Microsoft's documentation:

    http://dmcrm.blogspot.com/2008/02/figuring-out-email-router.html

    Maybe that will help you understand the email router better, maybe it won't.

    Fronk
    http://dmcrm.blogspot.com
    Friday, April 24, 2009 6:39 PM
  • Fronk,

    Thank you for the rapid response.

    I am giving it a try (again) using as you suggest HTTPS://mail.domain.com (but changing the port in the advance tab to 443) and rebboting the CRM server, not just the email router service.

    One thing you say as me wondering:
    One note on the URL for the Location Server, make sure that the server you are configuring the email router on has your Exchange certificate installed on it.

    Do you men I have to import the same p7b I requested for the CAS server on the CRM server?
    Or do you mean the CA from which the certificate comes from?

    I am really uncertain about what you imply in that phrase..

    Again Thanks!
    Friday, April 24, 2009 6:58 PM
  • Serge,

    You just need to install the certificate from the server.  Meaning, if you go to OWA on the server with the email router on it, if you do not have the certificate installed you will be told that the page isn't trusted, are you sure you want to continue on to the page.  You say yes, and then install the certificate.  Just like you would for any other client machine.  If you can get to OWA without the certificate warning/challenge, then you should be all set.

    Fronk
    http://dmcrm.blogspot.com
    • Marked as answer by Jim Glass Jr Friday, April 24, 2009 7:32 PM
    Friday, April 24, 2009 7:16 PM
  • Still now joy....
    I don't get a warning since I used my own CA to create the certificate for SSL used by CAS server.

    I am able to log in via the OWA without trouble using the crm forwarding mailbox, but the Router is not able too... At least now I get a message "MS.crm.tools.email.providers.exchangepollingmailboxprovider has been aborted because it has been running for longer then the allowed execution time."

    Any more idea where my problem lies? :( :( :(  
    Friday, April 24, 2009 7:26 PM
  • Serge,

    Have you seen this blog post?

    http://billoncrmtech.blogspot.com/2008/07/microsoft-dynamics-crm-e-mail-router.html

    It steps through Exchange 2007 pretty well.  It focuses on the certificate a lot, which you may not have to worry about since it sounds like the certificate is already installed on your machine.  The other thing I would make sure that is present is a trust, or relay between the two servers.  Though, typically if that isn't established you get an error stating that the connection was actively refused. 

    Just to verify, when you go to test from the email router configuration manager the Outgoing works but the Incoming gives you the error "MS.crm.tools.email.providers.exchangepollingmailboxprovider has been aborted because it has been running for longer then the allowed execution time."  Is that correct?

    Have you tried restarting the Email Router service?  Are users set up to use the "Forward Mailbox" setting or are you using another setting?

    On a system that I have working I have everything set up as I outlined before and on the Advanced Tab I have:

    Network Port: 443
    Connection Timeout: 300
    Maxiumum Message Per Cycle: 1000
    Polling Period: 60
    Messages Expiration: 86400

    And just to ask, have you set up the Forward Mailbox?  Meaning, on the "Users, Queues, and Forward Mailboxes" tab, load the Data and two new tabs will appear: "Users and Queues" and "Forward Mailboxes".  On the "Forward Mailboxes" tab you should have a record for the forward mailbox that you are using (a email address on a user that is NOT associated to CRM).

    The values I have are:

    Name: CRM Router (Anything really)
    Email Address: crmmail@domain.com (email address of the forward mailbox)
    Incoming Configuration Profile: Incoming (or name of your incoming profile)
    Delete messages in forward mailbox after processing: Checked

    Hopefully that helps a bit.  If not, if you have any more detail you can share that might make it a little easier to try to figure this out.

    Fronk
     
    http://dmcrm.blogspot.com
    Friday, April 24, 2009 8:44 PM
  • Hi Fronk!!

    Once again, thank you for your very good answers and time spending to reply to my challenge!
    It is MORE then appreciated, and I hope we meet one day so I can treat you to a {insert drink of choice} and supper :D

    What is the most frustrating, is that I should have, with all the documentations I have, knowledge and experience be able to have solved this by now... Sigh... Hard hit on the ego, hehehe


    First, all my users are set to use Forwarding Mailbox for incoming.

    I tried restarting the router service, and also rebooting the server, after changing settings via the Configurator,

    I would "think" my Exchange 2007 set-up (i.e. one server with the Client Access Server Role, called it CAS.domain.com, and my Exchange 2007 server with Mailbox and hub roles, called it xchg2k7.domain.com) are correctly set, since I have not had any users complaining (internally) of any trouble getting to their mailbox with OUtlook or via OWA (and that's both those with their boxes on the old exchange 2003 and those on the Exchange 2007).

    The forwarding mailbox is the same as I used when the mailbox was in the exhange 2003, I just moved it... But now, I am starting to wonder if I shouldn't recreate a new one directly in 2007 and point there, but that would mean removing the current rule and putting a new one... I know the rule deployment manager SHOULD do it, but still...

    The error message I gave came from the Event viewer, since in the test access result only in a "timeout" error for thge incoming after goign on for

    Now I did get the test to conclude correctly ONCE today (and then the errors came back) by putting in the xchg2k7.domain.com in the incoming configuration, instead of the MAIL.domain.com that the certificate are made for, since I read in a blog that it not the true "OWA" server (or CAS) that should be inserted but the Exchange with the mailbox role.

    I made sure that the authentication method is set to a "non form-based" method, with both INtegrated and Basic authentication enabled, but still...


    I think I may trough down the gauntlet and give a call to MS Support the way it's going, and get help from both a CRM engineer and Exchange 2007...


    Anyway, once again, I want to thank you for your help and time.

    Serge Ayotte




    Monday, April 27, 2009 8:04 PM
  • Serge,

    I wish I could be more help.  Having MS Support will definitely be your quickest route to solution at this point.  Just try and get them to dial in with you and get you fixed up.

    Sorry I couldn't help figure out the exact issue on what needed to be fixed.

    If there any other questions you have on this let me know and I'd be happy to help out.

    Fronk
    http://dmcrm.blogspot.com
    Monday, April 27, 2009 9:47 PM
  • Serge,

    Did you end up finding a solution to this?  I am having the exact same problem.

    Thanks
    Tim 
    dsf
    Monday, June 8, 2009 3:29 PM
  • Serge,

    Did you end up finding a solution to this?  I am having the exact same problem.

    Thanks
    Tim 
    dsf

    HI TIM!

    Not really, I even placed a support call to MS, but it did not really "panned out" to good.

    I got it to work using SMTP/POP3 for now, and the only thing I have not had the chance to try was recreating the mailbox in Exchange 2007 instead of using a mailbox moved from the old xchg to the new.

    Regards!
    Serge
    Tuesday, June 9, 2009 2:05 PM