locked
Update Existing Records - urgent RRS feed

  • Question

  •  

    Hi...

     

    Can anyone know how to perform update functionality on "Entity" i.e - Lead using import wizard.?

     

    Monday, September 8, 2008 11:04 AM

Answers

  • Try this: use auto-mapping feature. Save the following text to a csv file,then import:

     

     

    Code Snippet
    Contact,Last Name,E-mail
    042B229C-587E-DD11-8892-0015E9BBCBD0,Chris,Test@eTest.com

     

     

    Please make sure there are no unnecessary spaces, and:

    Data Delimiter: none

    Filed Delimiter: comma(,)

     

    Jim
    Tuesday, September 9, 2008 11:14 AM
    Moderator
  • Hi Jim,

     

    It's working fine.

     

    I found the reason why the update functionality is not work.

    Note:- If the automatic data mapping is not done then the update functionality is also not work.

     

    Thank You Very Much...

     

     

     

    Tuesday, September 9, 2008 11:50 AM

All replies

  • You need to export data to excel, show the GUID column, put it in front of the excel sheet, then do the import.

    It will call the update function.

     

    Jim

    Monday, September 8, 2008 1:59 PM
    Moderator
  • Hi Jim

    ..

     

    Thank for replay..

     

    I am doing same thing but at the time of Re-Import its producing sql server error which is "A SQL Server error occured. Try this action again. If the problem continues, check the Microsoft Dynamic CRM Community for the solutions or contact your organization's Microsoft Dynamic CR< Administrator. Finally, you can contact Microsoft Support."  Error Code : - 0x80044150.

     

    Waiting for your solution...

    Thanks

    Parth

     

     

     

    Tuesday, September 9, 2008 4:31 AM
  • Hey jim,

     

    I'm getting the same error.

    The automatic mapping was not recognized so i created my own data mapping.

    If i change the accountid column Data from GUID to "account,GUID" the import ignores the value and creates a duplicate record.

     

    How did you manage to get the data import to update an existing record?

     

     

     

    Tuesday, September 9, 2008 6:13 AM
  • Adi, to use Auto mapping feature, you must make sure the column names Exactly match the Attribute's Display name.

     

    Parth,you can enable trace, but the easy way is just input 1 record to see the result.

    You may paste here 1 record of your source data if you want, and I will see what I can do for that.

     

     

    Cheers,

    Jim

     

     

    Tuesday, September 9, 2008 9:38 AM
    Moderator
  • Got it.

     

    Changed the "(accountid)" column header to "Account" and it worked like a charm.

     

    Thanks Jim.

     

     

    Tuesday, September 9, 2008 10:48 AM
  • Hi Jim...

     

    Record details :-

     

    Contact Last Name E-mail
    042B229C-587E-DD11-8892-0015E9BBCBD0 Chris Test@eTest.com

     

    The above record is for the Contact Entity,

     

    -- What I am doing?

    1. I am creating one contact entity with the last name Chris and exporting that record.

    2. After exporting I am Re-Importing same record with adding E-mail address. - for updating exinging record

     

    During data map I am mapping contactid but it's not updating records its producing SQL Server error.

    Thanks

     

    Tuesday, September 9, 2008 11:08 AM
  • Try this: use auto-mapping feature. Save the following text to a csv file,then import:

     

     

    Code Snippet
    Contact,Last Name,E-mail
    042B229C-587E-DD11-8892-0015E9BBCBD0,Chris,Test@eTest.com

     

     

    Please make sure there are no unnecessary spaces, and:

    Data Delimiter: none

    Filed Delimiter: comma(,)

     

    Jim
    Tuesday, September 9, 2008 11:14 AM
    Moderator
  • Hi Jim,

     

    It's working fine.

     

    I found the reason why the update functionality is not work.

    Note:- If the automatic data mapping is not done then the update functionality is also not work.

     

    Thank You Very Much...

     

     

     

    Tuesday, September 9, 2008 11:50 AM