locked
"My Tasks" not showing users current tasks RRS feed

  • Question

  • Project Server 2010

    One of our project managers is not seeing her assigned tasks in her My Task view for a specific plan on PWA but she can see assigned tasks for other plans, however, when I look at resource assignment I can see the tasks and they are assigned to her.

    I have checked the below and have run out of options

    1. The tasks fall within the current range on the users view.
    2. The tasks are marked as active.
    3. They are marked yes to be published in the plan.
    4. The booking type is set to commited.
    5. I have deleted the plan from PWA and republished it as a new plan and the tasks are still not showing.
    6. I have added in test tasks for a different user and they are able to see the tasks in "My Tasks"

    I cant see any other settings that she may have "accidentally" turned on or off, or changed, please help!

    Thanks in Advance.


    Colin Cook.

    Monday, April 23, 2012 2:54 PM

Answers

  • Hi,

    After so much time playing around we simply created a completely new plan, copied everything across into the new plan from the old one manually and published it, it now pulls through correctly into PWA and the PM's "My Tasks".

    This points to something being wrong in the Project itself, but I am not sure which settings could have cuased this...

    Thanks for all the help.


    Colin Cook.

    • Proposed as answer by PWMatherMVP Wednesday, April 25, 2012 6:55 PM
    • Marked as answer by ColCook Thursday, April 26, 2012 8:26 AM
    Wednesday, April 25, 2012 11:29 AM

All replies

  • Hi Colin,

    What about adding test tasks for the PM, do the test tasks appear? The PM hasn't got any filters applied?

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com

    Monday, April 23, 2012 4:55 PM
  • Hi Paul,

    We have added a couple of test tasks, one user can see his but the PM cannot see the new tasks on hers, we have checked with another resource and it appears he cannot see any tasks for this particular project either. They are all using the same view with no filters applied in "My Tasks."


    Colin Cook.

    Tuesday, April 24, 2012 10:11 AM
  • Check to see who is the Assignment Owner on the tasks that are not appearing.


    Reid McTaggart – DeltaBahn Vice President
    Blog | Twitter | LinkedIn

    Tuesday, April 24, 2012 12:56 PM
  • Hi,

    Check the Assignment Attributes for the user.

    Server Setting-->Security--> Manage User-->select user and check Assignment Attributes

    Might be possible Assignment Owner is someone else for the user.

    Regards,

    Kirtesh


    kirtesh

    Wednesday, April 25, 2012 9:20 AM
  • I have checked the user settings and the assignment attributes display as herself correctly. Also within the plan she is the assignment owner and appears as a resource in the plan.

    We have since tried saving the plan and republishing it as a completely new plan but still the issue occurs, a member of our Project Management administrators team can create and display tasks for himself but the PM still cannot. Obviously these two will have different levels of access so we have checked Categories and security templates but as she can see tasks for other projects It doesnt seem that this is causing the issue.

    I have checked her "My Tasks" view and can only see an option to select filters / sort by / and date range, I have removed any filters she has and checked the tasks fall within the date range set.

    Could there be something in the plan or tasks themselves causing the issue, also is there a way we can reset any personal settings in PWA that she may have set or am i missing something in the Categories and security templates that could affect this?

    Its definately a very frustrating head scratcher!

    Thanks for all the suggestions so far


    Colin Cook.

    Wednesday, April 25, 2012 9:34 AM
  • Please check Security and template setting for user if User is a part of PM group,please for the same task add another user who has access of PM Group and check whether other PM is able to access the task assignment.

    Also please check RBS level.

    1. First Try with same RBS level .

    2. Then with different level of RBS .


    kirtesh

    Wednesday, April 25, 2012 11:06 AM
  • Hi,

    After so much time playing around we simply created a completely new plan, copied everything across into the new plan from the old one manually and published it, it now pulls through correctly into PWA and the PM's "My Tasks".

    This points to something being wrong in the Project itself, but I am not sure which settings could have cuased this...

    Thanks for all the help.


    Colin Cook.

    • Proposed as answer by PWMatherMVP Wednesday, April 25, 2012 6:55 PM
    • Marked as answer by ColCook Thursday, April 26, 2012 8:26 AM
    Wednesday, April 25, 2012 11:29 AM
  • Given the things you checked, and that your rebuild solution worked, I don't think any settings caused the problem.  Sometimes bad things happen to good projects.

    Glad you got things working again.


    Reid McTaggart – DeltaBahn Vice President
    Blog | Twitter | LinkedIn

    Wednesday, April 25, 2012 1:05 PM
  • Sometimes bad things happen to good projects.

    Reid McTaggart – DeltaBahn Vice President
    Blog | Twitter | LinkedIn

    Thanks, this will be my new Technical standpoint. :)

    Colin Cook.

    Wednesday, April 25, 2012 1:22 PM
  • Hi Colin

    Have you checked the task mode for the tasks in the MS Project schedule in question? I believe that tasks that are set to Manually Schedule in MS Project as opposed to Auto Schedule, do not necessarily show up in the My Tasks view in PWA when the schedule is published.

    Cheers

    Chris Hubmann

    Cognizant

    Monday, May 7, 2012 12:30 AM
  • I think manual task publishing was added with SP1 FWIW.
     
     

    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky
    Monday, May 7, 2012 11:45 AM