locked
Activation OK, Online Genuine OK, MGADiag.exe = Invalid license! RRS feed

  • Question

  • I have had no problems with my Windows Vista, Automatic updates etc. for the last 3 to 4 months since purchasing this laptop and even after reinstallation of Windows Vista.

    However in the last week, possibly following a Windows Vista update (again this is automated) I am now being constantly harrassed by:

    A) "Activation successful" dialogs everytime Windows Vista starts. 
    Note:  This appears even after a ordinary restart and not just always after Windows Updates (the latter I believe is normal)

    B) "This copy of windows is not genuine.  Build 6001 etc." watermark in the bottom right of the desktop
    This appears then disappears in cycles following restarting, but (A) "activation successful" dialog is constant.

    C) The MGADiag.exe tool states I have an invalid license (as shown below).

    However this conflicts with the following 6 points:

    1) I have a genuine copy of Windows Vista SP1 which came with my m15x laptop = OEM I believe is correct term.
    2) Activation is sucessful.
    3) Online genuine validation is successful
    4) I am able to download software e.g. DirectX End-time user etc. that requires WGA validation
    5) I am able to activate my product key for Vista via the Windows Activation "Change product key..." dialog successfully using the VALID product serial number on the sticker underneath my laptop.
    6) In addition I just wasted an hour of my life talking to Microsoft over the phone (Malaysia?!) upon which they confirmed that my Windows Vista installation CD is valid (based on the number on the CD) and that my key was valid (this took them took 3 goes which I'll put down to a language/accent barrier).

    Microsoft support has suggested the I do a "Windows System Repair" with the installation CD due to my WGA files becoming corrupt.  I'll try this as a last resort as I think this is a bit drastic!

    In addition I have tried deleting my LegitControl.dll, WGA*.* files in System32 directory and relying on (4) "WGA required software install" to reinstall them but this did not alleviate the problem.
    Note: The WGA files in System32 have not reappeared... 

    PLEASE HELP me get rid of these annoying messages and continue normal functioning!

    I have pasted the output from the MGADiag.exe tool below. 

    Diagnostic Report (1.7.0095.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Invalid License
    Validation Code: 50
    Online Validation Code: 0x0
    Cached Validation Code: 0x0
    Windows Product Key: *****-*****-D96Q3-FWM88-Q6946
    Windows Product Key Hash: fyBecrbFSx0/sLLaMZj9mjnVLFc=
    Windows Product ID: 89578-OEM-7359803-47319
    Windows Product ID Type: 3
    Windows License Type: OEM System Builder
    Windows OS version: 6.0.6001.2.00010300.1.0.003
    CSVLK Server: N/A
    CSVLK PID: N/A
    ID: {9C09537C-792C-44E0-B5A9-1412F7F3D526}(3)
    Is Admin: Yes
    TestCab: 0x0
    WGA Version: Registered, 1.7.69.2
    Signed By: Microsoft
    Product Name: Windows Vista (TM) Home Premium
    Architecture: 0x00000000
    Build lab: 6001.vistasp1_gdr.080425-1930
    TTS Error:
    Validation Diagnostic:
    Resolution Status: N/A

    WgaER Data-->
    ThreatID(s): N/A, hr = 0x80070002
    Version: 6.0.6002.16398

    WGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    File Exists: No
    Version: N/A, hr = 0x80070002
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{9C09537C-792C-44E0-B5A9-1412F7F3D526}</UGUID><Version>1.7.0095.0</Version><OS>6.0.6001.2.00010300.1.0.003</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-Q6946</PKey><PID>89578-OEM-7359803-47319</PID><PIDType>3</PIDType><SID>S-1-5-21-2789849703-1215225967-4255311427</SID><SYSTEM><Manufacturer>Alienware   </Manufacturer><Model>m15x            </Model></SYSTEM><BIOS><Manufacturer>Quanta </Manufacturer><Version>vX32 P3</Version><SMBIOSVersion major="2" minor="4"/><Date>20080411000000.000000+000</Date></BIOS><HWID>C2323507018400F8</HWID><UserLCID>0C09</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>E. Australia Standard Time(GMT+10:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>ALWARE</OEMID><OEMTableID>ALIENWRE</OEMTableID></OEM><BRT/></MachineData><Software><Office><Result>108</Result><Products><Product GUID="{90120000-0030-0000-0000-0000000FF1CE}"><LegitResult>108</LegitResult><Name>Microsoft Office Enterprise 2007</Name><Ver>12</Ver><Val>D1806239BB2586</Val><Hash>2WYEWONOwZTklLuVgXtCMMsQy+w=</Hash><Pid>89388-707-1208712-65189</Pid><PidType>14</PidType></Product></Products><Applications><App Id="15" Version="12" Result="108"/><App Id="16" Version="12" Result="108"/><App Id="18" Version="12" Result="108"/><App Id="19" Version="12" Result="108"/><App Id="1A" Version="12" Result="108"/><App Id="1B" Version="12" Result="108"/><App Id="44" Version="12" Result="108"/><App Id="A1" Version="12" Result="108"/><App Id="BA" Version="12" Result="108"/></Applications></Office></Software></GenuineResults> 

    Spsys.log Content: 0x80070002



    • Edited by mad rabbit Thursday, September 18, 2008 12:46 PM
    Friday, September 12, 2008 5:19 AM

Answers

  • Hello Mad Rabbit,


    Curious have you opened a support request with Microsoft regarding the problems you have and are experiencing? Please create a (no cost) support request at the following link:

    http://go.microsoft.com/fwlink/?linkid=52029 .  This would be your best avenue of attack @ this point.  Thank you :-)


    Stephen Holm, MS
    WGA Forum Manager


    Stephen Holm
    • Marked as answer by Stephen Holm Monday, October 13, 2008 6:52 PM
    Monday, October 13, 2008 6:52 PM

All replies

  • The following also has not worked:

    http://social.microsoft.com/forums/en-US/genuinevista/thread/08ce98fa-32e1-4ae8-9b47-625e14a4cda4/
    Friday, September 12, 2008 1:49 PM
  • Tried the following just then:

    http://social.microsoft.com/forums/en-US/genuinevista/thread/6e1b1ac0-0b63-41a5-9557-d06fbd5aa2cd/

    Got to (10) of Step#2 i.e. reboot and was unable to access Windows Vista after login screen.  Was told I had to reinstall Windows completely!
    Did a system restore to a pretty recent timepoint i.e. after step (4) in my original post above where I reinstalled DirectX to try and 'fix' the WGA.

    Was able to start Windows Vista and MGADiag.exe tool NOW says Windows Vista copy is genuine?!

    Closing notes:

    1) Technical support form Microsoft i.e. via phone to Malaysia call centre is terrible.  I was put on hold 8 times!
    2) I advocated the use of Vista to all my friends and workmates.  I will no longer do this nor will I wonder why people are now preferring to buy Macintosh anymore.

    Case Reference #: 1078595414

    If you want to prevent piracy Microsoft stop hurting your legitimate which in turn 'promotes' software piracy.  I came very close to searching for a WGA crack for my VALID copy of Vista!
    Friday, September 12, 2008 3:10 PM
  • Mad Rabbit,

    I am sorry to hear about the complications you experienced. Has everything worked out for you after you called the call center or do you still need help?


    Thank you,


    Stephen Holm, MS
    WGA Forum Manager
    Stephen Holm
    • Marked as answer by Stephen Holm Friday, September 12, 2008 4:22 PM
    • Unmarked as answer by mad rabbit Monday, September 22, 2008 1:00 PM
    Friday, September 12, 2008 4:16 PM
  • The problem is back again!

    The system restore from my 13/09/08 post was to restore to a point on the 11/09/08, which solved the problem in my opinion.

    I then proceded to update Windows Vista and I believe this has resulted in the problem reappearing.

    The following updates have been installed on and after the 11/09/08:

    Definition Update for Windows Defender - KB915597 (Definition 1.43.309.0)

    Windows Malicious Software Removal Tool - September 2008 (KB890830)

    Update for Windows Vista (KB954366)

    Update for Windows Mail Junk E-mail Filter [September 2008] (KB905866)

    Update for Microsoft Office Outlook 2007 Junk Email Filter (KB956080)

    Security Update for the 2007 Microsoft Office System (KB954326)

    Security Update for Windows Vista (KB954154)

    Security Update for the 2007 Microsoft Office System (KB951944)

    Security Update for Windows Vista (KB938464)

    Update for Windows Vista (KB955302)

    Security Update for Microsoft Office OneNote 2007 (KB950130)

     I believe it is one of the above updates causing the probelm...at least I hope it is as then the problem would be simple = avoid that update.

    PLEASE HELP!

    Thursday, September 18, 2008 12:30 PM
  • Again as the title reads:

    Activation OK

    Online Genuine Validation OK

    MGADiag.exe = Invalid license (codes are the same as posted above)

    Identical symptoms to first original post.
    Thursday, September 18, 2008 12:45 PM
  • Anybody have any thoughts?  I really don't want to do a System Restore again especially if the problem is just going to keep resurfacing following Windows Vista updates or some other unknown process.
    Friday, September 19, 2008 1:16 AM
  • BUMP!

    I would appreciate if someone at Microsoft could help me with this issue ASAP.
    Monday, September 22, 2008 1:00 PM
  • Mad Rabbit,

    Where did you purchase Vista Home Prem from?  You may have to perform a clean installation of Vista.  Also I noticed you have MS Office Enterprise 2008 installed and it is receiving an error code 108. Error code 108 is a non-genuine version installed. 



    Thank you,


    Stephen Holm, MS
    WGA Forum Manager
    Stephen Holm
    Monday, September 22, 2008 5:04 PM
  • Hi Stephen,

    Thankyou for your reply.

    My copy of Vista Home Prem came with the m15x laptop I purchase from Alienware.  I'm happy to email and provide photos of the sticker on the bottom of the laptop, in addition to invoices from Alienware which include the purchasing of Windows Vista as part of the laptop package.

    As for the copy of MS Office Enterprise 2008, your right it is not genuine nor am I going to make excuses for it's use.  Suffice to say I was comparing it's features to a free "Home and Student" version I am eligable for i.e. get a 'hands-on look' at what I am missing out on.

    If Microsoft wish to discontinue their assistance in regards to my Windows Vista validation problems as a result of this then there not much I can say except for that the whole point will become moot if I have to format and reinstall Windows Vista again, and this would be the second time I've had to reinstall Vista due to BSOD etc.

    In addition if the two problems are related, or even 'intertwined', then this is the first appearance of the genuine validation issues with Windows Vista I have had.
    Tuesday, September 23, 2008 6:25 AM
  • Mad Rabbit,

    Your product key indicates Invalid Product Key or unsupported key type.  Please confirm the last 15 alpha/numeric characters of the product key you have against the below:

    Windows Product Key: *****-*****-D96Q3-FWM88-Q6946


    Do they match are are they different?  Did you purchase the system directly from the manufacturer? Please share with us where you actually purchased the system.


    At this point your produce is not a valid product key.



    Thankyou,


    Stephen Holm, MS
    WGA  Forum manager
    Stephen Holm
    Tuesday, September 23, 2008 8:24 PM
  • Hi Stephen,

    The 15 alpha/numeric characters you have displayed above (from the MGADiag.exe I'm guessing) matches EXACTLY with the last 15 alpha/numeric characters on the "Windows Vista Home Premium OEM Software" sticker on the bottom of my laptop.

    The Alienware m15x laptop system was purchased directly from the manufacturer (or at least the Australian division of the manufacturer) online at Alienware Australia:

    http://www.alienware.com.au/


    Address on the invoice:

    Alienware Australia
    2a Willowie Street
    Albert Park 5014
    Adelaide, SA

    As far as I know, Alienware is now a subdivision of Dell computers.

    Again,  if you supply me a viable Microsoft email address, I'm more than happy to email a photo of the sticker mentioned above in addition to the receipt for the laptop showing the purchase of Windows Vista OEM.
    • Edited by mad rabbit Wednesday, September 24, 2008 9:57 AM
    Tuesday, September 23, 2008 10:47 PM
  • Still getting the 'not genuine' notifications...

    Any thoughts, aside from Windows Vista reinstallation?
    Tuesday, September 30, 2008 1:12 PM
  • Mad Rabbit,

    What did Telephone suppport say regarding your problem? You may have to perform a complete re-installation.  First please try and activate by telephone.  

     

    a) If you have access to the Start button: Click the Start button, and type slui.exe 4 in the search field and then press the "Enter" key. This will bring up the Activate by Phone dialog window. Follow the steps provided by the window. The phone activation process should only take about 6 minutes.

     

    b) If you do not have access to the Start button: Reboot and login to Vista, a dialog window will come up. In that window, click the option "Access computer with reduced functionality". Once you do that, Internet Explorer or Firefox browser will open. In the address bar type c:\windows\system32\cmd.exe and press enter, a new window will come up, type: slui 4 and hit enter and follow steps to Activate over the Phone.

     

    NOTE The key to this process is that you need to talk to a Live Activation Rep! When you first call, you will be interacting with an Automated Voice, either select the option to talk to a Live Rep or if there is no option, do not enter any numbers. This should force the automated voice to transfer you to a Live Rep.




    Thank you,


    Stephen Holm, MS
    WGA Forum Manager


    Stephen Holm
    • Marked as answer by Stephen Holm Tuesday, September 30, 2008 5:24 PM
    • Unmarked as answer by mad rabbit Monday, October 13, 2008 7:25 AM
    Tuesday, September 30, 2008 5:24 PM
  • Hi Stephen,

    I do still have access to the Windows Vista and the start button, as at the moment the notifications are more of an annoyance than anything.  As such I have tried step (a) as you haev suggested.

    I had no problems activating by phone and am happy to email both sets of numbers to you/Microsoft for further verification.

    After the second restart the problem seemed to have diappeared.  However after a couple more restarts I am still getting the 'non-genuine' messages.

    It's seems strange that they appear intermittently i.e. sometimes I get the 'Activation Successful' dialog straight and/or the 'non-genuine' watermark at the bottom of my desktop.  Other times neither appear?!

    So in summary, although your suggestion seemed to have worked initially, I still am getting the same 'non-genuine' notifications.
    Monday, October 13, 2008 5:30 AM
  • I am also still able to obtain files/updates from Microsoft, such as the "WinHlp32.exe" I downloaded today, that require genuine verification, despite the notification messages I keep receiving.

    ----

    One possible reason for my problems which I was not initially aware of was that my flat-mate borrowed my Windows Vista DVD to reinstall their OS
    BUT
    used their VALID Windows Vista key which we obtained using a retrieval program.

    Are the Windows Vista DVDs registered for particular Windows Vista serials?
    OR
    Can a Windows Vista DVD be used to install the OS on mutliple computers, each with their own VALID Windows Vista key?

    This could be the reason for my problems.

    EDIT: I've also found out that my flatmate is also getting 'non-genunine/counterfeit' messages as I am.  Again, we both have DIFFERENT yet VALID Windows Vista keys. 

    If my flatmate was to uninstall her version of Windows Vista (i.e. my DVD with their serial) would that alleviate the current problems?
    • Edited by mad rabbit Monday, October 13, 2008 7:26 AM
    Monday, October 13, 2008 5:35 AM
  • Hello Mad Rabbit,


    Curious have you opened a support request with Microsoft regarding the problems you have and are experiencing? Please create a (no cost) support request at the following link:

    http://go.microsoft.com/fwlink/?linkid=52029 .  This would be your best avenue of attack @ this point.  Thank you :-)


    Stephen Holm, MS
    WGA Forum Manager


    Stephen Holm
    • Marked as answer by Stephen Holm Monday, October 13, 2008 6:52 PM
    Monday, October 13, 2008 6:52 PM
  • I would've choosen Windows XP for this laptop had some of the On-Screen-Display features etc. not been exclusively designed for Windows Vista.

    Currently there has has been no progress in terms of:

    1) The disapperance of these annoying messages.
    - It seems odd that every second time I restart I get an 'Activation Successful' dialog after login YET a "You may be a victim of software counterfeiting" message during use?!

    2) Response from Microsoft via this forum in terms of a novel solution AND/OR alternative to reinstallation of the whole OS

    3) Any Windows Updates from the initial appearance of these error messages to the present day that fixes this issue.

    Thursday, October 23, 2008 7:07 AM
  • To Stephen Holm:

    As per your instructions I have submitted a support request with Microsoft: Incident # 1082659366
    Thursday, October 23, 2008 7:14 AM
  • SAME PROBLEM HERE I AM VERY ANGRY RIGHT NOW WINDOWS HAS STOPPED MY WORK AND I NEED TO WORK......
    Saturday, October 25, 2008 12:19 AM
  • This solution provided to me by a member of Microsoft Asia Pacific Online Technical Support seems to have worked!

    ----------

    Register DLL Files

     

    1. Please click Start.

     

    2. Please type CMD in the Start Search box right above Start button.

     

    3. Please right click on CMD in the Programs List and select Run as Administrator.

     

    4. Please type cd \ and Enter.

    Note: There is a space between “cd” and “\”.

     

    5. Please type regsvr32 softpub.dll and Enter.

    Note: There is a space between “regsvr32” and “softpub.dll”

     

    6. When prompted “DllRegisterServer for softpub.dll succeeded”, please click OK.

     

    7. Please repeat with the following DLL Files.

     

    regsvr32 mssip32.dll

    regsvr32 initpki.dll

     

    Note: There might be Error Messages prompt. Please ignore them and proceed to the other steps.

     

    8. Please type Exit and Enter.

     

    9. Please disable third party antivirus program.

     
    10. Please go to www.microsoft.com/genuine and click Validate Windows.

    ---------

    I have tested this at home (private LAN, no internet) and work (intranet and proxy internet), with several restarts in-between and I have NOT seen the pre-login ‘Activation Successful’, the post-post-login desktop watermark in the bottom right-hand corner, nor the periodic ‘Counterfeit’ message.

    Give it a try if your experiencing the same problems I've detailed here!

    Thursday, October 30, 2008 3:49 AM
  • Spoke too soon...exact same problems are back again i.e. the pre-login ‘Activation Successful’, the post-post-login desktop watermark in the bottom right-hand corner, nor the periodic ‘Counterfeit’ message...
    Friday, October 31, 2008 7:48 AM