locked
API is failing in release mode but working in debug mode. RRS feed

  • Question

  • Hi All,

    I am using a third party library in my code.

    When i run it in debug mode(with visual studio debugger) it works fine but when i run by clicking the exe(which uses third party API) it fails always.

    I searched on web and found there is some problem with working directory. I could not understand it.

    When i contact the third party they said it is working fine in their environment.

    I am a kind of stuck here.

    Can somebody give some idea about the root cause.

    Thanks,

    Nihal.k 

    Thursday, October 5, 2017 3:03 PM

Answers

  • If you needed help with visual studio debugging you could also over here.

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/home?forum=vsdebug

    For debugging the library I'd ask the third party for help.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    • Proposed as answer by Richard MuellerMVP Thursday, October 5, 2017 8:00 PM
    • Marked as answer by Just Karl Thursday, October 12, 2017 7:52 PM
    Thursday, October 5, 2017 3:22 PM