locked
Tasks are not visible on the "Tasks" page after publishing RRS feed

  • Question

  • I have created a project using PWA. I assigned a task to a team member and then published it (and finally checked it in).

    However, the very team member can't see the published task in his "My Work" page. What's wrong?

    Thanks,


    Monday, June 27, 2011 3:00 AM

Answers

  • Hi,

    sorry, my e-mail alert is currently not working.
    Have you had a look at Default Assignmnet owner for this resource? It is not empty? While project creation, default assignment owner is set as assignment owner, so I am wondering why it is empty in your case.

    Moreover, I am still thinking how to change assignment owner without Project Professional. I assume that you will need to find a client or some work around. Edit in assignment views is not possible, and this is what you would need to do (http://download.microsoft.com/download/5/0/B/50B59BE2-1BB2-4886-A2C9-435E7BC7A204/PRO_PWA_comparison.pdf).

    My only idea at the moment: use team builder to replace your resource by any other one and publish your project. Make sure that your resource has defined himself as Default Assignment Owner and do another replace in Team Builder to original resource. Perhaps there will be an assignment ower now?

    Good luck!
    Barbara

    • Marked as answer by Tom Xie Monday, July 4, 2011 5:28 AM
    Tuesday, June 28, 2011 6:30 PM

All replies

  • Hi Tom,

    there are several potential reasons for this behaviour:

    • Booking Type is proposed instaed of comitted. (Proposed does "hide" tasks from users.) Check in Buidl Team dialog.
    • There is someone else Assignment Owner for these tasks. Apply Resource Usage view and add column assignment owner. If it is not user's name, change this value to his name. By the way: if it is the name of the person who published this plan initially, there is propably no Default Assignment Ower defined for this resource. You can check this in Project Web App - Resource Center. All tasks are displayed ton Assignment Owner's Task page.
    • I don't think this will be the case here, but I want to mention. Tasks are also hidden from Task page, if their value for published was set to No by adding column Published in a task view.

    Does any of these reasons apply?
    Regards
    Barbara

    Monday, June 27, 2011 4:41 AM
  • Thanks Barbara,

    1. The booking type is committed.

    2. I don't understand this, could you please give me more details? (I'm newbie for Project Server)

    3. How can I add the "Published" column in task view?

     

    Thanks,

    Monday, June 27, 2011 5:20 AM
  • Hi Tom,

    ad 2: Open your project in Project client. On Task ribbon, section view, click in pick-list button Gantt chart. Select entry Resource Usage. Right click on any column header in the left pane and select Insert Column. Select Assignment owner from field list. Is this name resource's name for all assignments? It is possible, that it is yours (any other PMs name). Change this name to resource's name and publish your project. If this was the case and to avoid in future, go to Resource Center, select this resource and click on edit. There is a field called Default Assignment Owner. Make sure that you insert the name of the person, who should see tasks assigned to this resource on Tasks page (in most cases, Resource Name = Default Assignment Owner). After changing, all new assignments (a task assigned to a resource) will take this name in column Assignment Owner. All assignments created before, you will have to change manually as described.

    ad 3: Open your project in Project client. On Task ribbon, section view, just click on the button Gantt chart (don't open pick-list). Right click on any column header in the left pane and select Insert Column. Select Publish from field list. Value should be True for all tasks (I assume, this is the case).

    Regards
    Barbara

     

    Monday, June 27, 2011 10:43 AM
  • I'm going to let Barbara carry on answering, because her responses are spot on - however, I wanted to say that it is very easy to set up delegation to quickly see what the user sees.    Set yourself up as a delegate for the user you are having issues with, and it makes it all much quicker to troubleshoot.
    Ben Howard [MVP] blog | web
    Monday, June 27, 2011 8:41 PM
  • Thanks Barbara, but I don't have the fat client, so I can't do anything with what you said above. <sigh> Sorry.

    Ben, what's the delegation? how to set it? Forgive my ignorance! <grin>

    Thanks

    Tuesday, June 28, 2011 3:15 AM
  • Hi Tom,

    you can check the assignment owner also in Project Web App, if you are an administrator or the administrator does give you some support:

    Server Settings - Manage Views. Select a view with "Assignment" in its name you are allowed to use from the first section (Project). Click on Copy View, enter a name (original name + Assignment Owner?), and click OK. Click on the name of your new view, add "Assignment Owner" field to the right column, and save. When you click on your project's name in project center, you can select your new view in drop down box. This view will show the assignment owner for each assignment.

    Since you are working in Project Web App, I think you do not need spend some time on Published field. It was little likely your issue, but it is less now.

    Regards
    Barbara

    Tuesday, June 28, 2011 6:02 AM
  • Thanks very much, Barbara

    I did as you said, only to find the assignment owner is empty. Is that the cause of the problem? If so, how can I overcome it?

    PS, Barbara. I don't understand why the assignment owner matters here? Because in my mind, the assignment owner should be the resource name by default when the task is assigned, right? And I promise I didn't change the default assignment owner, why it's empty this time?

    Any idea?


    Tuesday, June 28, 2011 6:20 AM
  • Hi,

    sorry, my e-mail alert is currently not working.
    Have you had a look at Default Assignmnet owner for this resource? It is not empty? While project creation, default assignment owner is set as assignment owner, so I am wondering why it is empty in your case.

    Moreover, I am still thinking how to change assignment owner without Project Professional. I assume that you will need to find a client or some work around. Edit in assignment views is not possible, and this is what you would need to do (http://download.microsoft.com/download/5/0/B/50B59BE2-1BB2-4886-A2C9-435E7BC7A204/PRO_PWA_comparison.pdf).

    My only idea at the moment: use team builder to replace your resource by any other one and publish your project. Make sure that your resource has defined himself as Default Assignment Owner and do another replace in Team Builder to original resource. Perhaps there will be an assignment ower now?

    Good luck!
    Barbara

    • Marked as answer by Tom Xie Monday, July 4, 2011 5:28 AM
    Tuesday, June 28, 2011 6:30 PM
  • Thanks, Barbara

    I will try and see.

    Wednesday, June 29, 2011 2:08 AM
  • Still no effect.

    Friday, July 1, 2011 5:43 AM
  • Finally, I delete the PWA site and recreate a new one, everything works. (I'm still making Barbara's reply as an answer for her initiatives.)

    Monday, July 4, 2011 5:28 AM