Disable auto save functionality in Dynamics CRM 2013 RRS feed

  • Question

  • I don't want to use auto save in CRM 2013, want to disable auto save functionality in Dynamics CRM 2013, please let me know is there anyway i can disable auto save for all entities.
    Thursday, December 26, 2013 9:44 PM


  • You can following below steps to disable auto save , it is organization level settings, once you set “No” auto save will not work on any entity.
     - Click on Dynamics CRM-> Settings tile
     - Click on Settings-> Administration tile
     - Click on System Settings icon
     - Set “No” to “Enable auto save on all forms” under “Select the default save option for forms”
    1.Write following JavaScript code in your entity JavaScript file.

    function preventAutoSave(econtext) {
        var eventArgs = econtext.getEventArgs();
        if (eventArgs.getSaveMode() == 70) {

    2. In the Form Properties window, in the Event Handlers section, set Event to OnSave.
    3. Click on Add  and choose the above code written JavaScript resource file
    4. In the Handler Properties window, set Library to the web resource you added in the previous step.
    5. Type ‘preventAutoSave’ in the Function field. This is case sensitive. Do not include quotation marks.
    6. Make sure that Enabled is checked.
    7. Check Pass execution context as first parameter.
    8. Click OK to close the Handler Properties dialog.

    After you apply this script to the OnSave event, when people edit a record using this form the message unsaved changes will appear in the bottom right corner of the form just as it would if auto-save was not disabled. But this message will not go away until people click the Save button next to it.

    • Proposed as answer by VSomireddy Thursday, December 26, 2013 9:46 PM
    • Marked as answer by Venkat_Reddy Thursday, December 26, 2013 9:47 PM
    Thursday, December 26, 2013 9:46 PM