locked
Unable to Delete or Publish entity CRM 4.0 RRS feed

  • Question

  • Hi all,

    I am working on a Virtual PC and am unable to publish or delete a custom entity. Also if I am trying to import the same entity to overwrite it, it throws an error saying "the schema name already exists, please select a unique name."

    Sunday, January 20, 2008 12:40 PM

Answers

All replies

  • Hi SlimGees,

     

    Does this custom entity have relationships with other entities?

    If so, remove those relationships first and publish it, and then delete tihs custom entity.

     

    Regards,

    Jim

     

    Sunday, January 20, 2008 2:52 PM
    Moderator
  • Hey Jim,

     

    Well, if I want to export the custom entity and import it to another machine, do I have to Export and Import all the related entites also? Cuz I want to retain those relationships after export and an import..

     

    This is the scenario in brief...........

    I have actually made a few custom entities and it of course has relations with other custom entities and system entities. Now I want to deploy these customizations on the production server. But before that I am running this in a test environment. The customizations are not being imported successfully. It has some problems with the relations. When I try to import the customizations, it gives an error saying,,,,,,

    "Failure : new_entity1_entity2(this is the schema name for the relationship), Invalid Argument."

     

    I tried importing all the customizations from the exported machine, but this error still persists.

    Kindly, explain this in brief why does this happen.

    Thank you.

     

    Sunday, January 20, 2008 4:19 PM
  • Dear Slim,

     

    http://support.microsoft.com/kb/909830/ja

     

    There should be some attributes exists with similar .

    Check the relationship with this enity. , do first publish and then export. It seems you had change some entity attributes or relationships and did not perform any publish.

     

    Regards,

    Imran

     

    http://microsoftcrm3.blogspot.com

     

     

    Monday, January 21, 2008 7:41 AM
    Moderator
  • I would highly suggest you use the undo disk feature of the VPC.

     

    Oshri Cohen
    http://mymscrm3.blogspot.com/
    http://www.linkedin.com/in/oshricohen

    Monday, January 21, 2008 9:31 PM
  • I Have same problem... I tried to delete entity relationship but this operation return me a generic error message. the same error return me when I try to delete the entity
    can you give me a idea?
    Wednesday, July 23, 2008 10:07 AM