locked
QoS settings stop video from working RRS feed

  • Question

  • Hi,

    When we enable the QoS registry setting in XP, communicator video stops working. We have ruled out the network by using a hub between two endpoints. The machine shows it sending the video stream with the right QoS markings but no video is displayed on the receiving device. When Ichange the allowed bandwidth setting to lower the available bandwidth for video there is a slight improvement but hardly what you would call usable. The same QoS settings on Vista works fine. I have alter the Group policy for our DSCP markings. I have also disabled the personal firewall on the sending machine although when the registry settings are removed it works just fine.

    Has anyone else seen this behavior?

    Cheers
    Chris
    http://voipnorm.blogspot.com/
    Tuesday, July 28, 2009 5:05 PM

Answers

All replies

  • Hi,

    Problem solved. Communicator patch .37 solves this issue.

    http://support.microsoft.com/kb/971846


     

    Cheers

    Chris


    http://voipnorm.blogspot.com/
    • Edited by VoIPnorm Friday, July 31, 2009 4:04 PM error
    • Marked as answer by VoIPnorm Friday, July 31, 2009 4:04 PM
    Friday, July 31, 2009 4:03 PM
  • Hi Chris
    Have you tried to get QoS DSCP working with Office 2007 Live Meeting?

    We found that if you use Windows XP it work ok, but it does not work with Vista.
    The .37 Communicator patch does not change this situation.

    Regards
    Nigel Smith
    http://nwsmith.blogspot.com/
    Thursday, August 20, 2009 6:39 PM
  • Hi Nigel,

    Vista is a little different in the way you setup QoS. You need to enable it first but you can also specify which application you want to set QoS for. Here is a link to my blog that talks a little about the registry settings for communicator but I am pretty sure you could do the same thing for Live Meeting.

    http://voipnorm.blogspot.com/2009/01/quality-of-service-for-moc.html

    These settings can be configured through group policy or just as a set of reg keys as in my blog post suggests.

    Hope this helps.

    Cheers
    Chris
    http://voipnorm.blogspot.com/
    Thursday, August 20, 2009 7:31 PM
  • Hi Chris
    Yes, we have tried a similar approach with Live Meeting on Vista, using group policy, and it does work.
    But the problem is you cannot differentiate the audio stream from the video stream.

    As I guess you know, with Office Communicator 2007 R2, you just:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RTC\Transport
    "QoSEnabled"=dword:00000001
    ..and provided your using v3.5.6907.37 it just works, AND you get different dscp values for audio & video.
    And that also work for Live Meeting, if you use Windows XP, but it does not work on Vista.

    Another problem with Vista is that you cannot use 'tcmon.exe' to see what is happening, like you can on Windows XP.
    Regards
    Nigel Smith
    Thursday, August 20, 2009 11:52 PM
  • You make a good point about the markings being the same. So if you look under local computer policy (using gpedit.msc) in the computer configuration under network there should be QoS packet scheduler . This is where you can actually set the DSCP values of conforming and non conforming packets. I didnt have much success until I changed non conforming values to what I wanted them to be for our network but its something you could try on both.

    DSCP value of non-conforming packets
    DSCP Value of conforming packets

    There are five values under these. You will need to alter Guaranteed service type(voice) and controlled load service type (video) to the DSCP values you wnat for your network. This also allows you to change the values in XP from the default as well.

    Cheers
    Chris
    http://voipnorm.blogspot.com/
    Friday, August 21, 2009 2:02 AM
  • There is actaully a bug in this at the moment where the GPO-based settings can be ignored and the default DSCP values will be used regardless.
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Friday, August 21, 2009 3:43 AM
    Moderator
  • Thanks Jeff. At least when it doesnt work we know why:-) 
    http://voipnorm.blogspot.com/
    Friday, August 21, 2009 4:21 AM
  • Hi Jeff & Chris
    I've posted some details on the results from our testing with Live Meeting on my blog:

    http://nwsmith.blogspot.com/2009/08/dscp-qos-microsoft-office-live-meeting.html

    So far as we can tell, from testing using the PC's we have available, there is a bug
    in Live Meeting v8.0.6362.128 which stops DSCP marking working correctly with QoSEnabled=1
    to automatically mark audio & video packets when using Vista or Windows 7.
    There is not a problem with Windows XP.

    Jeff. can you confirm if Microsoft know about this & are working on a fix.
    Otherwise how best to report the bug?
    Many thanks
    Nigel Smith
    Friday, August 21, 2009 3:34 PM