locked
Increased CPU usage since PP1 RRS feed

Answers

  •  

    Just an update, 1776 seems to have fixed this issue.
    Friday, June 27, 2008 9:37 PM
    Moderator

All replies

  • Well, not sure that it has anything to do with ORB, but I too noticed that Demigrator.exe is still churning away and CPU usage has gone from 65%-75% when running to 86%-95% now (use Taskmanager to view).  BUT,,,,BUT, I've noticed that Demigrator.exe turns off now! Unlike before when it ran 24/7. So that's good.

     Does Orb do something to trigger  CPU usage with PP1?  Not sure.

    Anyone have some ideas?
    Wednesday, June 11, 2008 11:43 PM
  • You really have to give the update some good time to settle everything in.  I would expect high CPU usuage and IO usuage while this is happening.  How data is handled and stored is completely different with the PP1 update.

     

    Thursday, June 12, 2008 12:24 AM
    Moderator
  • Joel,

    I originally posed a similar conclusion in my post, but deleted that line. There may be a need for time to "align the planets" ...er...a files with PP1.

    Thursday, June 12, 2008 2:57 AM
  • I noticed the same thing on my Mediasmart server.  Even the console was so slow that it was almost unusable.  Check the server status in the console and found that the CPU was running very hot (57c).

    I found the following by RDP to the server and running TaskManager (Start/Windows Security/Task Manager or Start/Run/Taskmgr).  Go to the processes tab and click on "Show processes from all users" and then click on the "CPU" header twice to sort the processes by CPU usage from highest to lowest.

     

    I first found that the process "WMCCDS.exe" was using 100% of the CPU cycles.  This process has to do with Windows Media Connect, so I went to the server console and turned off media sharing for all media types.  This stopped the 100% access by WMCCDS.  Shortly after, I was having the same problem and checked the Task Manager again.  This time "SearchProtocolHost.exe & SearchFilterHost.exe" were using 100% of the CPU cycles.  I let these processes run for over 6 hours at 100% utilization and check the indexing status periodically.  It made very little progress over this time.

     

    I deleted most of the files on my server and let the indexing process run.  It stabilized very quickly and now processor utilization is down to 3-5% and the temps are down to 34c.  I will try turning the multimedia services back on as soon as I resolve a couple of other issues.

     

     

    Hope this helps!

     

    Toby

     

    Thursday, June 12, 2008 3:23 AM
  • HP Mediasmart EX470 with PP1 and I am having the same issues with both Orb and WMCCDS.exe.  I have tired killing Orb and that dropped some cycles, but still spikes due to WMCCDS.  CPU isn't running as hot, mostly in the 40s.  Firefly has also been chiming in with its demand of proc time, so I get near perfect sine waves... OK, not quite, more like square waves on my proc usage from Task Manager.  I rebooted the server and about 200mb disappeared off the Page File usage (it was pegged at over 800mb which sounds high) but if, as I read in an old post about WMCCDS it takes a while to get everything sorted out again, I may just leave and let it run over night.  Proc temps are hovering in the 40s and it has been doing this most of the night, so I should be safe...  Wait, nope, now that I have typed that out loud, it jumped up in to the 50s.  So, I have just killed Orb again, which has helped, I will see where it is at in the morning and try running Orb again and see if that jumps to square waves again.
    Thursday, June 12, 2008 5:21 AM
  • I've left mine overnight, and this morning it's still doing the same, and CPU usage is running at 40% average. I've closed Orb and it goes quiet again.

    Thursday, June 12, 2008 7:07 AM
    Moderator
  • After an overnight run without Orb, I am still seeing proc spikes and they still appear to be due to WMCCDS.exe.  I have about 120gigs of music on the server, so I guess it could be taking a while to get everything sorted, but it has been more than 10 hours at this point.  And I am leary of turning Orb back on until this process finishes it's job.  Page file usage is back up to a constant 818MB which sounds a bit high too, can anyone else confirm if this is the case on their home servers?  Firefly also appears to be having fits at the server on a regular basis.

    Thursday, June 12, 2008 5:19 PM
  • I see some activity from WMCCD (about 3% average) every 5 seconds, but nowhere near as harsh as Orb. Firefly's not doing anything on mine though.

     

    I've installed Twonky now, and thats also spiking every 5 seconds at 25%.. somethings really not right here.

     

    Thursday, June 12, 2008 5:42 PM
    Moderator
  • Firefly appears to be my fault, it was set to check for new files every 5 minutes, don't remember setting that, but since changing it back to once a day, it has quieted right down.  Tried turning Orb back on and the proc immediately went back in to seismic graph mode.  Or EKG mode. Either way, proc was up and down 100%.  It's turned back off again after proc temp climbed back up over 50 degrees consistently.  At this point, I can run without Orb, as Hamachi has given me VPN access to all my music, but it would be nice to get sorted eventually so I can listen from my Xbox again.

    Thursday, June 12, 2008 7:06 PM
  • Did anyone on this thread bother to submit a bug with their server logs that described what you were seeing and what you did with Orb, Firefly, Windows Media Connect and how it affected the CPU usage? 

     

     

     

    Friday, June 13, 2008 3:46 PM
  • I've submitted feedback ID 350962. Sorry for the delay, my server logs were too big to either submit or attach so I just learned how to clean first.

     

    Friday, June 13, 2008 8:14 PM
    Moderator
  • thank you!

     

    Friday, June 13, 2008 9:35 PM
  •  

    Just an update, 1776 seems to have fixed this issue.
    Friday, June 27, 2008 9:37 PM
    Moderator