none
Hyperthreading turned off in bios, but HPC still using it....how do I stop it? RRS feed

  • Question

  • I have hyperthreading turned off in the bios on my servers.  There are 2 dual core processors in each of them.  When I tell HPC to use 8 nodes, or 16 sockets HPC reports to me that it is using 16 cores on each machine, or 128 cores.  How can I stop HPC from using hyperthreading??  Note that when I open the task manager on the servers and check out the performance graphs it is only showing me 8 cores.

    Is this just an error in HPC telling me it is using 16 cores, or is something else going on here I am unaware of?

    Craig

    Monday, November 19, 2012 4:03 PM

All replies

  • Could you write the output of the following command executed on one of your servers:

    set | find "NUMBER_OF_PROCESSORS"

    Also type in console "msconfig" and go to "Boot" tab and the to "Advanced options".What is the number in the field :"Number of processors" ?

    Also verify that logical processors number is set to single in your BIOS.What hardware do you use?


    Daniel Drypczewski

    Wednesday, November 21, 2012 3:07 AM
  • I think I found the issue.  I needed to reset the servers.  When we ran the monthly upgrade and rebooted the servers all was well.

    I also found this http://scorpiotek.com/blog/?tag=hpc which I plan to try in the future should this problem arise again.

    Tuesday, November 27, 2012 3:43 PM