locked
Remote Access to Windows Home Server exceeded users RRS feed

  • Question

  • Everytime I try to use the "Remote Access to Windows Home Server" option "Connect to your Home Server" i get the error "The Terminal Server has exceeded the maximum number of allowed connections"...I am able to use remote access on all the other machines on my network, but not connect to the Server...Does anyone have any ideas on what could be causing this?

    Currently i only have 3 PC's, 1 Laptop, a PS3, Xbox360 and the WHS on the network...

    Thanks in advance...

    Troy

    Thursday, March 22, 2007 8:50 PM

Answers

  • This can happen if you RDP (remote desktop protocol) into your Windows Home Server and open the console.  Did you RDP into your Windows Home Server?
    Thursday, March 22, 2007 9:05 PM
    Moderator
  • I have used RDP to access the server in the past, but i am not currently RDP'd to it from any machines...i am also pretty sure that all PC's that i have RDP'd to it from have been rebooted since that time...
    Thursday, March 22, 2007 9:10 PM
  • Unless you have a license for Remote Terminal Services, Windows 2003 Server (base for WHS) only allows 2 Terminal Services Connections to the server. If your connection times out (easy to do) sometimes it will sit there waiting for a connection that will never come. You need to manually disconnect the session.

    If you can get into the server, go to Start--Administrative Tools--Terminal Services Manager. In the left hand colum you should see your server name. Click on it and in the right box you should see a list of connected users, probably console and 2 remote users. You need to reset the two remote users. You can do this by right clicking and selecting "Reset." You should now be able to connect with RDP again.

    I'm not sure if it will work on workgroups, and I haven't tried it yet, but if you install the 2003 Server Admin tools, you may be able to do this from any XP machine. I will try it when I get a chance, but I don't have much faith, as the tools use your admin privedliges on a Domain. If anyone has already tried this, please post, or direct me to the thread where it is already discussed. I will also look.

    I hope this helps.

    Steve

    Thursday, March 22, 2007 9:29 PM
  •  Troy Flint wrote:
    I have used RDP to access the server in the past, but i am not currently RDP'd to it from any machines...i am also pretty sure that all PC's that i have RDP'd to it from have been rebooted since that time...
    I think you probably closed Remote Desktop windows that were open to the WHS desktop.

    When you are done with a Remote Desktop session on WHS, you should always use "Log Off" rather than closing the RD window. By default, Remote Desktop connections to WHS don't time out, and if you simply close the RD window you disconnect from the session but leave it active. Each disconnected but active session uses up a connection, and you can only have two simultaneous connections to the WHS remote desktop. This is a restriction of Remote Desktop For Administration; there is no easy way to change it.

    You may be able to reconnect to one of the active sessions, but there are no guarantees. Failing that, if you have not yet disconnected your keyboard, mouse, and monitor, you can log in to the desktop and use the Terminal Services Manager MMC snap-in to disconnect remote sessions (you can always log in locally). If you've already gone headless, you will probably have to restart WHS using the power or reset button.
    Thursday, March 22, 2007 9:36 PM
    Moderator
  • An easier fix would also be just rebooting the Windows Home Server.
    Thursday, March 22, 2007 9:48 PM
    Moderator

All replies

  • This can happen if you RDP (remote desktop protocol) into your Windows Home Server and open the console.  Did you RDP into your Windows Home Server?
    Thursday, March 22, 2007 9:05 PM
    Moderator
  • I have used RDP to access the server in the past, but i am not currently RDP'd to it from any machines...i am also pretty sure that all PC's that i have RDP'd to it from have been rebooted since that time...
    Thursday, March 22, 2007 9:10 PM
  • Unless you have a license for Remote Terminal Services, Windows 2003 Server (base for WHS) only allows 2 Terminal Services Connections to the server. If your connection times out (easy to do) sometimes it will sit there waiting for a connection that will never come. You need to manually disconnect the session.

    If you can get into the server, go to Start--Administrative Tools--Terminal Services Manager. In the left hand colum you should see your server name. Click on it and in the right box you should see a list of connected users, probably console and 2 remote users. You need to reset the two remote users. You can do this by right clicking and selecting "Reset." You should now be able to connect with RDP again.

    I'm not sure if it will work on workgroups, and I haven't tried it yet, but if you install the 2003 Server Admin tools, you may be able to do this from any XP machine. I will try it when I get a chance, but I don't have much faith, as the tools use your admin privedliges on a Domain. If anyone has already tried this, please post, or direct me to the thread where it is already discussed. I will also look.

    I hope this helps.

    Steve

    Thursday, March 22, 2007 9:29 PM
  •  Troy Flint wrote:
    I have used RDP to access the server in the past, but i am not currently RDP'd to it from any machines...i am also pretty sure that all PC's that i have RDP'd to it from have been rebooted since that time...
    I think you probably closed Remote Desktop windows that were open to the WHS desktop.

    When you are done with a Remote Desktop session on WHS, you should always use "Log Off" rather than closing the RD window. By default, Remote Desktop connections to WHS don't time out, and if you simply close the RD window you disconnect from the session but leave it active. Each disconnected but active session uses up a connection, and you can only have two simultaneous connections to the WHS remote desktop. This is a restriction of Remote Desktop For Administration; there is no easy way to change it.

    You may be able to reconnect to one of the active sessions, but there are no guarantees. Failing that, if you have not yet disconnected your keyboard, mouse, and monitor, you can log in to the desktop and use the Terminal Services Manager MMC snap-in to disconnect remote sessions (you can always log in locally). If you've already gone headless, you will probably have to restart WHS using the power or reset button.
    Thursday, March 22, 2007 9:36 PM
    Moderator
  • Thanks a ton for the quick responses...I will try that and see if it clears up the problem...
    Thursday, March 22, 2007 9:41 PM
  • An easier fix would also be just rebooting the Windows Home Server.
    Thursday, March 22, 2007 9:48 PM
    Moderator
  • Yeah, had 2 remote connections that must have locked up....reset them and it works like a charm, thx much guys...
    Thursday, March 22, 2007 10:00 PM
  • I'm new to Windows Server. Any pointers to instructions on setting this up? I'd like to be able to access the WHS console from my XP machine for viewing the event logs, etc.

     

    Thanks

     

    gib

    Thursday, June 21, 2007 10:01 AM