locked
audio & video fails in anonymous LM when web proxy port is above 32768 RRS feed

  • Question

  •  

    Hello,

     

    We discovered a strange behavior with LM that looks like a bug. When a partner joins a meeting in anonmous mode and if he reaches the Internet through a web proxy, A/V doens't work if the web proxy port is above 32768. We tested it with both ISA 2006 and squid proxy servers and the behavior is the same : if the web proxy port is 32767 or less,  A/V works flawlessly , and if it is 32769 or more, A/V fails ! Other LM protocols work fine (SIP, PSOM, HTTPS).

     

    Is it a LM console bug, and A/V edge server bug, or is there some obscure RFC that says a web proxy port should be below 32768 ?

     

    We use OCS 2007 plain RTM and LM console 8.0.6362.91

     

    Thanks in advance for any help

     

    Matthieu

    Tuesday, December 9, 2008 7:33 PM

All replies

  • Matthieu,

     

    I'm bouncing this one off the product team to see if they have any input on it; I have not heard of this before.

     

    Wednesday, December 10, 2008 4:27 PM
    Moderator
  • I just did a small experiment by using a private http proxy (ISA 2006) and set the proxy port to 32780 and A/Vwas working as normal. Let me take it offline and invetigate. We would need traces (network capture) from the site.

    Thx

    Humayun

     

    Wednesday, December 10, 2008 5:36 PM
  •  

    Realized that I do not know the email address of the original author. M. Willm please contact me humkha at microsoft dot com
    Wednesday, December 10, 2008 5:39 PM
  •  

    Hello,

     

    I've done tests with both squid and ISA with the same results. But when you reproduce the problem in a lab, you need to make sure that no direct communication path is possible between your remote LM client and the A/V edge and A/V conference server, otherwise the STUN mechanism will find that direct path and the A/V flow won't actually go through the proxy. An easy way to do this is to put the client behind a firewall (I used Zone Alarm on the client itself) and deny all trafic to and from *all* adresses but the web proxy, and use network monitor to ensure the flow is actually going through the proxy and not through another path (which STUN easily finds in a lab environment ...). Using this configuration, it simulates quite well a remote corporate network on which the only outgoing path is the web proxy. In that case, with proxy ports under 32767 A/V works fine in LM and all trafic goes through the proxy. Above 32768, LM joins the meeting but A/V fails to initialize.

     

    Thanks for your help

     

    Matthieu

    Wednesday, December 10, 2008 7:06 PM
  • Hello again, and thanks for your help

     

    I'll contact you by mail tomorrow from work. My e-mail is matthieu dot willm at dassault-aviation dot com

     

    Matthieu

     

    Wednesday, December 10, 2008 7:08 PM