locked
After WHS RDP session, sound does not play on remote computer RRS feed

  • Question

  • I use remote desktop through Windows Home Server and the .homeserver.com login.  I have a Windows 7 computer that plays music all day, and sometimes the sound file 'gets stuck' and the player needs to be closed.

    I access the computer through WHS from work, fix the problem and exit.  The sound, which begins to play through the RDP connection, never returns to playing through the sound card of the computer.  I have to physically go to the computer and reboot it to have the sound play through it again.

    I know in a regular RDP session, you have the ability to specify that sound stays with the remote console.  And that the WHS RDP offers a checkbox to not send sound through the RDP.  But this seems to be not working regardless of the checkbox.

    Thank you,

    -Larry

    -Larry
    Tuesday, December 15, 2009 2:44 PM

Answers

  • It's likely that the cause of your issue is an interaction between the sound drivers on that computer and the Terminal Services host engine. If you configure your router to forward port 3389 to that computer and connect to it directly (instead of through your server) what happens? The same thing, i.e. the computer stops playing sound locally? That's what I would expect, given what you describe. If the same thing does happen, the next thing to try is connecting to the console session on the remote computer. See e.g. this blog post for more info on that. Probably everything will work normally if you do that...

    It might also be worthwhile to seek assistance from a forum for your client operating system, since you're having a problem with the client. You'll find those on Technet.

    I'm not on the WHS team, I just post a lot. :)
    Monday, January 18, 2010 3:39 PM
    Moderator

All replies

  • I use remote desktop through Windows Home Server and the .homeserver.com login.  I have a Windows 7 computer that plays music all day, and sometimes the sound file 'gets stuck' and the player needs to be closed.

    I access the computer through WHS from work, fix the problem and exit.  The sound, which begins to play through the RDP connection, never returns to playing through the sound card of the computer.  I have to physically go to the computer and reboot it to have the sound play through it again.

    I know in a regular RDP session, you have the ability to specify that sound stays with the remote console.  And that the WHS RDP offers a checkbox to not send sound through the RDP.  But this seems to be not working regardless of the checkbox.

    Thank you,

    -Larry

    -Larry
    Anybody got an idea about this; perhaps a registry setting on the remote computer or a bug in the RDP from WHS?

    -Larry
    Sunday, January 17, 2010 7:17 PM
  • How are you disconnecting from the remote session? Are you logging off the remote computer, or just closing the window?
    I'm not on the WHS team, I just post a lot. :)
    Monday, January 18, 2010 3:28 AM
    Moderator
  • I'm using the log off button.  Remember, I check off "bring sounds to this computer"  and it still brings the sounds to the remote computer and does not reset the sounds on the distant computer.
    -Larry
    Monday, January 18, 2010 2:23 PM
  • It's likely that the cause of your issue is an interaction between the sound drivers on that computer and the Terminal Services host engine. If you configure your router to forward port 3389 to that computer and connect to it directly (instead of through your server) what happens? The same thing, i.e. the computer stops playing sound locally? That's what I would expect, given what you describe. If the same thing does happen, the next thing to try is connecting to the console session on the remote computer. See e.g. this blog post for more info on that. Probably everything will work normally if you do that...

    It might also be worthwhile to seek assistance from a forum for your client operating system, since you're having a problem with the client. You'll find those on Technet.

    I'm not on the WHS team, I just post a lot. :)
    Monday, January 18, 2010 3:39 PM
    Moderator
  • I have used Group Policy on both of the Windows 7 computers that exhibit this problem.  If I RDC through the local network, the sound stays where it is, as I set "Do not bring sound to remote computer" on each computer.  However, when accessing the computer through the homeserver.com remote login, it brings the sound up regardless of the group policy setting.  This is where I thnk the problem is; if the remote https login is a different user, then perhaps the policy doesn't apply.

    I'll check in with Technet.

     

     


    -Larry
    Tuesday, August 24, 2010 1:50 PM