none
Xamarin, .NET Standard and sockets on UWP doesn't work depending on the SDK destination version RRS feed

  • Question

  • I have developed a multiplatform application in Xamarin, that using .NET Standard shared library with sockets to comunícate with a server. The application works correctly in Android, any version, also iOS, but with .NET Standard 2.0 as shared library and UWP destination version 10.0.16299, the socket does not comunícate, always fire a "Timeout". Connection seems to work, but when I try to send or receive data, always timeout. 

    If I change versions, .NET Standard to 1.4 and UWP destination previous to 10.0.16299, without changing any line of code, program works correctly and I can send and receive packets. 

    Anybody knows this issue? Could I resolve it? I have search a lot about it, but I don't find anything related to this problem.

    Thanks in advance

    Ruben

    • Moved by Barry Wang Tuesday, June 12, 2018 3:04 AM
    Monday, June 11, 2018 11:28 AM

All replies

  • Hello Ruben,

    For Xamarin related issue please directly post on Xamarin official forum or stackoverflow with proper tags. MSDN UWP forum is not the right forum for your question.

    Best regards,

    Barry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, June 12, 2018 3:04 AM