locked
Backup not working after upgrading to a new larger HD on client machine RRS feed

  • Question

  • I just upgraded a client PC's HD from 500G to 1T. Everything went fine. The client is running Vista 32.
    However, now WHS will not back up the puter.
    I consistently get an error message:
    "The backup failed because your computer was unable to create a volume snapshot. To resolve this problem, try running chkdsk /f /r on each of your hard drives & restart your computer.'
    Well, I did run chkdsk /f /r from the run command, and in a momentary short flash a DOS box comes & disappears in a fraction of a second.
    I also went to Windows Explorer, right clicked all installed HD's (including new, one at a time) - Tools, Error Checking , check now, and clicked BOTH automatically fix file system errors & scan & attempt recovery of bad sectors (which requires a reboot.)
    Backups were working fine prior to the HD change. Now, can't get WHS to backup this client.
    Wednesday, October 7, 2009 11:26 PM

Answers

  • John:

    To reconfigure the Vista machine's backup parameters, start the WHS Console and go to the Computers & Backup tab. Right-click on the entry for the Vista PC and choose Configure Backup.
    • Marked as answer by johnchrysostom Monday, October 12, 2009 11:40 PM
    Monday, October 12, 2009 12:51 PM

All replies

  • I just upgraded a client PC's HD from 500G to 1T. Everything went fine. The client is running Vista 32.
    However, now WHS will not back up the puter.
    I consistently get an error message:
    "The backup failed because your computer was unable to create a volume snapshot. To resolve this problem, try running chkdsk /f /r on each of your hard drives & restart your computer.'
    Well, I did run chkdsk /f /r from the run command, and in a momentary short flash a DOS box comes & disappears in a fraction of a second.
    I also went to Windows Explorer, right clicked all installed HD's (including new, one at a time) - Tools, Error Checking , check now, and clicked BOTH automatically fix file system errors & scan & attempt recovery of bad sectors (which requires a reboot.)
    Backups were working fine prior to the HD change. Now, can't get WHS to backup this client.
    Did the chkdsk ever actually run?  Based on the way you described, it didn't.  You might need to run as administrator.  Right click on Command Prompt and select Run as Administrator, then run chkdsk /r (and also don't forget to put the drive letter as well).
    Thursday, October 8, 2009 3:44 AM
    Moderator
  • Ok - after having difficulty getting a command prompt with administrator privileges, I was able to get chkdsk to run upon next boot up. Will et you know if this fixed problem!
    Friday, October 9, 2009 1:38 AM
  • Didn't work. I ran Chkdsk /f /r from run command as administrator on a reboot overnight. It is AM. Rebooted server & client, tried to do a manual backup & it failed.
    This seems to have something to do with Volume Services, maybe answer is in somehow turning off VVS and then turning back on? Or by somehow deleting old VVS images & creating a new one?

    Friday, October 9, 2009 2:40 PM
  • John:

    For any partition on the Vista PC that you have configured to be backed up by WHS, VSS needs to have at least 300 MB of free space on the partition. I had this problem on a small boot partition that had insufficient free space for the volume snapshot.
    Friday, October 9, 2009 3:48 PM
  • Didn't work. I ran Chkdsk /f /r from run command as administrator on a reboot overnight. It is AM. Rebooted server & client, tried to do a manual backup & it failed.
    This seems to have something to do with Volume Services, maybe answer is in somehow turning off VVS and then turning back on? Or by somehow deleting old VVS images & creating a new one?

    You could try looking at the event logs and WHS logs for more info on what's going on.  The event logs are in Computer Management (click Start > right click Computer > select Manage > Event Viewer).  The WHS logs on Vista and 7 are at C:\Users\All Users\Microsoft\Windows Home Server\logs.  The WHS logs on XP and WHS are at C:\Documents and Settings\All Users\Application Data\Microsoft\Windows Home Server\logs.
    Friday, October 9, 2009 11:00 PM
    Moderator
  • I just installed a 1T HD which is about 2/3rds empty. I don't think space for snapshot is an issue.
    Is there some way I can delete those snapshots & have it take a new one?
    Friday, October 9, 2009 11:00 PM
  • John:

    First check to see if this is even an issue. From an elevated command prompt (right-click on cmd.exe and choose Run as administrator) on the client Vista PC enter the following command: vssadmin list shadowstorage. You will see a list of the disk volumes that contain shadow copies and their size. If your 1 TB hard disk is the only disk on the Vista PC and this disk has only one partition then I doubt this is the issue.

    To delete existing VSS snapshots you could turn off system restore for the disk. Reboot and then turn it back on. Check the output of the vssadmin command before and after to see the difference.
    Friday, October 9, 2009 11:14 PM
  • This is error message:
    182
        SERVER
    Microsoft.HomeServer.Backup.VSS.ShadowVolumeException: VSS Operation timed out ---> System.TimeoutException: VSS Operation timed out at Microsoft.HomeServer.Backup.VSS.ShadowVolumeSet.Wait(IVssAsync va) at Microsoft.HomeServer.Backup.VSS.ShadowVolumeSet.CreateShadowVolume(VolumeInfo[] volumes) --- End of inner exception stack trace --- at Microsoft.HomeServer.Backup.VSS.ShadowVolumeSet.CreateShadowVolume(VolumeInfo[] volumes) at Microsoft.HomeServer.Backup.VSS.ShadowVolumeSet..ctor(VolumeInfo[] volumes) at Microsoft.HomeServer.Backup.BackupOp.BackupSetOperation.RunWithoutCatch() at Microsoft.HomeServer.Backup.BackupOp.BackupSetOperation.Run()
    Friday, October 9, 2009 11:21 PM
  • I ran command vssadmin list shadowstorage and this was reply:
    Used Shadow copy storage space 64.506 GB
    Allocated Shadow copy storage space 66.673 GB
    Maximum shadow copy storage space 69.864gm

    Friday, October 9, 2009 11:27 PM
  • John:

    There is something slightly odd about your result. By default, Vista reserves 15% of the partition for shadow storage, but your drive has 7.5% reserved. The 69.864 GB of space is 15% of a 500 GB disk, so this leaves me to wonder how you upgraded the disk in this PC from 500 GB to 1 TB. Did you install the new disk and do a clean install of Vista, or did you use imaging or cloning software to clone the smaller drive to the new, larger drive?

    If the latter, perhaps the pointer to the shadow storage area is incorrect. Go to the control panel and open System , then Advanced System Settings then the System Protection tab. Look in the list of available drives that are being protected by System Restore. Do you see any entries that look out of place; perhaps one for the C: partition that is followed by a bunch of question marks or one that is grayed out?

    If so, turn off system restore on the faulty partition and enable it on the real C: partition. Better to do this by first disabling system restore on all partitions and then rebooting so that the system will discard the old restore points. Then enable system restore on the Vista partition.
    Friday, October 9, 2009 11:42 PM
  • I used Paragon Drive Backup 9 pro version:
    http://paragon-software-group.amazonwebstore.com/Paragon-Drive-Backup-9.0-Professional/M/B001G7RTDW.htm?traffic_src=froogle&utm_medium=organic&utm_source=froogle

    I also just noticed in following above that System restore had been somehow (not by me) turned off. I turned it back on. Then tired to haave WHS backup again. Again failed with same error message as in posting #1

    I will try what you say Mark in latest posing. THANKS!
    Saturday, October 10, 2009 12:09 AM
  • Thanks for help Mark - I think we are making progress. But no cigar yet.
    As per above, I discovered System restore was turned off for all 3 drives on system. rebooted
    I turned System Restore on for 2 HD's. (One older PATA drive refused to allow system restore to be resotored. So, I just enabled system restore for 2 good HDs. I might just remove this HD as it does nothing.)
    One I turned them on, I re-ran vssadmin list shadowstorage again.
    New results w/System retore newly turned on & rebooted:
    for volume C (new 1T HD, SATA2)
    Used Shadow Copy storage space 201.438 MB (note the M)
    Allocated shadow copy storage space 3.017GB
    Maximum Shadow Copy Service space 69.864GB

    For Volume G (a 250G SATA1 HD)
    Shadow copy storage space 67.219 MB
    Allocated Shadow copy storage space 1.465GB
    Maximum Shadow Copy Storage space 34.014GM
    Saturday, October 10, 2009 12:43 AM
  • Maybe I need do something to WHS to flush the VSS that it expects to see on the Vista client?
    Saturday, October 10, 2009 12:49 AM
  • John:

    OK; now it looks like you've cleared the older restore points. Next try the following command, again from an elevated command prompt: vssadmin list writers . Look over the list to see if any of the writers have error messages associated with them.

    When you configured the WHS backup for this PC, which drives did you include in the backup? If more than one, try enabling only one at a time to see which drive the VSS error is associated with.
    Saturday, October 10, 2009 12:52 AM
  • I ran vssadmin list writers and no errors were found. I actually ran it several times, no errors.

    Yes, the drives formerly seen by WHS and the current machine have different HD configurations. As per above, VSS was not working properly on an older PATA drive. So I removed this drive. Actualy, there were 4 HD formerly being backed up by WHS from this client. Now there are two.
    Saturday, October 10, 2009 3:10 PM
  • John:

    I'm about out of ideas other than the suggestion in my last post to try configuring WHS backup to do only one volume at a time on the Vista PC to see whether the VSS error is associated with only one of the volumes.
    Saturday, October 10, 2009 3:24 PM
  • Great Idea Mark. The other HD's on the client are just for internal backup purposes, so I do not need them backuped up on my WHS.
    How would I go about reconfiguring WHS so it only backs up the C dive on the client?
    Monday, October 12, 2009 12:27 PM
  • John:

    To reconfigure the Vista machine's backup parameters, start the WHS Console and go to the Computers & Backup tab. Right-click on the entry for the Vista PC and choose Configure Backup.
    • Marked as answer by johnchrysostom Monday, October 12, 2009 11:40 PM
    Monday, October 12, 2009 12:51 PM
  • Thank you Mark & Kari21! After flushing the VSS, I was able to go into the WHS console and then to "Computers & Backup", left click on the troublesome Vista client, and the reconfigure the backup. ANd it ran! Backups working again!
    THANKS 1,000,000!
    Tuesday, October 13, 2009 1:35 AM