locked
Problems with attachments after redeploy in CRM 4.0 RRS feed

  • Question

  • I am running CRM 4.0 we had to upgrade the hardware, so we have installed a new CRM 4.0 enviroment and imported the previous Organization.

    The fact is that the attachments are not working on the new deployment. Every time a try to attach a file it trhows an error and in the Event Viewer I can see an error containing that message "Column 'BlockedAttachmentsForDownload' does not exist on Table 'Deployment'".

    In te previous deploy the attachments are working fine, so it is an error we have added on that procedure.

    Googling a little bit I found that the problem might be fixed reinstalling UR6, but the new deployment doesn´t have any UR installed and the database versio is 4.0.7333.2148. I have found that UR7 4.0.7333.2138 and UR8 is 4.0.7333.2542, so I am in the middle!

    I had a look on the database version of the previous deployment and it has UR7, so I believe it sould not be a problem.

    Any suggestions?

    Regards,

    Sebastian.

     

    Tuesday, August 30, 2011 2:10 PM

All replies

  • It could be that the BlockedAttachmentsForDownload setting to the Deployment properties in the Configuration database (MSCRM_CONFIG) was made in the former instance.

     

    To add the BlockedAttachmentsForDownload setting to the Deployment properties in the Configuration database (MSCRM_CONFIG).  The tool from the Rollup 6 Server version  .

     It was run out of the tools folder.

    In the Tools folder, copy the Microsoft.Crm.DeploymentConfigTool.exe file from the extracted files into the Tools directory on the CRM Server under Program Files, Microsoft crm, Tools. Open a command prompt and change directories to the Tools directory. Then, run the following command at the command prompt

    You may be able to reverse it with the using the DeploymentConfigTool.

    On the clients you may also have a registry setting configured to work along with the server setting. There will be a string value at  HKCU\SOFTWARE\Microsoft\MSCRMClient . The string name was  BlockedAttachmentsForDownload.

     

     

     


    Curtis J Spanburgh
    Tuesday, August 30, 2011 6:23 PM
    Moderator
  • Thanks Curt!

    But I don´t understand wich command do you say I must execute. I believe you havn´t put it.

    I believe your post is comming from that URL: http://support.microsoft.com/default.aspx?scid=kb;EN-US;974597

    I had a look on that link but if I excecute that command:

    Microsoft.Crm.DeploymentConfigTool.exe MiscSettings Update -BlockedAttachmentsForDownload:XML;JS;VBS;JSON;RSS;INI;HTA;HTC;URI;URL;cookie;ASP;ASPX;CSS;DIB;EOT;XHTML;HTM;HTML;MHT;MHTML;CUR;EMF;JFIF;WMF;OSID

    Throws the same message error, it says BlockedAttachmentsForDownload doesn´t exists, is there any way to create instead of Update?

    As you said, if I run the query select * from DeploymentProperties where ColumnName = 'BlockedAttachmentsForDownload' on the server, it doesn´t find any record.

    Regards,

    Sebastian. 

    Tuesday, August 30, 2011 6:45 PM
  • You do run a risk of applying the next role up.

    But there should be some change control logs that show this was done.

    You will note in the partner source post that those command were set to stop certain types of attachments.

    In the deployment table there are only three columns by default unless this one is created by the proceedure, it's not going to find it.

    So it SEEMS that if that column is not there then look at what the registry is saying.

    I would mess with this on a test org and see if I could reverse engineer the config.

     


    Curtis J Spanburgh
    Tuesday, August 30, 2011 7:07 PM
    Moderator
  • So your suggestion is that I should try to install the next rollup to see if it fixes the problem. What I have found is that other people with my problem have tried before but is has never fixed the issue. Anyways I´ll try.

    Regarding to the BlockedAttachmentsForDownload column, it is not present in any of the others CRM 4.0 deployments I have, so I am not sure why it is asking me!

    What do you mean with the registry? Do you think I should check on HKCU\SOFTWARE\Microsoft\MSCRMClient? It is not in the server, I believe is is related to the Outlook Clients.

     

    Unfortunatly I can not create another Test Org because we have a Professional deployment, so I can not have multiple Organizations.

     

    Thank you for your help!

    Sebastian.

    Tuesday, August 30, 2011 7:44 PM
  • I have installe UR8 in both enviroments and imported te organization back and I still have the problem in new one.

    It doesn´t make any sense to install crm again because it is a clean installation!

    The problem is the new installation because if I create a new organization deleteing the imported one there also are problems on the attachments.

     

    Any suggestions?

    Wednesday, August 31, 2011 6:55 PM
  • Joel, dealt with this issue with another Dynamics CRM owner.

    Look at this thread.

    http://social.microsoft.com/Forums/en/crm/thread/f5f57952-a339-4aba-bfad-0f01406c6971

     Also this:

    http://community.dynamics.com/product/crm/f/117/p/23689/38366.aspx

     


    Curtis J Spanburgh
    Wednesday, August 31, 2011 8:49 PM
    Moderator