locked
Help with WHS Remote Access over a Cisco ASA 5505 RRS feed

  • Question

  • Hi I'm trying to get my Cisco router configured properly.  Unfortunately I'm nowhere near the technical level required to understand the Cisco help documents.  Can someone help me?

    I'll go through the list of "Required Questions for Troubleshooting":

    I have WHS with Power Pack 2

    My router is a Cisco ASA 5505, software version 7.2(4), configuring it using ADSM 5.2(4).  This router does not have UPnP.

    I'm on a static IP address and have my modem configured to transparent bridge mode.  (I'm successfully using my ASA to VPN to my work, which is why I have it.)

    I cannot connect to http://myname.homeserver.com from anywhere.  I get "The connection was reset"

    When I do nslookup on myname.homserver.com I get a "Non-authoratative answer" that matches my external IP address.

    Inside my home network, I cannot successfully visit http://<my whs pc name>.  My browser tries for a while and the nredirects to http://www.<my whs pc name>.com and tells me "Server not found".  I can visit http://<my whs internal IP address>, log in and do all the proper stuff.

    I have configured the router to forward ports 80, 443 and 4125 using the instructions here: http://episteme.arstechnica.com/eve/forums/a/tpc/f/469092836/m/416006178831
    and here:
    http://remotesupportsoftware.blogspot.com/2008/10/configure-rdp-port-forwarding-on-cisco.html
    That is:
    - in the NAT page I added a Static NAT Rule for each port number.  Original Interface: inside, Source: WHS IP address. Translated Interface: outside, Use Interface IP Adress.  Enable PAT, Protocol TCP, Original Port 80, Translated Port 80.  Same again for the other ports.
    - in the Security Policy page, I added 3 incoming rules (at least one of which I'm sure is unnessecary):  1) Source: any, Destination: my external IP, Service: tcp/4125, tcp/80, tcp/443, Action: permit.  2) Same but with Destination: my WHS internal IP address.  3) same as 1 but Service: udp/80.

    From a PC on my home network, I can complete the Internet Connectivity Evaluation Tool with the only problem being the lack of UPnP.
    (That's this one: http://www.microsoft.com/windows/using/tools/igd )
    • Edited by Superghengis Thursday, October 22, 2009 12:46 AM made links work
    Thursday, October 22, 2009 12:43 AM

Answers

  • Hi I'm trying to get my Cisco router configured properly.  Unfortunately I'm nowhere near the technical level required to understand the Cisco help documents.  Can someone help me?

    I'll go through the list of "Required Questions for Troubleshooting":

    I have WHS with Power Pack 2

    My router is a Cisco ASA 5505, software version 7.2(4), configuring it using ADSM 5.2(4).  This router does not have UPnP.

    I'm on a static IP address and have my modem configured to transparent bridge mode.  (I'm successfully using my ASA to VPN to my work, which is why I have it.)

    I cannot connect to http://myname.homeserver.com from anywhere.  I get "The connection was reset"

    When I do nslookup on myname.homserver.com I get a "Non-authoratative answer" that matches my external IP address.

    Inside my home network, I cannot successfully visit http://<my whs pc name>.  My browser tries for a while and the nredirects to http://www.<my whs pc name>.com and tells me "Server not found".  I can visit http://<my whs internal IP address>, log in and do all the proper stuff.

    I have configured the router to forward ports 80, 443 and 4125 using the instructions here: http://episteme.arstechnica.com/eve/forums/a/tpc/f/469092836/m/416006178831
    and here:
    http://remotesupportsoftware.blogspot.com/2008/10/configure-rdp-port-forwarding-on-cisco.html
    That is:
    - in the NAT page I added a Static NAT Rule for each port number.  Original Interface: inside, Source: WHS IP address. Translated Interface: outside, Use Interface IP Adress.  Enable PAT, Protocol TCP, Original Port 80, Translated Port 80.  Same again for the other ports.
    - in the Security Policy page, I added 3 incoming rules (at least one of which I'm sure is unnessecary):  1) Source: any, Destination: my external IP, Service: tcp/4125, tcp/80, tcp/443, Action: permit.  2) Same but with Destination: my WHS internal IP address.  3) same as 1 but Service: udp/80.

    From a PC on my home network, I can complete the Internet Connectivity Evaluation Tool with the only problem being the lack of UPnP.
    (That's this one: http://www.microsoft.com/windows/using/tools/igd )

    You should contact Cisco for support (especially since you are apparently forwarding the correct ports to your server and are having problems with their product).
    Thursday, October 22, 2009 1:46 AM
    Moderator

All replies

  • Hi I'm trying to get my Cisco router configured properly.  Unfortunately I'm nowhere near the technical level required to understand the Cisco help documents.  Can someone help me?

    I'll go through the list of "Required Questions for Troubleshooting":

    I have WHS with Power Pack 2

    My router is a Cisco ASA 5505, software version 7.2(4), configuring it using ADSM 5.2(4).  This router does not have UPnP.

    I'm on a static IP address and have my modem configured to transparent bridge mode.  (I'm successfully using my ASA to VPN to my work, which is why I have it.)

    I cannot connect to http://myname.homeserver.com from anywhere.  I get "The connection was reset"

    When I do nslookup on myname.homserver.com I get a "Non-authoratative answer" that matches my external IP address.

    Inside my home network, I cannot successfully visit http://<my whs pc name>.  My browser tries for a while and the nredirects to http://www.<my whs pc name>.com and tells me "Server not found".  I can visit http://<my whs internal IP address>, log in and do all the proper stuff.

    I have configured the router to forward ports 80, 443 and 4125 using the instructions here: http://episteme.arstechnica.com/eve/forums/a/tpc/f/469092836/m/416006178831
    and here:
    http://remotesupportsoftware.blogspot.com/2008/10/configure-rdp-port-forwarding-on-cisco.html
    That is:
    - in the NAT page I added a Static NAT Rule for each port number.  Original Interface: inside, Source: WHS IP address. Translated Interface: outside, Use Interface IP Adress.  Enable PAT, Protocol TCP, Original Port 80, Translated Port 80.  Same again for the other ports.
    - in the Security Policy page, I added 3 incoming rules (at least one of which I'm sure is unnessecary):  1) Source: any, Destination: my external IP, Service: tcp/4125, tcp/80, tcp/443, Action: permit.  2) Same but with Destination: my WHS internal IP address.  3) same as 1 but Service: udp/80.

    From a PC on my home network, I can complete the Internet Connectivity Evaluation Tool with the only problem being the lack of UPnP.
    (That's this one: http://www.microsoft.com/windows/using/tools/igd )

    You should contact Cisco for support (especially since you are apparently forwarding the correct ports to your server and are having problems with their product).
    Thursday, October 22, 2009 1:46 AM
    Moderator
  • I don't know if this has been solved, but you may be better off setting your ASA up with VPN.
    Wednesday, December 30, 2009 5:43 PM