none
Works poorly with built-in driver for Realtek RTL8169 chip RRS feed

  • Question

  • Am using an Aus A7N8X motherboard with 512K of RAM and Athlon XP 2500

    Installation overall went smooth enough, but drivers are an issue here - doesnt pick up most of the NForce components
    Anyway board has built-in 3Comand Nvidia 100MBit NIC controllers
    So, before I started, I also added in a generic Gbit card with RTL8169 chipset - the MHS installation routine picked up this one, and assigned it a driver

    Then set everythtng up includingthe network at home, but the performance of the built-in driver for the 8169 chip was pathetic

    I was watching thru-put with DUMeter, and I tried to play 3 files remotely on a Athlon X2 5200 machine

    A H264 High def file (needs to run at 4.8mB/sec) - started above this but within 2 sec, slowed down to unmeasurable on DUMeter, obviously video froze
    A MPEG2 transport stream  High def file (needs to run at 3.6mB/sec) - started above this but within 3 sec, slowed down to unmeasurable on DUMeter, obviously video froze
    A mkv h264 file (needs to run at 0.8mB/sec) - started above this but within 4 sec, slowed down to unmeasurableon DUMeter, obviously video froze

    All of this was fixed by upgrading to the latest RTL8169 driver (for XP) on the Realtek site - the files "5663_20070117"

    Any others finding similar issues?

    Note that when I used the 100MBit built in NIC's, they both used fine (played High Def video fine) , altho neither installed with the MHS install disk, I had to use other XP drivers
    the 4.7.1.0 drivers for the NForce
    the 4.31.0.0 for the 3Com 3C920B-EMB



    Monday, February 19, 2007 7:43 AM

Answers

All replies

  • Seems to be an intermittent problem - while what is above is true, when I rolled the Realtek 8169 driver back to the MHS version, it actually worked fine for a while
    Then I tried some of the HD material about a hour later - same problem with frozen video, and a network transfer rate that fades to zero very quickly

    No idea why this is - didnt change any other variables
    Monday, February 19, 2007 8:39 AM
  • Please do a bug report for us!

    http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=1234839&SiteID=50

    Also, are you sure non of the hardware is faulty? (Powersupply, Network Interface Card, etc...)

    Monday, February 19, 2007 5:47 PM
    Moderator
  • Yes - I've also experienced very poor performance with a Realtek RTL-8169 based card when using the drivers off the install DVD.

    My initial install was done with an SMC based 10/100 card and I saw 60 mbp/s transfers with that card, switching to the Realtek card gave similar numbers on a 100 m connection, but a disappointing 24 mbp/s throughput when on GBe - switching to the drivers that shipped with the card moved the GBe perfomance up to approximately 95 mbp/s, nothing to get excited about, but, on par with the other gigabit card I had tried, an Intel PRO1000, so I think I'm possibly hitting the limits of the hardware platform, which is an older Compaq Deskpro with an 866 MHz PIII.

    Sunday, March 25, 2007 4:06 PM
  • Conratulations to all who got NICs working, I have not been able to get the Realtek 8169 based internal to work, nor an SIS based card (Airlink gigabit), nor a Dlink DGE-530T. All have worked with XP and I have used the latest drivers from the mfgs as well as the drivers that came with the cards.

     

    The Dlink card is not even rcognized, but the others are. The device manager says the Airlink is working normally -- but no connection. The Realtek says the driver is not installed properly. Only one at a time.

     

    Any sugestions would be appreciated. Thanks.

     

    Ray

    Saturday, March 31, 2007 1:39 AM
  • The problem that we are seeing is due to nVidia having never produced drivers for the nforce1 chipset for windows server 2003, as such there is little to no support for the motherboards and the networking devices. In my case installing WHS on a nforce1 motherboard resulted in the networking being completely unusable until I purchased a dlink pci networking card that supported windows server 2003. The best course of action is to ensure your hardware supports windows 2003, before trying to install WHS on it.

    Feedback has already been posted for this issue 264047 and as one would expect this is a hardware vendor issue, rather than a Microsoft software issue. I know it is not the answer many of you want to hear, but there it is.

    Saturday, March 31, 2007 6:01 AM
  • That's an interesting answer, but unlikely to be the cause of the problem in my case - since, there is no nVidia hardware whatsoever in my WHS box.

     

    Intel PIII processor, Intel chipset, Intel integrated graphics and three PCI cards - Silicon Image SATA controller, VIA USB2.0 & Realtek ethernet

    Saturday, March 31, 2007 3:40 PM