locked
WHS reinstall hangs at 'Connecting to Storage Manager Service' RRS feed

  • Question

  • I've seen a few posts about this but no resolutions. I had to reinstall WHS after my primary hard drive failed. I put in a replacement drive and chose the 'restore' option for WHS. Everything went swimingly until I got to the screen showing 'connecting to storage manager service'. At this point, the process hangs. I notice that the qsm.exe process is running and when I go to Windows Explorer, the D: drive keeps flickering and I can't access it, which is where the shares appear.

    I tried following the suggestions of another poster and deleted the partitions on the failed primary drive. This helped me get to the point of having the WHS installer prompting me to do a restore.

    I'm dying here. I've got 3 years of critical data on my WHS and I'm desperate to recover it. Any suggestions out there? Has anyone experienced this and managed to recover from it?

    Some more info:

    * I have 3 drives in the machine, all SATA. One of the drives is connected to a Silicon Image based PCI SATA RAID controller. I installed the drivers for it early in the install process and the drive is recognised by WHS. I did have an error where it needed the drivers again after being prompted that 'restoring the archiver data' was failing. I went into devices and updated the driver for the RAID controller and it continued on its merry way until it got to this latest screen.

    * I've tried installing two versions (one from my original WHS disk and a newer downloaded disk) and I get exactly the same error.

    * The machine is my own home brew using a purchased OEM version of WHS. It has been working fine for 2 years.

    HEEELP! I'm really desperate.

    Monday, March 29, 2010 11:30 PM

All replies

  • Ok, I gave up trying to fix it. I moved over to a recently decommissioned motherboard to try and preclude the possibility of any other hardware issues. This time no additional SATA RAID controller or anything except a graphics card. I got to the same point and it failed again. This time I installed all the motherboard drivers and miraculously, it kept going. This time instead it got as far as trying to install Windows Home Server and again failed but this time, according to the log, it had an error of 'cannot create operation to rebuild primary'. WTF? I just can't seem to win a trick with my WHS. I'm going to create a separate post for this new error. Otherwise, consider this thread closed without resolution.

    • Edited by BigRizz Tuesday, March 30, 2010 10:11 AM added more detail
    Tuesday, March 30, 2010 10:10 AM