locked
ip address change on WHS RRS feed

  • Question

  • For the third time now since install whs has a different ip address. This causes a yellow network alert screen stating that there is a problem with port forwarding and that whs may not be available via the internet. Because another device on the network has grabbed whs's old ip address I have tried ipconfig /release and ipconfig /renew and it keeps giving me the same ip address that ends in .101 instead of the .100 I need. Ultimately I simply went back into the router and changed the port forwarding address to .101 and everything is green now. Is the final solution to assign whs a static ip address so that this does not happen in the future?
    Wednesday, July 4, 2007 8:10 AM

Answers

  • Kaisat, you have a couple of choices. First, you can set your WHS to a static IP address, as you suggest you might do. That will obviously fix your problem, though you'll have to do some additional manual configuration of DNS information.

    Or, if your broadband router supports it, you can use what's referred to as "static DHCP", where you use a configuration option in the router to lock a particular DHCP IP address to a particular MAC address. That would be my preferred solution, because you won't need any manual configuration of the server in that case. It'll pick up DNS info directly from the router.
    Wednesday, July 4, 2007 2:10 PM
    Moderator

All replies

  • I suspect the most probable solution is that UPnP will be used to configure the router automatically, which should update the changes straight away - either that or manually using the Unconfigure / Configure buttons.

     

    However, I'm not sure that this is going to be a problem.  The HS is intended to be left on 24/7, so should in theory never lose the IP address it was initially assigned.  In fact, unless you're running low on DHCP addresses and the server is left off for longer than the lease expiry time, you should never have this issue.  I'd go as far as to say that in any home environment, the DHCP pool is normally way in excess of the actual number of devices that use it.

     

    There are two options you could undertake to fix this, though:

    1. If your router can do it, tell it to reserve the IP address for your server within DHCP.  This means grabbing the MAC address for the network card, but this is dead easy to get at by typing IPCONFIG /ALL at a command prompt.
    2. If the router doesn't support this (and I'll admit not all do) then choose an IP address within your subnet which isn't in the DHCP scope and tell the server to use a static address.  You'll need to make sure you have the gateway, subnet mask and DNS in there as well, but as before the IPCONFIG /ALL will give you this, provided you do it before you change the settings.

    I've gone with the first option - it's saved me a bit of time with the rebuilding to the new HS version and I don't have to concern myself with changing the port forwarding settings.  My router does have UPnP, allegedly, but it's very hit and miss.

    Wednesday, July 4, 2007 11:38 AM
  • Short answer, yes.  I've had mine that way since first install and I've had no probs like drifting ports and stuff like that.  I recommend it.
    Wednesday, July 4, 2007 1:00 PM
  • Kaisat, you have a couple of choices. First, you can set your WHS to a static IP address, as you suggest you might do. That will obviously fix your problem, though you'll have to do some additional manual configuration of DNS information.

    Or, if your broadband router supports it, you can use what's referred to as "static DHCP", where you use a configuration option in the router to lock a particular DHCP IP address to a particular MAC address. That would be my preferred solution, because you won't need any manual configuration of the server in that case. It'll pick up DNS info directly from the router.
    Wednesday, July 4, 2007 2:10 PM
    Moderator